summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-09-09 20:28:54 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-09-09 20:28:54 +0000
commite007c40db0d69f738e701ea5deb53525e5966729 (patch)
tree58eb482e4d7e04cf381d2f7f18e8999824a13bf1 /app-sci/ginac/ginac-1.1.3.ebuild
parentUpdate manifest (diff)
downloadgentoo-2-e007c40db0d69f738e701ea5deb53525e5966729.tar.gz
gentoo-2-e007c40db0d69f738e701ea5deb53525e5966729.tar.bz2
gentoo-2-e007c40db0d69f738e701ea5deb53525e5966729.zip
new version
Diffstat (limited to 'app-sci/ginac/ginac-1.1.3.ebuild')
-rw-r--r--app-sci/ginac/ginac-1.1.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-sci/ginac/ginac-1.1.3.ebuild b/app-sci/ginac/ginac-1.1.3.ebuild
new file mode 100644
index 000000000000..143fd24ce676
--- /dev/null
+++ b/app-sci/ginac/ginac-1.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ginac/ginac-1.1.3.ebuild,v 1.1 2003/09/09 20:28:47 george Exp $
+
+IUSE=""
+
+inherit flag-o-matic
+
+Name="GiNaC"
+S=${WORKDIR}/${Name}-${PV}
+
+DESCRIPTION="GiNaC : a free CAS (computer algebra system)"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/${Name}-${PV}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc"
+
+DEPEND="dev-libs/cln"
+
+src_compile() {
+ filter-flags "-funroll-loops -frerun-loop-opt"
+ econf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}