summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-02-27 10:23:31 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-02-27 10:23:31 +0000
commit50dfd79d6a5d944d8637aea364189fdd6dd9779f (patch)
tree56dc5b46fc8e38d848423f5a2424b1b05075b6c7 /app-sci/foldingathome
parentCloses #15657. (diff)
downloadgentoo-2-50dfd79d6a5d944d8637aea364189fdd6dd9779f.tar.gz
gentoo-2-50dfd79d6a5d944d8637aea364189fdd6dd9779f.tar.bz2
gentoo-2-50dfd79d6a5d944d8637aea364189fdd6dd9779f.zip
Version bump and closing of #12950.
Diffstat (limited to 'app-sci/foldingathome')
-rw-r--r--app-sci/foldingathome/ChangeLog10
-rw-r--r--app-sci/foldingathome/files/digest-foldingathome-3.241
-rw-r--r--app-sci/foldingathome/files/folding-init.d5
-rw-r--r--app-sci/foldingathome/foldingathome-3.24.ebuild40
4 files changed, 54 insertions, 2 deletions
diff --git a/app-sci/foldingathome/ChangeLog b/app-sci/foldingathome/ChangeLog
index 18d00edad06b..e23c0d7d7713 100644
--- a/app-sci/foldingathome/ChangeLog
+++ b/app-sci/foldingathome/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for app-sci/foldingathome
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/ChangeLog,v 1.2 2003/02/12 05:15:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/ChangeLog,v 1.3 2003/02/27 10:23:31 aliz Exp $
+*foldingathome-3.24 (27 Feb 2003)
+
+ 27 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> foldingathome-3.24.ebuild :
+ Version bump.
+
+ 27 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> files/folding-init.d :
+ Start the daemon with nice, closes #12950.
+
*foldingathome-3.14 (04 Nov 2002)
04 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
diff --git a/app-sci/foldingathome/files/digest-foldingathome-3.24 b/app-sci/foldingathome/files/digest-foldingathome-3.24
new file mode 100644
index 000000000000..bb487acf3884
--- /dev/null
+++ b/app-sci/foldingathome/files/digest-foldingathome-3.24
@@ -0,0 +1 @@
+MD5 df9c2a68e5a2b808daee0128d78ecde3 FAH3Console-Linux.exe 613632
diff --git a/app-sci/foldingathome/files/folding-init.d b/app-sci/foldingathome/files/folding-init.d
index 2a6dc5b3898e..f4dbefa1e15c 100644
--- a/app-sci/foldingathome/files/folding-init.d
+++ b/app-sci/foldingathome/files/folding-init.d
@@ -1,10 +1,13 @@
#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/files/folding-init.d,v 1.2 2003/02/27 10:23:31 aliz Exp $
start() {
ebegin "Starting Folding@home"
cd /opt/foldingathome
- ./foldingathome >&/dev/null&
+ nice -n 19 ./foldingathome >&/dev/null&
eend $?
}
diff --git a/app-sci/foldingathome/foldingathome-3.24.ebuild b/app-sci/foldingathome/foldingathome-3.24.ebuild
new file mode 100644
index 000000000000..4e6bd86af48a
--- /dev/null
+++ b/app-sci/foldingathome/foldingathome-3.24.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/foldingathome-3.24.ebuild,v 1.1 2003/02/27 10:23:31 aliz Exp $
+
+# no version number on this install dir since upgrades will be using same dir
+# (data will be stored here too)
+I="/opt/foldingathome"
+
+DESCRIPTION="Help simulate protein folding at home"
+HOMEPAGE="http://folding.stanford.edu/"
+SRC_URI="http://www.stanford.edu/group/pandegroup/release/FAH3Console-Linux.exe"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/baselayout-1.8.0"
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ mkdir ${P}
+ cp ${DISTDIR}/FAH3Console-Linux.exe ${P}
+}
+
+src_install() {
+ exeinto ${I} ; newexe FAH3Console-Linux.exe foldingathome
+ exeinto /etc/init.d ; newexe ${FILESDIR}/folding-init.d foldingathome
+}
+
+pkg_postinst() {
+ einfo "To run Folding@home in the background at boot:"
+ einfo " rc-update add foldingathome default"
+ einfo ""
+}
+
+pkg_postrm() {
+ einfo "Folding@home data files were not removed."
+ einfo " Remove them manually from ${I}"
+ einfo ""
+}