summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2011-02-14 22:27:08 +0000
committerDaniel Pielmeier <billie@gentoo.org>2011-02-14 22:27:08 +0000
commit8f31f717785749512d0bc8fb4ff9a99d6761b817 (patch)
treec4db63cec43c3ea14aeb09946d92630516b0e82f /app-portage
parentsys-power/suspend: Fix compilation for USE=crypt (diff)
downloadgentoo-2-8f31f717785749512d0bc8fb4ff9a99d6761b817.tar.gz
gentoo-2-8f31f717785749512d0bc8fb4ff9a99d6761b817.tar.bz2
gentoo-2-8f31f717785749512d0bc8fb4ff9a99d6761b817.zip
Revision bump. Small update to the e-file script.
(Portage version: 2.1.9.35/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pfl/ChangeLog7
-rw-r--r--app-portage/pfl/pfl-2.1-r1.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/app-portage/pfl/ChangeLog b/app-portage/pfl/ChangeLog
index 7e87a0dd6b18..16f36e80187a 100644
--- a/app-portage/pfl/ChangeLog
+++ b/app-portage/pfl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/pfl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.21 2011/02/13 20:00:38 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.22 2011/02/14 22:27:08 billie Exp $
+
+*pfl-2.1-r1 (14 Feb 2011)
+
+ 14 Feb 2011; Daniel Pielmeier <billie@gentoo.org> +pfl-2.1-r1.ebuild:
+ Revision bump. Small update to the e-file script.
13 Feb 2011; Daniel Pielmeier <billie@gentoo.org> -pfl-2.0.ebuild:
Remove old.
diff --git a/app-portage/pfl/pfl-2.1-r1.ebuild b/app-portage/pfl/pfl-2.1-r1.ebuild
new file mode 100644
index 000000000000..539803acd0e2
--- /dev/null
+++ b/app-portage/pfl/pfl-2.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/pfl-2.1-r1.ebuild,v 1.1 2011/02/14 22:27:08 billie Exp $
+
+EAPI=3
+
+PYTHON_DEPEND=2
+
+inherit python
+
+MY_PV=20110209
+
+DESCRIPTION="PFL is an online searchable file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de/index.php/Special:PFLQuery2"
+SRC_URI="http://files.portagefilelist.de/${P}
+ http://linuxfire.com.cn/~lily/e-file-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE="network-cron"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/pyxml
+ net-misc/curl
+ sys-apps/portage"
+
+RESTRICT="mirror"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_unpack() {
+ cp "${DISTDIR}/${P}" "${WORKDIR}/${PN}.py"
+ cp "${DISTDIR}/e-file-${MY_PV}" "${WORKDIR}/e-file"
+}
+
+src_install() {
+ if use network-cron ; then
+ cat >> "${T}/${PN}" <<- EOF
+ #!/bin/sh
+ exec nice $(PYTHON) -O $(python_get_sitedir)/${PN}/${PN}.py >/dev/null
+ EOF
+
+ exeinto /etc/cron.weekly
+ doexe "${T}/${PN}" || die
+ fi
+
+ exeinto $(python_get_sitedir)/${PN}
+ doexe ${PN}.py || die
+
+ dobin e-file || die
+
+ dodir /var/lib/${PN} || die
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+
+ if [[ ! -e "${ROOT%/}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${ROOT%/}/var/lib/${PN}/pfl.info"
+ chown -R 0:portage "${ROOT%/}/var/lib/${PN}"
+ chmod 775 "${ROOT%/}/var/lib/${PN}"
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}