summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2006-01-04 06:40:23 +0000
committerHarald van Dijk <truedfx@gentoo.org>2006-01-04 06:40:23 +0000
commit8381ed15c77fb9de3e6b3939012252aa4540be56 (patch)
tree1a49b81eaed79e6d5234126579d8d5fd5910a0ff /app-portage
parentfix broken SRC_URI mirror:// syntax (diff)
downloadgentoo-2-8381ed15c77fb9de3e6b3939012252aa4540be56.tar.gz
gentoo-2-8381ed15c77fb9de3e6b3939012252aa4540be56.tar.bz2
gentoo-2-8381ed15c77fb9de3e6b3939012252aa4540be56.zip
Version bump
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/cfg-update/ChangeLog10
-rw-r--r--app-portage/cfg-update/Manifest8
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.0-r1.ebuild50
-rw-r--r--app-portage/cfg-update/files/digest-cfg-update-1.8.0-r11
4 files changed, 64 insertions, 5 deletions
diff --git a/app-portage/cfg-update/ChangeLog b/app-portage/cfg-update/ChangeLog
index 7685f8fb4a5f..ac33f7bc4b75 100644
--- a/app-portage/cfg-update/ChangeLog
+++ b/app-portage/cfg-update/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/cfg-update
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/ChangeLog,v 1.4 2005/09/08 06:12:02 truedfx Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/ChangeLog,v 1.5 2006/01/04 06:40:23 truedfx Exp $
+
+*cfg-update-1.8.0-r1 (04 Jan 2006)
+
+ 04 Jan 2006; Harald van Dijk <truedfx@gentoo.org>
+ +cfg-update-1.8.0-r1.ebuild:
+ Version bump
*cfg-update-1.7.2 (08 Sep 2005)
diff --git a/app-portage/cfg-update/Manifest b/app-portage/cfg-update/Manifest
index 374aa7b00fda..f43335a17dd0 100644
--- a/app-portage/cfg-update/Manifest
+++ b/app-portage/cfg-update/Manifest
@@ -4,11 +4,13 @@ Hash: SHA1
MD5 a10aea2d90932c4309817a21ae39d426 ChangeLog 771
MD5 d2f99257546fd32545332a3cce582cd9 metadata.xml 229
MD5 39d10b172c94673d21e05fddafabe09b cfg-update-1.7.2.ebuild 1782
+MD5 8b1a6a05eaa4e310e07622ee25835a65 cfg-update-1.8.0-r1.ebuild 1636
MD5 6178c171993eae0f345538f32ac0f42c files/digest-cfg-update-1.7.2 67
+MD5 22598eb9a77fa1e1cd97f796acff0b7f files/digest-cfg-update-1.8.0-r1 70
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDH9YWwnQyISwouHwRAqfMAKCWI9XogWADsmJhQGbCJBnsb5iWhQCbByul
-1d0rMD8tVs3FSMXdpt0cz0k=
-=tDx/
+iD8DBQFDu20rwnQyISwouHwRAv9SAKC/lbc4ZAIP628hFO3SUhQh4BpL5QCgp7iO
+Le2fzgIuPdefQ1X+64Y+EGQ=
+=1Wi8
-----END PGP SIGNATURE-----
diff --git a/app-portage/cfg-update/cfg-update-1.8.0-r1.ebuild b/app-portage/cfg-update/cfg-update-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..76a1f45f9fa5
--- /dev/null
+++ b/app-portage/cfg-update/cfg-update-1.8.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/cfg-update-1.8.0-r1.ebuild,v 1.1 2006/01/04 06:40:23 truedfx Exp $
+
+DESCRIPTION="Easy to use GUI & CLI alternative for etc-update with safe automatic updating functionality"
+HOMEPAGE="http://people.zeelandnet.nl/xentric/"
+SRC_URI="http://people.zeelandnet.nl/xentric/${PF}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="kde gnome"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="kde? (
+ >=x11-misc/sux-1.0
+ || ( >=dev-util/xxdiff-2.9
+ >=kde-misc/kdiff3-0.9 ) )
+ gnome? (
+ >=x11-misc/sux-1.0
+ >=dev-util/meld-0.9 )"
+
+S=${WORKDIR}/${PF}
+
+pkg_postrm() {
+ ewarn
+ ewarn "You should manually disable the alias for emerge in /root/.bash_profile"
+ ewarn "and remove the index file /usr/lib/cfg-update/checksum-index"
+ ewarn "if you want to permanently remove cfg-update from your system."
+ ewarn
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe cfg-update emerge_with_indexing_for_cfg-update emerge_with_indexing_for_cfg-update_phphelper cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
+ insinto /usr/lib/cfg-update
+ doins .bashrc .bash_profile .Xdefaults ChangeLog cfg-update
+ doman *.8
+ insinto /etc
+ doins cfg-update.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Converting old backups to new filename format..."
+ cfg-update --convert-old-backups &>/dev/null
+ einfo "Trying to remove old emerge alias from /etc/profile..."
+ cfg-update --remove-old-alias &>/dev/null
+ ewarn "Please read the installation instructions on http://people.zeelandnet.nl/xentric"
+ ewarn "You need to run cfg-update --on (possibly followed by cfg-update --fix)"
+ ewarn "and cfg-update --index after installation!"
+ ewarn
+}
diff --git a/app-portage/cfg-update/files/digest-cfg-update-1.8.0-r1 b/app-portage/cfg-update/files/digest-cfg-update-1.8.0-r1
new file mode 100644
index 000000000000..4d16219ea7f6
--- /dev/null
+++ b/app-portage/cfg-update/files/digest-cfg-update-1.8.0-r1
@@ -0,0 +1 @@
+MD5 d26b5e9c69a22ef2a0c0dbfedb6397f9 cfg-update-1.8.0-r1.tar.gz 34404