summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-05-26 10:15:09 +0000
committerMichał Górny <mgorny@gentoo.org>2012-05-26 10:15:09 +0000
commit34ada68e5f2aa105f4b4cd9b8168e340eed6f66b (patch)
treec294dcc3bbeea8ce236185eb486097b70cfcfbb2 /app-portage
parentarm stable, bug #384483 (diff)
downloadgentoo-2-34ada68e5f2aa105f4b4cd9b8168e340eed6f66b.tar.gz
gentoo-2-34ada68e5f2aa105f4b4cd9b8168e340eed6f66b.tar.bz2
gentoo-2-34ada68e5f2aa105f4b4cd9b8168e340eed6f66b.zip
Use python-distutils-ng. Re-enable Python 3 support.
(Portage version: 2.2.0_alpha107_p2/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/ChangeLog8
-rw-r--r--app-portage/smart-live-rebuild/metadata.xml2
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.2.3-r1.ebuild37
3 files changed, 45 insertions, 2 deletions
diff --git a/app-portage/smart-live-rebuild/ChangeLog b/app-portage/smart-live-rebuild/ChangeLog
index 808540fec880..8223f65bf120 100644
--- a/app-portage/smart-live-rebuild/ChangeLog
+++ b/app-portage/smart-live-rebuild/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/smart-live-rebuild
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.37 2012/04/17 16:07:52 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.38 2012/05/26 10:15:09 mgorny Exp $
+
+*smart-live-rebuild-1.2.3-r1 (26 May 2012)
+
+ 26 May 2012; Michał Górny <mgorny@gentoo.org>
+ +smart-live-rebuild-1.2.3-r1.ebuild, metadata.xml:
+ Use python-distutils-ng. Re-enable Python 3 support.
*smart-live-rebuild-1.2.3 (17 Apr 2012)
diff --git a/app-portage/smart-live-rebuild/metadata.xml b/app-portage/smart-live-rebuild/metadata.xml
index 83d42c6efb5c..41f3e5db150b 100644
--- a/app-portage/smart-live-rebuild/metadata.xml
+++ b/app-portage/smart-live-rebuild/metadata.xml
@@ -16,6 +16,6 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>https://github.com/mgorny/smart-live-rebuild/issues/</bugs-to>
+ <bugs-to>https://bitbucket.org/mgorny/smart-live-rebuild/issues/</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.3-r1.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..21257f73d54e
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.3-r1.ebuild,v 1.1 2012/05/26 10:15:09 mgorny Exp $
+
+EAPI=4
+
+PYTHON_COMPAT='python2_6 python2_7 python3_1 python3_2'
+
+inherit base python-distutils-ng
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://bitbucket.org/mgorny/smart-live-rebuild/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[python_targets_python2_6?,python_targets_python2_7?,python_targets_python3_1?,python_targets_python3_2?]"
+
+python_prepare_all() {
+ base_src_prepare
+}
+
+python_test() {
+ "${PYTHON}" setup.py test || die
+}
+
+python_install_all() {
+ dodoc README
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example ${PN}.conf
+}