summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-29 08:11:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-29 08:11:21 +0000
commitc50a624a5048a23945c5daa44c464e1805d2e1d7 (patch)
treef9c25c4b8d5809b7543e3b94329a92e918975649 /app-pda
parentUpdate to EAPI 2 and use slot dep for gtk+. (diff)
downloadgentoo-2-c50a624a5048a23945c5daa44c464e1805d2e1d7.tar.gz
gentoo-2-c50a624a5048a23945c5daa44c464e1805d2e1d7.tar.bz2
gentoo-2-c50a624a5048a23945c5daa44c464e1805d2e1d7.zip
Initial commit wrt #348529 by "nando.sm".
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/ideviceinstaller/ChangeLog10
-rw-r--r--app-pda/ideviceinstaller/files/ideviceinstaller-1.0.0-libgen_h.patch20
-rw-r--r--app-pda/ideviceinstaller/ideviceinstaller-1.0.0.ebuild26
-rw-r--r--app-pda/ideviceinstaller/metadata.xml5
4 files changed, 61 insertions, 0 deletions
diff --git a/app-pda/ideviceinstaller/ChangeLog b/app-pda/ideviceinstaller/ChangeLog
new file mode 100644
index 000000000000..555635572a0b
--- /dev/null
+++ b/app-pda/ideviceinstaller/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-pda/ideviceinstaller
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/ideviceinstaller/ChangeLog,v 1.1 2011/03/29 08:11:21 ssuominen Exp $
+
+*ideviceinstaller-1.0.0 (29 Mar 2011)
+
+ 29 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +ideviceinstaller-1.0.0.ebuild, +files/ideviceinstaller-1.0.0-libgen_h.patch:
+ Initial commit wrt #348529 by "nando.sm".
+
diff --git a/app-pda/ideviceinstaller/files/ideviceinstaller-1.0.0-libgen_h.patch b/app-pda/ideviceinstaller/files/ideviceinstaller-1.0.0-libgen_h.patch
new file mode 100644
index 000000000000..b7c8be7a7932
--- /dev/null
+++ b/app-pda/ideviceinstaller/files/ideviceinstaller-1.0.0-libgen_h.patch
@@ -0,0 +1,20 @@
+From ecb942b024de4038ff98cbaa3ca2e209b1da290c Mon Sep 17 00:00:00 2001
+From: Martin Szulecki
+Date: Sat, 26 Mar 2011 10:19:04 +0000
+Subject: Add missing libgen.h include to make compilers happy
+
+---
+diff --git a/src/ideviceinstaller.c b/src/ideviceinstaller.c
+index d8c68ba..365da0b 100644
+--- a/src/ideviceinstaller.c
++++ b/src/ideviceinstaller.c
+@@ -31,6 +31,7 @@
+ #include <getopt.h>
+ #include <errno.h>
+ #include <time.h>
++#include <libgen.h>
+
+ #include <libimobiledevice/libimobiledevice.h>
+ #include <libimobiledevice/lockdown.h>
+--
+cgit v0.8.3.1-34-gbf3d
diff --git a/app-pda/ideviceinstaller/ideviceinstaller-1.0.0.ebuild b/app-pda/ideviceinstaller/ideviceinstaller-1.0.0.ebuild
new file mode 100644
index 000000000000..c1671c8c76de
--- /dev/null
+++ b/app-pda/ideviceinstaller/ideviceinstaller-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/ideviceinstaller/ideviceinstaller-1.0.0.ebuild,v 1.1 2011/03/29 08:11:21 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A tool to interact with the installation_proxy of an Apple's iDevice"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-pda/libimobiledevice-1.0.0
+ >=app-pda/libplist-0.15
+ >=dev-libs/libzip-0.8"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libgen_h.patch
+ sed -i -e 's:-Werror -g::' configure || die
+}
diff --git a/app-pda/ideviceinstaller/metadata.xml b/app-pda/ideviceinstaller/metadata.xml
new file mode 100644
index 000000000000..228404d3a4b2
--- /dev/null
+++ b/app-pda/ideviceinstaller/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pda</herd>
+</pkgmetadata>