summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-29 01:44:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-29 01:44:24 +0000
commit339bb3b4206859d4704932b614b8d28d9f652c19 (patch)
tree5cd9fb89c129ccf4d3f96373dfa4f9453d7e68d2 /app-pda
parentVersion bump. (diff)
downloadgentoo-2-339bb3b4206859d4704932b614b8d28d9f652c19.tar.gz
gentoo-2-339bb3b4206859d4704932b614b8d28d9f652c19.tar.bz2
gentoo-2-339bb3b4206859d4704932b614b8d28d9f652c19.zip
Remove broken Python and SWIG support wrt #361029.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libimobiledevice/ChangeLog6
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.0.4.ebuild32
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild20
3 files changed, 11 insertions, 47 deletions
diff --git a/app-pda/libimobiledevice/ChangeLog b/app-pda/libimobiledevice/ChangeLog
index 8a133dee1ea1..605a3a46c88e 100644
--- a/app-pda/libimobiledevice/ChangeLog
+++ b/app-pda/libimobiledevice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/libimobiledevice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.12 2011/03/29 01:06:38 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.13 2011/03/29 01:44:24 ssuominen Exp $
+
+ 29 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ libimobiledevice-1.0.6.ebuild:
+ Remove broken Python and SWIG support wrt #361029.
*libimobiledevice-1.0.6 (29 Mar 2011)
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.0.4.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.0.4.ebuild
deleted file mode 100644
index 1576921a27ba..000000000000
--- a/app-pda/libimobiledevice/libimobiledevice-1.0.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.0.4.ebuild,v 1.1 2010/11/30 11:01:59 bangert Exp $
-
-EAPI=3
-
-DESCRIPTION="Support library to communicate with Apple iPhone/iPod Touch devices"
-HOMEPAGE="http://www.libimobiledevice.org/"
-SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="python"
-
-DEPEND="dev-util/pkgconfig
- ${RDEPEND}"
-RDEPEND=">=app-pda/libplist-1.3
- >=app-pda/usbmuxd-1.0.3
- >=dev-libs/glib-2.14.1
- dev-libs/libgcrypt
- net-libs/gnutls
- sys-fs/fuse
- virtual/libusb:1"
-
-src_configure() {
- econf $(use_with python swig)
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc README NEWS
-}
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild
index abd03c441d51..2cf84680a8af 100644
--- a/app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild
+++ b/app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild,v 1.1 2011/03/29 01:06:38 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.0.6.ebuild,v 1.2 2011/03/29 01:44:24 ssuominen Exp $
EAPI=3
-PYTHON_DEPEND="python? 2:2.6"
-inherit python
DESCRIPTION="Support library to communicate with Apple iPhone/iPod Touch devices"
HOMEPAGE="http://www.libimobiledevice.org/"
@@ -13,7 +11,7 @@ SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="python static-libs"
+IUSE="static-libs"
RDEPEND=">=app-pda/libplist-0.15
>=app-pda/usbmuxd-0.1.4
@@ -24,21 +22,15 @@ RDEPEND=">=app-pda/libplist-0.15
sys-fs/fuse
virtual/libusb:1"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- python? ( dev-lang/swig )"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
+ dev-util/pkgconfig"
src_configure() {
+ # Be careful when enabling Python, and read this thru:
+ # http://bugs.gentoo.org/show_bug.cgi?id=361029
econf \
--disable-dependency-tracking \
$(use_enable static-libs static) \
- $(use_with python swig)
+ --without-swig
}
src_install() {