summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-09-18 21:04:19 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-09-18 21:04:19 +0000
commit8176ab0f0ce01e621ceb72366a58ce2d58e393e2 (patch)
tree19f2a47ba5b671d1e4b82a331314274f94cc7190 /app-pda/pilot-link
parentMaintenance release bump (diff)
downloadgentoo-2-8176ab0f0ce01e621ceb72366a58ce2d58e393e2.tar.gz
gentoo-2-8176ab0f0ce01e621ceb72366a58ce2d58e393e2.tar.bz2
gentoo-2-8176ab0f0ce01e621ceb72366a58ce2d58e393e2.zip
Added a minimal patch to fix QA bug 162209.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-pda/pilot-link')
-rw-r--r--app-pda/pilot-link/ChangeLog7
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.11.8-missing-include.patch10
-rw-r--r--app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild22
3 files changed, 28 insertions, 11 deletions
diff --git a/app-pda/pilot-link/ChangeLog b/app-pda/pilot-link/ChangeLog
index e1654d2cd672..45286d7de593 100644
--- a/app-pda/pilot-link/ChangeLog
+++ b/app-pda/pilot-link/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/pilot-link
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.28 2007/08/25 19:17:04 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.29 2007/09/18 21:04:18 philantrop Exp $
+
+ 18 Sep 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/pilot-link-0.11.8-missing-include.patch,
+ pilot-link-0.11.8-r1.ebuild:
+ Added a minimal patch to fix QA bug 162209.
*pilot-link-0.12.2 (25 Aug 2007)
diff --git a/app-pda/pilot-link/files/pilot-link-0.11.8-missing-include.patch b/app-pda/pilot-link/files/pilot-link-0.11.8-missing-include.patch
new file mode 100644
index 000000000000..a41201e51cc2
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.11.8-missing-include.patch
@@ -0,0 +1,10 @@
+--- bindings/Tcl/pitcl.c.orig 2007-01-15 15:23:16.000000000 +0100
++++ bindings/Tcl/pitcl.c 2007-01-15 15:23:35.000000000 +0100
+@@ -15,6 +15,7 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <errno.h>
+ #include <tcl.h>
+ #include <pi-source.h>
diff --git a/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild b/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
index c183fee3a41b..9bb3a99f35e2 100644
--- a/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild,v 1.18 2007/01/11 18:19:24 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild,v 1.19 2007/09/18 21:04:18 philantrop Exp $
inherit perl-module eutils
@@ -13,8 +13,7 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc sparc ~x86"
IUSE="perl java tk python png readline"
-DEPEND="virtual/libc
- sys-libs/ncurses
+DEPEND="sys-libs/ncurses
perl? ( dev-lang/perl )
java? ( virtual/jre )
tk? ( dev-lang/tcl dev-tcltk/itcl dev-lang/tk )
@@ -26,22 +25,25 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch ${FILESDIR}/${P}-java_fPIC_fix.patch
+ epatch "${FILESDIR}/${P}-java_fPIC_fix.patch"
if use java; then
if use ppc; then
- epatch ${FILESDIR}/${P}-java_install_ppc.patch
+ epatch "${FILESDIR}/${P}-java_install_ppc.patch"
elif use amd64; then
- epatch ${FILESDIR}/${P}-java_install_amd64.patch
+ epatch "${FILESDIR}/${P}-java_install_amd64.patch"
else
- epatch ${FILESDIR}/${P}-java_install_all.patch
+ epatch "${FILESDIR}/${P}-java_install_all.patch"
fi
fi
epatch "${FILESDIR}"/${P}-m4.patch
+ # fixes bug 162209
+ epatch "${FILESDIR}/${P}-missing-include.patch"
+
# bug #62873
- cd ${S}/libpisock; epatch ${FILESDIR}/${P}-netsync.patch
+ cd "${S}/libpisock"; epatch "${FILESDIR}/${P}-netsync.patch"
}
src_compile() {
@@ -74,14 +76,14 @@ src_compile() {
make || die
if use perl ; then
- cd ${S}/bindings/Perl
+ cd "${S}/bindings/Perl"
perl-module_src_prep
perl-module_src_compile
fi
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS