summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-31 21:53:38 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-31 21:53:38 +0000
commit43e77b2c12fd470c6cc19c6f715216f3580d6442 (patch)
tree09580eb818be73036295996697eb2549c93b9ae1 /app-office
parent2.1.2 version bump (diff)
downloadgentoo-2-43e77b2c12fd470c6cc19c6f715216f3580d6442.tar.gz
gentoo-2-43e77b2c12fd470c6cc19c6f715216f3580d6442.tar.bz2
gentoo-2-43e77b2c12fd470c6cc19c6f715216f3580d6442.zip
2.1.2 version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kword/ChangeLog7
-rw-r--r--app-office/kword/kword-2.1.2.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 2a0f359d9c92..03703d071672 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kword
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.145 2010/02/27 22:27:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.146 2010/03/31 21:53:38 tampakrap Exp $
+
+*kword-2.1.2 (31 Mar 2010)
+
+ 31 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org> +kword-2.1.2.ebuild:
+ 2.1.2 version bump
*kword-2.1.1 (27 Feb 2010)
diff --git a/app-office/kword/kword-2.1.2.ebuild b/app-office/kword/kword-2.1.2.ebuild
new file mode 100644
index 000000000000..85dc85544f20
--- /dev/null
+++ b/app-office/kword/kword-2.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-2.1.2.ebuild,v 1.1 2010/03/31 21:53:38 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice word processor."
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="wpd +wv2"
+
+DEPEND="
+ wpd? ( app-text/libwpd )
+ wv2? ( >=app-text/wv2-0.4.2 )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="filters/${KMMODULE}/"
+
+KMEXTRACTONLY="
+ filters/
+ kspread/
+ libs/
+ plugins/
+"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with wpd)
+ $(cmake-utils_use_with wv2)"
+
+ kde4-meta_src_configure
+}