summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-01-19 17:29:29 +0000
committerDan Armak <danarmak@gentoo.org>2002-01-19 17:29:29 +0000
commit0e077b21781e4f624e17e7913bc8cd7fb9243554 (patch)
treefe2c8b185cd6867477ab5baeaec80d7a72c8bdfb /app-office
parentbleh (diff)
downloadgentoo-2-0e077b21781e4f624e17e7913bc8cd7fb9243554.tar.gz
gentoo-2-0e077b21781e4f624e17e7913bc8cd7fb9243554.tar.bz2
gentoo-2-0e077b21781e4f624e17e7913bc8cd7fb9243554.zip
new version. note that no vesion confirms to sandbox, that's under investgation
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx-base/files/digest-lyx-base-1.1.6.41
-rw-r--r--app-office/lyx-base/lyx-base-1.1.6.4.ebuild45
-rw-r--r--app-office/lyx-utils/lyx-utils-1.1.6.4.ebuild32
-rw-r--r--app-office/lyx/lyx-1.1.6.4.ebuild12
4 files changed, 90 insertions, 0 deletions
diff --git a/app-office/lyx-base/files/digest-lyx-base-1.1.6.4 b/app-office/lyx-base/files/digest-lyx-base-1.1.6.4
new file mode 100644
index 000000000000..8bf017649e77
--- /dev/null
+++ b/app-office/lyx-base/files/digest-lyx-base-1.1.6.4
@@ -0,0 +1 @@
+MD5 de8fc7e0f390f12db4093098f8fee9d6 lyx-1.1.6fix4.tar.gz 5566464
diff --git a/app-office/lyx-base/lyx-base-1.1.6.4.ebuild b/app-office/lyx-base/lyx-base-1.1.6.4.ebuild
new file mode 100644
index 000000000000..4f359cb08ab7
--- /dev/null
+++ b/app-office/lyx-base/lyx-base-1.1.6.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx-base/lyx-base-1.1.6.4.ebuild,v 1.1 2002/01/19 17:29:29 danarmak Exp $
+
+# The real version of LyX is 1.1.6fix4. As Portage has no support for
+# arbitrary suffixes like 'fix', this is translated into 1.1.6.4.
+P=lyx-1.1.6fix4
+S=${WORKDIR}/${P}
+
+DESCRIPTION="LyX is an Xwindows graphical frontend for LaTeX. Instead\
+ of forcing you to learn LaTeX markup syntax and use the\
+ proper tags, however, it is a WYSIWYM program."
+
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.gz"
+
+HOMEPAGE="http://www.lyx.org/"
+
+# This lyx-base ebuild only depends on the absolutely necessary packages.
+# The acompanying lyx-utils ebuild depends on lyx-base and on everything
+# else that lyx can use.
+DEPEND="virtual/x11
+ x11-libs/xforms
+ app-text/tetex
+ >=sys-devel/perl-5
+ sys-devel/gcc
+ sys-libs/glibc
+ sys-devel/ld.so"
+
+src_compile() {
+
+ try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}
+
+ try emake
+
+}
+
+src_install () {
+
+ # install-strip is a special target provided by the LyX makefile
+ # for striping installed binaries.
+ try make DESTDIR=${D} install-strip
+
+}
+
diff --git a/app-office/lyx-utils/lyx-utils-1.1.6.4.ebuild b/app-office/lyx-utils/lyx-utils-1.1.6.4.ebuild
new file mode 100644
index 000000000000..a8468318085a
--- /dev/null
+++ b/app-office/lyx-utils/lyx-utils-1.1.6.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx-utils/lyx-utils-1.1.6.4.ebuild,v 1.1 2002/01/19 17:29:29 danarmak Exp $
+
+# This ebuild does nothing, it depends on lyx-base and on all known
+# packages lyx can make use of. See the lyx-base ebuild for more info.
+# Note that these packages ( the ones this ebuild depends on) can be
+# installed in any order, both before and after the lyx installation;
+# when lyx runs it automatically uses whatever it finds.
+
+DESCRIPTION="All the utils/packages LyX (lyx-base.ebuild) can make use of."
+
+HOMEPAGE="http://www.lyx.org/"
+
+DEPEND="~app-office/lyx-base-$PV
+ app-text/ghostscript
+ app-text/xpdf
+ app-text/ispell
+ app-text/gv
+ app-text/latex2html
+ media-gfx/imagemagick
+ virtual/lpr
+ app-text/rcs
+ dev-util/cvs
+ app-text/sgmltools-lite
+ app-text/noweb"
+# app-text/chktex"
+
+# Missing from this list:
+# sgmltools - www.sgmltools.org is unreachable so I couldn't make
+# an ebuild for it. Lyx uses sgmltools for DocBook conversion.
diff --git a/app-office/lyx/lyx-1.1.6.4.ebuild b/app-office/lyx/lyx-1.1.6.4.ebuild
new file mode 100644
index 000000000000..316a49f2eb4d
--- /dev/null
+++ b/app-office/lyx/lyx-1.1.6.4.ebuild
@@ -0,0 +1,12 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.1.6.4.ebuild,v 1.1 2002/01/19 17:29:29 danarmak Exp $
+
+# This ebuild simply depends on lyx-base and lyx-utils.
+
+DESCRIPTION="Lyx itself (lyx-base), plus all the utils/packages it can make use of (lyx-utils)."
+
+HOMEPAGE="http://www.lyx.org/"
+
+DEPEND="~app-office/lyx-utils-${PV} ~app-office/lyx-base-${PV}"