summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2011-03-13 19:42:04 +0000
committerAndreas Proschofsky <suka@gentoo.org>2011-03-13 19:42:04 +0000
commit69c32f8b3411c053849f6556849d0cfde7b5167e (patch)
treee7a279913e37175d611397cae420e892d885ec03 /app-office/openoffice
parentFix src_test after virtualx.eclass updates, bug #358373 by graaff. Also clean... (diff)
downloadgentoo-2-69c32f8b3411c053849f6556849d0cfde7b5167e.tar.gz
gentoo-2-69c32f8b3411c053849f6556849d0cfde7b5167e.tar.bz2
gentoo-2-69c32f8b3411c053849f6556849d0cfde7b5167e.zip
Move pre-compilation checks to the right stage, bug #358491
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'app-office/openoffice')
-rw-r--r--app-office/openoffice/ChangeLog6
-rw-r--r--app-office/openoffice/openoffice-3.2.0.ebuild42
-rw-r--r--app-office/openoffice/openoffice-3.2.1-r1.ebuild42
3 files changed, 47 insertions, 43 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index 9f254e3e0ff2..ddb942e31e54 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/openoffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.547 2011/03/13 19:37:16 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.548 2011/03/13 19:42:04 suka Exp $
+
+ 13 Mar 2011; Andreas Proschofsky <suka@gentoo.org> openoffice-3.2.0.ebuild,
+ openoffice-3.2.1-r1.ebuild:
+ Move pre-compilation checks to the right stage, bug #358491
13 Mar 2011; Andreas Proschofsky <suka@gentoo.org> openoffice-3.2.0.ebuild,
openoffice-3.2.1-r1.ebuild:
diff --git a/app-office/openoffice/openoffice-3.2.0.ebuild b/app-office/openoffice/openoffice-3.2.0.ebuild
index 801326d0c71f..f24141fe2b82 100644
--- a/app-office/openoffice/openoffice-3.2.0.ebuild
+++ b/app-office/openoffice/openoffice-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.2.0.ebuild,v 1.31 2011/03/13 19:37:16 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.2.0.ebuild,v 1.32 2011/03/13 19:42:04 suka Exp $
WANT_AUTOMAKE="1.9"
EAPI="3"
@@ -143,6 +143,26 @@ PROVIDE="virtual/ooo"
pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+
+ # sys-libs/db version used
+ local db_ver=$(db_findver '>=sys-libs/db-4.3')
+
+ kde4-base_pkg_setup
+
+ python_set_active_version 2
+ python_pkg_setup
+
+}
+
+src_unpack() {
+
+ unpack ooo-build-${MY_PV}.tar.gz
+
+}
+
+src_prepare() {
+
ewarn
ewarn " It is important to note that OpenOffice.org is a very fragile "
ewarn " build when it comes to CFLAGS. A number of flags have already "
@@ -194,26 +214,6 @@ pkg_setup() {
die
fi
- java-pkg-opt-2_pkg_setup
-
- # sys-libs/db version used
- local db_ver=$(db_findver '>=sys-libs/db-4.3')
-
- kde4-base_pkg_setup
-
- python_set_active_version 2
- python_pkg_setup
-
-}
-
-src_unpack() {
-
- unpack ooo-build-${MY_PV}.tar.gz
-
-}
-
-src_prepare() {
-
# Hackish workaround for overlong path problem, see bug #130837
mv "${S_OLD}" "${S}" || die
diff --git a/app-office/openoffice/openoffice-3.2.1-r1.ebuild b/app-office/openoffice/openoffice-3.2.1-r1.ebuild
index 4c07fc6a3756..e021d9ab9072 100644
--- a/app-office/openoffice/openoffice-3.2.1-r1.ebuild
+++ b/app-office/openoffice/openoffice-3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.2.1-r1.ebuild,v 1.6 2011/03/13 19:37:16 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.2.1-r1.ebuild,v 1.7 2011/03/13 19:42:04 suka Exp $
WANT_AUTOMAKE="1.9"
EAPI="3"
@@ -142,6 +142,26 @@ PROVIDE="virtual/ooo"
pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+
+ # sys-libs/db version used
+ local db_ver=$(db_findver '>=sys-libs/db-4.3')
+
+ kde4-base_pkg_setup
+
+ python_set_active_version 2
+ python_pkg_setup
+
+}
+
+src_unpack() {
+
+ unpack ooo-build-${MY_PV}.tar.gz
+
+}
+
+src_prepare() {
+
ewarn
ewarn " It is important to note that OpenOffice.org is a very fragile "
ewarn " build when it comes to CFLAGS. A number of flags have already "
@@ -193,26 +213,6 @@ pkg_setup() {
die
fi
- java-pkg-opt-2_pkg_setup
-
- # sys-libs/db version used
- local db_ver=$(db_findver '>=sys-libs/db-4.3')
-
- kde4-base_pkg_setup
-
- python_set_active_version 2
- python_pkg_setup
-
-}
-
-src_unpack() {
-
- unpack ooo-build-${MY_PV}.tar.gz
-
-}
-
-src_prepare() {
-
# Hackish workaround for overlong path problem, see bug #130837
mv "${S_OLD}" "${S}" || die