summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-27 21:43:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-27 21:43:25 +0000
commit7fb317d9f36a30864e98e7733b4cf93930da67fe (patch)
tree0a11371080418c28f161c1fddbb69e07fe5299da /app-office/koffice-libs
parentVersion bump. (diff)
downloadgentoo-2-7fb317d9f36a30864e98e7733b4cf93930da67fe.tar.gz
gentoo-2-7fb317d9f36a30864e98e7733b4cf93930da67fe.tar.bz2
gentoo-2-7fb317d9f36a30864e98e7733b4cf93930da67fe.zip
Version bump.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-office/koffice-libs')
-rw-r--r--app-office/koffice-libs/ChangeLog8
-rw-r--r--app-office/koffice-libs/koffice-libs-2.1.1.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/app-office/koffice-libs/ChangeLog b/app-office/koffice-libs/ChangeLog
index 1e700b01769a..fa6f6fc2dc1c 100644
--- a/app-office/koffice-libs/ChangeLog
+++ b/app-office/koffice-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice-libs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.107 2010/01/24 13:39:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.108 2010/02/27 21:43:25 ssuominen Exp $
+
+*koffice-libs-2.1.1 (27 Feb 2010)
+
+ 27 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +koffice-libs-2.1.1.ebuild:
+ Version bump.
24 Jan 2010; Brent Baude <ranger@gentoo.org> koffice-libs-2.1.0.ebuild:
Marking koffice-libs-2.1.0 ~ppc for bug 295884
diff --git a/app-office/koffice-libs/koffice-libs-2.1.1.ebuild b/app-office/koffice-libs/koffice-libs-2.1.1.ebuild
new file mode 100644
index 000000000000..d4fceb5f5438
--- /dev/null
+++ b/app-office/koffice-libs/koffice-libs-2.1.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-2.1.1.ebuild,v 1.1 2010/02/27 21:43:25 ssuominen Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="libs"
+OPENGL_REQUIRED="optional"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Shared KOffice libraries."
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="crypt openexr"
+
+RDEPEND="
+ >=app-office/koffice-data-${PV}:${SLOT}
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=kde-base/kdepimlibs-${KDE_MINIMAL}
+ >=media-libs/lcms-1.18
+ crypt? ( app-crypt/qca:2 )
+ openexr? ( media-libs/openexr )
+ opengl? ( media-libs/mesa )
+"
+DEPEND="${RDEPEND}"
+# doc? ( app-doc/doxygen )"
+
+KMEXTRA="
+ doc/koffice/
+ doc/thesaurus/
+ filters/generic_wrapper/
+ filters/libkowmf/
+ filters/xsltfilter/
+ interfaces/
+ kounavail/
+ plugins/
+ tools/"
+# doc/api/"
+KMEXTRACTONLY="
+ doc/koffice.desktop"
+
+KMSAVELIBS="true"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with openexr OpenEXR)"
+ use crypt && mycmakeargs="${mycmakeargs}
+ -DQCA2_LIBRARIES=/usr/$(get_libdir)/qca2/libqca.so.2"
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ newdoc kounavail/README README.kounavail || die
+
+ kde4-meta_src_install
+}