summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-25 09:34:46 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-25 09:34:46 +0000
commit363288bcb9114d525f31fcc6e5b1cfca3be1f463 (patch)
tree8fc32f22ec27974852ece37dda7cc618c9c7ccbf /app-office/calligra-l10n
parentBump (diff)
downloadgentoo-2-363288bcb9114d525f31fcc6e5b1cfca3be1f463.tar.gz
gentoo-2-363288bcb9114d525f31fcc6e5b1cfca3be1f463.tar.bz2
gentoo-2-363288bcb9114d525f31fcc6e5b1cfca3be1f463.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-office/calligra-l10n')
-rw-r--r--app-office/calligra-l10n/ChangeLog9
-rw-r--r--app-office/calligra-l10n/calligra-l10n-2.5.5.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/app-office/calligra-l10n/ChangeLog b/app-office/calligra-l10n/ChangeLog
index 5cfd2f62d3b3..46d2cc3c6e71 100644
--- a/app-office/calligra-l10n/ChangeLog
+++ b/app-office/calligra-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/calligra-l10n
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/ChangeLog,v 1.27 2012/11/04 10:27:13 scarabeus Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/ChangeLog,v 1.28 2013/01/25 09:34:46 patrick Exp $
+
+*calligra-l10n-2.5.5 (25 Jan 2013)
+
+ 25 Jan 2013; Patrick Lauer <patrick@gentoo.org> +calligra-l10n-2.5.5.ebuild:
+ Bump
*calligra-l10n-2.5.3 (04 Nov 2012)
diff --git a/app-office/calligra-l10n/calligra-l10n-2.5.5.ebuild b/app-office/calligra-l10n/calligra-l10n-2.5.5.ebuild
new file mode 100644
index 000000000000..98d292f8eb0d
--- /dev/null
+++ b/app-office/calligra-l10n/calligra-l10n-2.5.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/calligra-l10n-2.5.5.ebuild,v 1.1 2013/01/25 09:34:46 patrick Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="Calligra localization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND="!app-office/koffice-l10n"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+MY_LANGS="ca da de el en_GB es et fi fr gl hu it ja kk nb nds nl pl pt pt_BR ru sk sv uk zh_CN zh_TW"
+URI_BASE="mirror://kde/stable/${PN/-l10n/}-${PV}/${PN}/"
+SRC_URI=""
+SLOT="4"
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+unset MY_LANG
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local lng dir
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for lng in ${MY_LANGS}; do
+ dir="${PN}-${lng}-${PV}"
+ if [[ -d "${dir}" ]] ; then
+ echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_MESSAGES=ON -DBUILD_DATA=ON
+ $(cmake-utils_use_build doc)
+ )
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_install
+}