summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-08-07 13:21:25 +0000
committerMike Frysinger <vapier@gentoo.org>2011-08-07 13:21:25 +0000
commit487cd96f7f2dc69e32e3bfe0e931e0465cfa2965 (patch)
treeb1532b1a8daeedf6285365ca1656ef0d63f4ca59 /app-mobilephone
parentFix dependencies, install cuetag.sh to /usr/bin. Fixes bug 327271 by Alexande... (diff)
downloadgentoo-2-487cd96f7f2dc69e32e3bfe0e931e0465cfa2965.tar.gz
gentoo-2-487cd96f7f2dc69e32e3bfe0e931e0465cfa2965.tar.bz2
gentoo-2-487cd96f7f2dc69e32e3bfe0e931e0465cfa2965.zip
Version bump.
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/dfu-util/ChangeLog7
-rw-r--r--app-mobilephone/dfu-util/dfu-util-0.4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-mobilephone/dfu-util/ChangeLog b/app-mobilephone/dfu-util/ChangeLog
index 4ad983e84660..8973d5628210 100644
--- a/app-mobilephone/dfu-util/ChangeLog
+++ b/app-mobilephone/dfu-util/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/dfu-util
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/dfu-util/ChangeLog,v 1.4 2011/08/07 13:20:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/dfu-util/ChangeLog,v 1.5 2011/08/07 13:21:25 vapier Exp $
+
+*dfu-util-0.4 (07 Aug 2011)
+
+ 07 Aug 2011; Mike Frysinger <vapier@gentoo.org> +dfu-util-0.4.ebuild:
+ Version bump.
07 Aug 2011; Mike Frysinger <vapier@gentoo.org> dfu-util-9999.ebuild:
Upstream has converted to libusb-1.
diff --git a/app-mobilephone/dfu-util/dfu-util-0.4.ebuild b/app-mobilephone/dfu-util/dfu-util-0.4.ebuild
new file mode 100644
index 000000000000..a1eac96a941a
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/dfu-util/dfu-util-0.4.ebuild,v 1.1 2011/08/07 13:21:25 vapier Exp $
+
+EAPI="2"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.openezx.org/dfu-util.git"
+ inherit autotools git
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="http://dfu-util.gnumonks.org/releases/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://wiki.openmoko.org/wiki/Dfu-util"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_prepare
+ eautoreconf
+ fi
+ sed -i '/^bin_PROGRAMS/s:dfu-util_static[^ ]*::' src/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README TODO
+}