summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-09-01 16:46:28 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-09-01 16:46:28 +0000
commitbc58bcda404b273e8add243e2710f8935fc3214a (patch)
tree790b4bd09e513574c753f19852fcecd377827632 /app-misc/strigi
parentVersion bump. (diff)
downloadgentoo-2-bc58bcda404b273e8add243e2710f8935fc3214a.tar.gz
gentoo-2-bc58bcda404b273e8add243e2710f8935fc3214a.tar.bz2
gentoo-2-bc58bcda404b273e8add243e2710f8935fc3214a.zip
Version bump, with a backported patch from upstream fixing build with GCC 4.8 (bug #483006).
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'app-misc/strigi')
-rw-r--r--app-misc/strigi/ChangeLog9
-rw-r--r--app-misc/strigi/files/strigi-0.7.8-gcc-4.8.patch11
-rw-r--r--app-misc/strigi/strigi-0.7.8.ebuild86
3 files changed, 105 insertions, 1 deletions
diff --git a/app-misc/strigi/ChangeLog b/app-misc/strigi/ChangeLog
index 6937dfbfc84f..4276a80221dd 100644
--- a/app-misc/strigi/ChangeLog
+++ b/app-misc/strigi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/strigi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.102 2013/04/02 20:55:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.103 2013/09/01 16:46:27 kensington Exp $
+
+*strigi-0.7.8 (01 Sep 2013)
+
+ 01 Sep 2013; Michael Palimaka <kensington@gentoo.org>
+ +files/strigi-0.7.8-gcc-4.8.patch, +strigi-0.7.8.ebuild:
+ Version bump, with a backported patch from upstream fixing build with GCC 4.8
+ (bug #483006).
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> strigi-0.7.7-r2.ebuild:
Stable for ppc64, wrt bug #462890
diff --git a/app-misc/strigi/files/strigi-0.7.8-gcc-4.8.patch b/app-misc/strigi/files/strigi-0.7.8-gcc-4.8.patch
new file mode 100644
index 000000000000..f525a71627a6
--- /dev/null
+++ b/app-misc/strigi/files/strigi-0.7.8-gcc-4.8.patch
@@ -0,0 +1,11 @@
+--- libstreams/include/strigi/bufferedstream.h
++++ libstreams/include/strigi/bufferedstream.h
+@@ -34,7 +34,7 @@
+ * BufferedStream will do the rest.
+ */
+ template <class T>
+-class BufferedStream : public StreamBase<T> {
++class STREAMS_EXPORT BufferedStream : public StreamBase<T> {
+ private:
+ StreamBuffer<T> buffer;
+ bool finishedWritingToBuffer;
diff --git a/app-misc/strigi/strigi-0.7.8.ebuild b/app-misc/strigi/strigi-0.7.8.ebuild
new file mode 100644
index 000000000000..9eebee0030c9
--- /dev/null
+++ b/app-misc/strigi/strigi-0.7.8.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.7.8.ebuild,v 1.1 2013/09/01 16:46:27 kensington Exp $
+
+EAPI=5
+
+if [[ "${PV}" != "9999" ]]; then
+ SRC_URI="http://www.vandenoever.info/software/strigi/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+else
+ EGIT_REPO_URI="git://anongit.kde.org/strigi"
+ GIT_ECLASS="git-2"
+ EGIT_HAS_SUBMODULES="true"
+ KEYWORDS=""
+fi
+
+inherit cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="Fast crawling desktop search engine with Qt4 GUI"
+HOMEPAGE="https://projects.kde.org/projects/kdesupport/strigi/strigi"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="clucene +dbus debug exif fam ffmpeg inotify log +qt4 test"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/libxml2:2
+ sys-libs/zlib
+ virtual/libiconv
+ clucene? ( >=dev-cpp/clucene-0.9.21[-debug] )
+ dbus? (
+ sys-apps/dbus
+ qt4? ( dev-qt/qtdbus:4 )
+ )
+ exif? ( >=media-gfx/exiv2-0.17 )
+ fam? ( virtual/fam )
+ ffmpeg? ( virtual/ffmpeg )
+ log? ( >=dev-libs/log4cxx-0.10.0 )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc-4.8.patch"
+)
+
+src_configure() {
+ # Enabled: POLLING (only reliable way to check for files changed.)
+ # Disabled: xine - recommended upstream to keep it this way
+ local mycmakeargs=(
+ -DENABLE_POLLING=ON
+ -DFORCE_DEPS=ON
+ -DENABLE_REGENERATEXSD=OFF
+ -DENABLE_XINE=OFF
+ $(cmake-utils_use_enable clucene CLUCENE)
+ $(cmake-utils_use_enable clucene CLUCENE_NG)
+ $(cmake-utils_use_enable dbus)
+ $(cmake-utils_use_enable exif EXIV2)
+ $(cmake-utils_use_enable fam)
+ $(cmake-utils_use_enable ffmpeg)
+ $(cmake-utils_use_enable inotify)
+ $(cmake-utils_use_enable log LOG4CXX)
+ $(cmake-utils_use_enable qt4)
+ $(cmake-utils_use_find_package test CPPUNIT)
+ )
+
+ if use qt4; then
+ mycmakeargs+=( -DENABLE_DBUS=ON )
+ fi
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if ! use clucene ; then
+ elog "Because you didn't enable the clucene backend, strigi may not be functional."
+ elog "If you intend to use standalone strigi indexer (not needed for KDE),"
+ elog "be sure to reinstall app-misc/strigi with the clucene USE flag enabled."
+ fi
+}