summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2012-11-24 18:11:34 +0000
committerRichard Freeman <rich0@gentoo.org>2012-11-24 18:11:34 +0000
commit521432b173d0cf3a0bccef818ff7b890e25785bb (patch)
tree6f4ce2c1636efd8608a83c2e3a4b5ac840fd9cbf /app-misc/sleepyhead
parentMask live ebuild. (diff)
downloadgentoo-2-521432b173d0cf3a0bccef818ff7b890e25785bb.tar.gz
gentoo-2-521432b173d0cf3a0bccef818ff7b890e25785bb.tar.bz2
gentoo-2-521432b173d0cf3a0bccef818ff7b890e25785bb.zip
Add live ebuild for testing.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x08C170DE55EC123A)
Diffstat (limited to 'app-misc/sleepyhead')
-rw-r--r--app-misc/sleepyhead/ChangeLog7
-rw-r--r--app-misc/sleepyhead/sleepyhead-9999.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/app-misc/sleepyhead/ChangeLog b/app-misc/sleepyhead/ChangeLog
index 4a9ea529b680..904266b612c6 100644
--- a/app-misc/sleepyhead/ChangeLog
+++ b/app-misc/sleepyhead/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/sleepyhead
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sleepyhead/ChangeLog,v 1.6 2012/11/12 01:48:06 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sleepyhead/ChangeLog,v 1.7 2012/11/24 18:11:34 rich0 Exp $
+
+*sleepyhead-9999 (24 Nov 2012)
+
+ 24 Nov 2012; Richard Freeman <rich0@gentoo.org> +sleepyhead-9999.ebuild:
+ Add live ebuild for testing.
12 Nov 2012; Richard Freeman <rich0@gentoo.org> sleepyhead-0.9.2.2-r1.ebuild,
+files/common_gui.patch:
diff --git a/app-misc/sleepyhead/sleepyhead-9999.ebuild b/app-misc/sleepyhead/sleepyhead-9999.ebuild
new file mode 100644
index 000000000000..f73dfa642a2c
--- /dev/null
+++ b/app-misc/sleepyhead/sleepyhead-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sleepyhead/sleepyhead-9999.ebuild,v 1.1 2012/11/24 18:11:34 rich0 Exp $
+
+EAPI=4
+inherit eutils git-2 qt4-r2
+DESCRIPTION="Software used to analyze data from CPAP machines."
+HOMEPAGE="https://sourceforge.net/apps/mediawiki/sleepyhead/index.php?title=Main_Page"
+
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+EGIT_REPO_URI="git://github.com/rich0/rich0-sleepyhead.git"
+EGIT_BRANCH="rich-test"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+IUSE="debug"
+
+DEPEND="virtual/opengl
+ x11-libs/libX11
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+ x11-libs/qt-webkit:4"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+git-2_src_unpack
+}
+
+src_prepare() {
+# qt4_src_prepare
+ cd "{$S}/sleepyhead-9999"
+# sed -i '1i#define OF(x) x' quazip/ioapi.h quazip/unzip.c quazip/unzip.h \
+# quazip/zip.c quazip/zip.h quazip/zlib.h
+ eqmake4 SleepyHeadQT.pro
+}
+
+src_install() {
+ cd "{$S}/sleepyhead-9999"
+ dobin SleepyHead || die
+ dodoc README || die
+ dodoc docs/* || die
+}