summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 04:13:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 04:13:52 +0000
commit1946ff5663a89304da65e5d134eed6477794c342 (patch)
treef25735bdc6c43575a0f6f591c81bba6adf18575d /app-misc/rioutil
parentdont apply query_user_context patch with USE=livecd (Manifest recommit) (diff)
downloadgentoo-2-1946ff5663a89304da65e5d134eed6477794c342.tar.gz
gentoo-2-1946ff5663a89304da65e5d134eed6477794c342.tar.bz2
gentoo-2-1946ff5663a89304da65e5d134eed6477794c342.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc/rioutil')
-rw-r--r--app-misc/rioutil/rioutil-1.4.2b.ebuild11
-rw-r--r--app-misc/rioutil/rioutil-1.4.4.ebuild14
2 files changed, 9 insertions, 16 deletions
diff --git a/app-misc/rioutil/rioutil-1.4.2b.ebuild b/app-misc/rioutil/rioutil-1.4.2b.ebuild
index e39bca68ab1e..422c9fcf151f 100644
--- a/app-misc/rioutil/rioutil-1.4.2b.ebuild
+++ b/app-misc/rioutil/rioutil-1.4.2b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.4.2b.ebuild,v 1.6 2004/06/24 22:30:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.4.2b.ebuild,v 1.7 2004/06/28 04:10:47 vapier Exp $
DESCRIPTION="Command line tools for transfering mp3s to and from a Rio 600, 800, and Nike PSA/Play"
HOMEPAGE="http://rioutil.sourceforge.net/"
@@ -14,14 +14,11 @@ IUSE=""
DEPEND="sys-libs/zlib"
src_compile() {
- local myconf="--with-usbdevfs"
-
- econf ${myconf} || die "econf failed"
+ econf --with-usbdevfs || die "econf failed"
emake || die "compile failure"
}
src_install() {
- einstall
-
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ einstall || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
}
diff --git a/app-misc/rioutil/rioutil-1.4.4.ebuild b/app-misc/rioutil/rioutil-1.4.4.ebuild
index 7347e4ec9e83..cf1e46604b2b 100644
--- a/app-misc/rioutil/rioutil-1.4.4.ebuild
+++ b/app-misc/rioutil/rioutil-1.4.4.ebuild
@@ -1,21 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.4.4.ebuild,v 1.5 2004/06/24 22:30:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.4.4.ebuild,v 1.6 2004/06/28 04:10:47 vapier Exp $
DESCRIPTION="Command line tool for transfering mp3s to and from a Rio 600, 800, Rio Riot, and Nike PSA/Play"
HOMEPAGE="http://rioutil.sourceforge.net/"
SRC_URI="mirror://sourceforge/rioutil/${P}.tar.bz2"
-RESTRICT="nomirror"
+
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 ~amd64"
IUSE=""
-RDEPEND="sys-libs/zlib
- virtual/glibc"
-
DEPEND="sys-libs/zlib
- =sys-kernel/linux-headers-2.4*"
+ virtual/libc"
src_compile() {
local myconf="--with-usbdevfs"
@@ -25,7 +22,6 @@ src_compile() {
}
src_install() {
- einstall
-
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ einstall || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
}