summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-06-02 21:53:50 +0000
committerTorsten Veller <tove@gentoo.org>2012-06-02 21:53:50 +0000
commit4934efe9716f56f3d94abb6ffe4482b089b7320a (patch)
tree091437985d36014c9851190b539c7b9b274059c4 /app-misc/remind
parentmedia-gfx/gimp: Fix rsvg dependency version (bug #416839) (diff)
downloadgentoo-2-4934efe9716f56f3d94abb6ffe4482b089b7320a.tar.gz
gentoo-2-4934efe9716f56f3d94abb6ffe4482b089b7320a.tar.bz2
gentoo-2-4934efe9716f56f3d94abb6ffe4482b089b7320a.zip
Fix test failure (#419369)
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/remind')
-rw-r--r--app-misc/remind/ChangeLog6
-rw-r--r--app-misc/remind/files/03.01.12-test.patch19
-rw-r--r--app-misc/remind/remind-03.01.12.ebuild6
3 files changed, 29 insertions, 2 deletions
diff --git a/app-misc/remind/ChangeLog b/app-misc/remind/ChangeLog
index 9d45aebb71ee..5ef73dd8e408 100644
--- a/app-misc/remind/ChangeLog
+++ b/app-misc/remind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/remind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/remind/ChangeLog,v 1.4 2012/06/02 11:36:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/remind/ChangeLog,v 1.5 2012/06/02 21:53:50 tove Exp $
+
+ 02 Jun 2012; Torsten Veller <tove@gentoo.org> +files/03.01.12-test.patch,
+ remind-03.01.12.ebuild:
+ Fix test failure (#419369)
02 Jun 2012; Agostino Sarubbo <ago@gentoo.org> remind-03.01.12.ebuild:
Stable for amd64, wrt bug #418611
diff --git a/app-misc/remind/files/03.01.12-test.patch b/app-misc/remind/files/03.01.12-test.patch
new file mode 100644
index 000000000000..f921304e36c0
--- /dev/null
+++ b/app-misc/remind/files/03.01.12-test.patch
@@ -0,0 +1,19 @@
+commit c56cfe9e1d61a7739fe88fcb42878432e75b3680
+Author: David F. Skoll <dfs@roaringpenguin.com>
+Date: Tue May 8 16:54:54 2012 -0400
+
+ Fix test harness failure.
+
+diff --git a/tests/test-rem b/tests/test-rem
+index 13b5ba6..bad3f49 100644
+--- a/tests/test-rem
++++ b/tests/test-rem
+@@ -68,7 +68,7 @@ echo "Sort Test" >> ../tests/test.out
+ (echo "REM AT 12:00 MSG Untimed"; echo "REM MSG Timed") | ../src/remind -q -gaaad - 1 Jan 2000 >> ../tests/test.out 2>&1
+
+ echo "Purge Test" >> ../tests/test.out
+-../src/remind -j999 ../tests/purge_dir/f1.rem >> ../tests/test.out 2>&1
++../src/remind -j999 ../tests/purge_dir/f1.rem 3 Feb 2012 >> ../tests/test.out 2>&1
+ echo "F1" >> ../tests/test.out
+ cat ../tests/purge_dir/f1.rem.purged >> ../tests/test.out
+ echo "F2" >> ../tests/test.out
diff --git a/app-misc/remind/remind-03.01.12.ebuild b/app-misc/remind/remind-03.01.12.ebuild
index 39ceba0d13c1..0fe5638886a5 100644
--- a/app-misc/remind/remind-03.01.12.ebuild
+++ b/app-misc/remind/remind-03.01.12.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/remind/remind-03.01.12.ebuild,v 1.2 2012/06/02 11:36:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/remind/remind-03.01.12.ebuild,v 1.3 2012/06/02 21:53:50 tove Exp $
+
+inherit eutils
MY_P=${P/_beta/-BETA-}
S=${WORKDIR}/${MY_P}
@@ -18,7 +20,9 @@ RDEPEND="tk? ( dev-lang/tk dev-tcltk/tcllib )"
src_unpack() {
unpack ${A}
+ cd "${S}"
sed -i 's:$(MAKE) install:&-nostripped:' "${S}"/Makefile || die
+ epatch "${FILESDIR}"/03.01.12-test.patch
}
src_test() {