summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-09-26 01:45:24 +0000
committerJeroen Roovers <jer@gentoo.org>2012-09-26 01:45:24 +0000
commit3d64d475655af46c053ee1d71484326303934334 (patch)
tree71afb81a0a774a64e34e96f3edd694d0159792a3 /app-misc/realpath
parentAdd ~x86-fbsd. #418355 (diff)
downloadgentoo-2-3d64d475655af46c053ee1d71484326303934334.tar.gz
gentoo-2-3d64d475655af46c053ee1d71484326303934334.tar.bz2
gentoo-2-3d64d475655af46c053ee1d71484326303934334.zip
Version bump.
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/realpath')
-rw-r--r--app-misc/realpath/ChangeLog8
-rw-r--r--app-misc/realpath/files/realpath-1.17-build.patch43
-rw-r--r--app-misc/realpath/realpath-1.17.ebuild75
3 files changed, 125 insertions, 1 deletions
diff --git a/app-misc/realpath/ChangeLog b/app-misc/realpath/ChangeLog
index 62db8f7cea84..47d3d82105f7 100644
--- a/app-misc/realpath/ChangeLog
+++ b/app-misc/realpath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/realpath
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.26 2012/06/01 02:02:21 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.27 2012/09/26 01:45:23 jer Exp $
+
+*realpath-1.17 (26 Sep 2012)
+
+ 26 Sep 2012; Jeroen Roovers <jer@gentoo.org> +realpath-1.17.ebuild,
+ +files/realpath-1.17-build.patch:
+ Version bump.
01 Jun 2012; Zac Medico <zmedico@gentoo.org> realpath-1.16.ebuild:
inherit multilib for get_libdir
diff --git a/app-misc/realpath/files/realpath-1.17-build.patch b/app-misc/realpath/files/realpath-1.17-build.patch
new file mode 100644
index 000000000000..c4a8b3dfc9b9
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.17-build.patch
@@ -0,0 +1,43 @@
+--- a/common.mk
++++ b/common.mk
+@@ -33,16 +33,9 @@
+ applicationsdir := $(prefix)/share/applications
+
+ PERL := /usr/bin/perl
+-CC := gcc
+-CFLAGS += $(CPPFLAGS) -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Werror -g -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
+-LIBS :=
+-
+-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -O0
+-else
+- CFLAGS += -O2
+-endif
+-
++CC ?= gcc
++CFLAGS += $(CPPFLAGS) -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
++LIBS +=
+
+ # determine our version number
+ ifndef VERSION
+@@ -58,9 +51,6 @@
+ unexport CDPATH ENV
+
+ ifdef DESTDIR
+- ifneq ($(DESTDIR),$(abspath $(DESTDIR)))
+- $(error DESTDIR "$(DESTDIR)" is not an absolute path)
+- endif
+ override ddirshort := DESTDIR
+ export ddirshort
+ endif
+@@ -108,7 +99,9 @@
+ esac; fi;
+ endef
+ else
+- msg := :
++ define msg
++ :
++ endef
+ endif
+
+ msgprefix := *$(subst * ,*,$(wordlist 1,$(MAKELEVEL),* * * * * * * * * * * * * * * * * *))
diff --git a/app-misc/realpath/realpath-1.17.ebuild b/app-misc/realpath/realpath-1.17.ebuild
new file mode 100644
index 000000000000..ba4954b650e3
--- /dev/null
+++ b/app-misc/realpath/realpath-1.17.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/realpath-1.17.ebuild,v 1.1 2012/09/26 01:45:23 jer Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs flag-o-matic multilib prefix
+
+DESCRIPTION="Return the canonicalized absolute pathname"
+HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
+SRC_URI="
+ mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz
+ nls? ( mirror://debian/pool/main/r/${PN}/${PN}_${PV}_i386.deb )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="!sys-freebsd/freebsd-bin
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ x86-interix? ( dev-libs/gnulib )
+ elibc_mintlib? ( virtual/libiconv )"
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+
+ if use nls; then
+ # Unpack the .deb file, in order to get the preprocessed man page
+ # translations. This way we avoid a dependency on app-text/po4a.
+ mkdir deb
+ cd deb
+ unpack ${PN}_${PV}_i386.deb
+ unpack ./data.tar.gz
+ fi
+}
+
+src_prepare() {
+ use nls || epatch "${FILESDIR}"/${P}-nonls.patch
+ epatch "${FILESDIR}"/${PN}-1.17-build.patch
+ epatch "${FILESDIR}"/${PN}-1.14-no-po4a.patch
+ epatch "${FILESDIR}"/${PN}-1.15-prefix.patch
+ eprefixify common.mk
+}
+
+src_compile() {
+ tc-export CC
+ use nls && use !elibc_glibc && append-libs -lintl
+ [[ ${CHOST} == *-mint* ]] && append-libs "-liconv"
+ if [[ ${CHOST} == *-irix* || ${CHOST} == *-interix[35]* ]] ; then
+ append-flags -I"${EPREFIX}"/usr/$(get_libdir)/gnulib/include
+ append-ldflags -L"${EPREFIX}"/usr/$(get_libdir)/gnulib/$(get_libdir)
+ append-libs -lgnu
+ fi
+
+ local subdir
+ for subdir in src man $(usex nls po ''); do
+ emake MAKE_VERBOSE=yes VERSION="${PV}" -C ${subdir}
+ done
+}
+
+src_install() {
+ emake VERSION="${PV}" SUBDIRS="src man $(usex nls po '')" \
+ DESTDIR="${D}" install
+ newdoc debian/changelog ChangeLog.debian
+
+ if use nls; then
+ local dir
+ for dir in "${WORKDIR}"/deb/usr/share/man/*; do
+ [ -f "${dir}"/man1/realpath.1 ] || continue
+ newman "${dir}"/man1/realpath.1 realpath.${dir##*/}.1
+ done
+ fi
+}