summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-02-25 15:56:36 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-02-25 15:56:36 +0000
commit3b4be3305985eba9d7c2f4a9539b20b42bb8dbef (patch)
tree6bc1bc88220f42e2f318d99ca5ce3dcb60350c37 /app-misc/pwsafe
parentold (diff)
downloadgentoo-2-3b4be3305985eba9d7c2f4a9539b20b42bb8dbef.tar.gz
gentoo-2-3b4be3305985eba9d7c2f4a9539b20b42bb8dbef.tar.bz2
gentoo-2-3b4be3305985eba9d7c2f4a9539b20b42bb8dbef.zip
Fix bug #402707 (proxy-commit for headch)
(Portage version: 2.2.0_alpha88/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/pwsafe')
-rw-r--r--app-misc/pwsafe/ChangeLog13
-rw-r--r--app-misc/pwsafe/files/pwsafe-0.2.0-XChangeProperty.patch22
-rw-r--r--app-misc/pwsafe/pwsafe-0.2.0-r2.ebuild42
3 files changed, 75 insertions, 2 deletions
diff --git a/app-misc/pwsafe/ChangeLog b/app-misc/pwsafe/ChangeLog
index 919f0f0dffa7..bdbb3f93647c 100644
--- a/app-misc/pwsafe/ChangeLog
+++ b/app-misc/pwsafe/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/pwsafe
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pwsafe/ChangeLog,v 1.12 2011/05/20 11:30:13 tomka Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pwsafe/ChangeLog,v 1.13 2012/02/25 15:56:36 nirbheek Exp $
+
+*pwsafe-0.2.0-r2 (25 Feb 2012)
+
+ 25 Feb 2012; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +files/pwsafe-0.2.0-XChangeProperty.patch, +pwsafe-0.2.0-r2.ebuild,
+ files/pwsafe-0.2.0-cvs-1.57.patch, files/pwsafe-0.2.0-fake-readline.patch,
+ files/pwsafe-0.2.0-man-page-option-syntax.patch,
+ files/pwsafe-0.2.0-printf.patch, metadata.xml:
+ Fix bug #402707 (proxy-commit for headch)
20 May 2011; Thomas Kahle <tomka@gentoo.org> pwsafe-0.2.0-r1.ebuild:
x86 stable per bug 347549
diff --git a/app-misc/pwsafe/files/pwsafe-0.2.0-XChangeProperty.patch b/app-misc/pwsafe/files/pwsafe-0.2.0-XChangeProperty.patch
new file mode 100644
index 000000000000..3fadfc2765fb
--- /dev/null
+++ b/app-misc/pwsafe/files/pwsafe-0.2.0-XChangeProperty.patch
@@ -0,0 +1,22 @@
+This patch came from <https://bugzilla.redhat.com/show_bug.cgi?id=667541>.
+
+Index: pwsafe.cpp
+===================================================================
+RCS file: /cvsroot/pwsafe/pwsafe/pwsafe.cpp,v
+retrieving revision 1.57
+diff -u -r1.57 pwsafe.cpp
+--- pwsafe.cpp 12 Aug 2007 12:33:06 -0000 1.57
++++ pwsafe.cpp 5 Jan 2011 22:16:43 -0000
+@@ -1820,10 +1820,10 @@
+ if (xev.xselectionrequest.target == XA_TARGETS(xdisplay)) {
+ // tell them what we can supply
+ const Atom targets[] = { XA_TARGETS(xdisplay), XA_TIMESTAMP(xdisplay), XA_TEXT(xdisplay), XA_STRING };
+- XChangeProperty(xdisplay, xev.xselectionrequest.requestor, prop, XA_TARGETS(xdisplay), 32, PropModeReplace, reinterpret_cast<const unsigned char*>(&targets), sizeof(targets)/sizeof(targets[0]));
++ XChangeProperty(xdisplay, xev.xselectionrequest.requestor, prop, XA_ATOM, 32, PropModeReplace, reinterpret_cast<const unsigned char*>(&targets), sizeof(targets)/sizeof(targets[0]));
+ }
+ else if (xev.xselectionrequest.target == XA_TIMESTAMP(xdisplay)) {
+- XChangeProperty(xdisplay, xev.xselectionrequest.requestor, prop, XA_TIMESTAMP(xdisplay), 32, PropModeReplace, reinterpret_cast<const unsigned char*>(&timestamp), 1);
++ XChangeProperty(xdisplay, xev.xselectionrequest.requestor, prop, XA_INTEGER, 32, PropModeReplace, reinterpret_cast<const unsigned char*>(&timestamp), 1);
+ }
+ else if (xev.xselectionrequest.target == XA_TEXT(xdisplay) ||
+ xev.xselectionrequest.target == XA_STRING) {
diff --git a/app-misc/pwsafe/pwsafe-0.2.0-r2.ebuild b/app-misc/pwsafe/pwsafe-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..42fb4eea78d7
--- /dev/null
+++ b/app-misc/pwsafe/pwsafe-0.2.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pwsafe/pwsafe-0.2.0-r2.ebuild,v 1.1 2012/02/25 15:56:36 nirbheek Exp $
+
+EAPI=4
+inherit base eutils
+
+DESCRIPTION="A Password Safe compatible command-line password manager"
+HOMEPAGE="http://nsd.dyndns.org/pwsafe/"
+SRC_URI="http://nsd.dyndns.org/pwsafe/releases/${P}.tar.gz"
+PATCHES=(
+ "${FILESDIR}/${P}-cvs-1.57.patch"
+ "${FILESDIR}/${P}-printf.patch"
+ "${FILESDIR}/${P}-fake-readline.patch"
+ "${FILESDIR}/${P}-man-page-option-syntax.patch"
+ "${FILESDIR}/${P}-XChangeProperty.patch"
+ )
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X readline"
+
+DEPEND="sys-libs/ncurses
+ dev-libs/openssl
+ readline? ( sys-libs/readline )
+ X? ( x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXmu
+ x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with X x) $(use_with readline)
+}
+
+src_install() {
+ doman pwsafe.1
+ dobin pwsafe
+ dodoc README NEWS
+}