summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-10-17 20:48:26 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-10-17 20:48:26 +0000
commitf256e5e943ba303b11a98a65835542fa992577d0 (patch)
tree59562025b4cc0a68055efb7cae2719cb69999805 /app-misc/lirc
parentbump to 5.20.2 (diff)
downloadgentoo-2-f256e5e943ba303b11a98a65835542fa992577d0.tar.gz
gentoo-2-f256e5e943ba303b11a98a65835542fa992577d0.tar.bz2
gentoo-2-f256e5e943ba303b11a98a65835542fa992577d0.zip
Updated imon-pad2key patch. This makes the option switchable via module-parameter instead of recompiling. Bug 196134
(Portage version: 2.1.3.14)
Diffstat (limited to 'app-misc/lirc')
-rw-r--r--app-misc/lirc/ChangeLog7
-rw-r--r--app-misc/lirc/files/lirc-0.8.3_pre1-imon-pad2keys.patch257
-rw-r--r--app-misc/lirc/lirc-0.8.3_pre1.ebuild6
3 files changed, 267 insertions, 3 deletions
diff --git a/app-misc/lirc/ChangeLog b/app-misc/lirc/ChangeLog
index d48ba447e839..5f864dc98262 100644
--- a/app-misc/lirc/ChangeLog
+++ b/app-misc/lirc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/lirc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.156 2007/10/14 10:16:47 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.157 2007/10/17 20:48:26 zzam Exp $
+
+ 17 Oct 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/lirc-0.8.3_pre1-imon-pad2keys.patch, lirc-0.8.3_pre1.ebuild:
+ Updated imon-pad2key patch. This makes the option switchable via
+ module-parameter instead of recompiling. Bug 196134
14 Oct 2007; Matthias Schwarzott <zzam@gentoo.org>
+files/lirc-0.8.3_pre1-remotewonderplus.patch, lirc-0.8.3_pre1.ebuild:
diff --git a/app-misc/lirc/files/lirc-0.8.3_pre1-imon-pad2keys.patch b/app-misc/lirc/files/lirc-0.8.3_pre1-imon-pad2keys.patch
new file mode 100644
index 000000000000..59ed4c9a1ea4
--- /dev/null
+++ b/app-misc/lirc/files/lirc-0.8.3_pre1-imon-pad2keys.patch
@@ -0,0 +1,257 @@
+diff -NuBbwr lirc-0.8.3pre1-orig/drivers/lirc_imon/lirc_imon.c lirc-0.8.3pre1/drivers/lirc_imon/lirc_imon.c
+--- lirc-0.8.3pre1-orig/drivers/lirc_imon/lirc_imon.c 2007-09-30 11:58:45.000000000 +0200
++++ lirc-0.8.3pre1/drivers/lirc_imon/lirc_imon.c 2007-10-14 14:20:07.000000000 +0200
+@@ -69,9 +69,9 @@
+
+
+ #define MOD_AUTHOR "Venky Raju <dev@venky.ws>"
+-#define MOD_DESC "Driver for Soundgraph iMON MultiMedia IR/VFD"
++#define MOD_DESC "Driver for Soundgraph iMON MultiMedia IR/VFD w/imon pad2keys patch"
+ #define MOD_NAME "lirc_imon"
+-#define MOD_VERSION "0.3"
++#define MOD_VERSION "0.3p2k"
+
+ #define VFD_MINOR_BASE 144 /* Same as LCD */
+ #define DEVFS_MODE (S_IFCHR | S_IRUSR | S_IWUSR | \
+@@ -87,6 +87,7 @@
+ #define TRUE 1
+ #define FALSE 0
+
++#define CURSOR_LIMIT 16
+
+ /* ------------------------------------------------------------
+ * P R O T O T Y P E S
+@@ -169,6 +170,10 @@
+ atomic_t busy; /* write in progress */
+ int status; /* status of tx completion */
+ } tx;
++
++ int key_x;
++ int key_y;
++ int last_count; /* number of times pressed */
+ };
+
+ #define LOCK_CONTEXT down(&context->sem)
+@@ -235,6 +240,9 @@
+
+ static int debug;
+
++/* pad2keys module parameter. pad2keys patch active? */
++static int pad2keys_active = 0;
++
+ #if !defined(KERNEL_2_5)
+
+ #define MAX_DEVICES 4 /* In case there's more than one iMON device */
+@@ -258,10 +266,13 @@
+
+ MODULE_AUTHOR(MOD_AUTHOR);
+ MODULE_DESCRIPTION(MOD_DESC);
++MODULE_VERSION(MOD_VERSION); /* MBr: was missing */
+ MODULE_LICENSE("GPL");
+ MODULE_DEVICE_TABLE(usb, imon_usb_id_table);
+ module_param(debug, int, 0);
+ MODULE_PARM_DESC(debug, "Debug messages: 0=no, 1=yes(default: no)");
++module_param (pad2keys_active, int, 0);
++MODULE_PARM_DESC (pad2keys_active, "pad2keys patch active: 0=no, 1=yes (default: no)");
+
+ static inline void delete_context(struct imon_context *context)
+ {
+@@ -684,6 +695,11 @@
+ context->rx.initial_space = 1;
+ context->rx.prev_bit = 0;
+
++ /* init pad context for pad2keys */
++ context ->key_x = 0;
++ context ->key_y = 0;
++ context ->last_count = 0;
++
+ usb_fill_int_urb(context->rx_urb, context->dev,
+ usb_rcvintpipe(context->dev,
+ context->rx_endpoint->bEndpointAddress),
+@@ -834,6 +850,94 @@
+
+ if (context->ir_onboard_decode) {
+ /* The signals have been decoded onboard the iMON controller */
++
++ if (pad2keys_active)
++ {
++ /* imon pad2keys patch
++ *
++ * make PAD and mouse buttons available for use with VDR,
++ * based on pad-mouse-emu patch from venky's forum
++ *
++ * last change: M.Brakemeier 2007-10-14
++ *
++ * generated PAD key codes:
++ * Mouse_N 0x690281B7
++ * Mouse_S 0x688291B7
++ * Mouse_W 0x6A8281B7
++ * Mouse_E 0x688A81B7
++ *
++ * mouse buttons (non-synthetic):
++ * MouseRightClick 0x688481B7
++ * MouseLeftClick 0x688301B7
++ */
++ if((buf[0] & 0x40) &&
++ !(buf[1] & 0x01 || buf[1] >> 2 & 0x01))
++ {
++ int rel_x = (buf[1] & 0x08) | (buf[1] & 0x10) >> 2 | (buf[1] & 0x20) >> 4 | (buf[1] & 0x40) >> 6;
++ int rel_y = (buf[2] & 0x08) | (buf[2] & 0x10) >> 2 | (buf[2] & 0x20) >> 4 | (buf[2] & 0x40) >> 6;
++
++ if(buf[0] & 0x02)
++ rel_x |= ~0x10+1;
++ if(buf[0] & 0x01)
++ rel_y |= ~0x10+1;
++
++ /* keyboard direction key emulation */
++ if( context->last_count > 32 )
++ { /* Hopefully eliminate drift*/
++ context->last_count=0;
++ context->key_y=0;
++ context->key_x=0;
++ }
++ context->last_count++;
++
++ /* limit decoded events */
++ if(abs(context->key_x) > CURSOR_LIMIT || abs(context->key_y) > CURSOR_LIMIT )
++ {
++ if(abs(context->key_y ) > abs(context->key_x))
++ { /* mouse s/n */
++ if(context->key_y > 0 && rel_y > 0)
++ { /* mouse s */
++ buf[0] = 0x68;
++ buf[1] = 0x82;
++ buf[2] = 0x91;
++ }
++ else if(context->key_y < 0 && rel_y < 0)
++ { /* mouse n */
++ buf[0] = 0x69;
++ buf[1] = 0x02;
++ buf[2] = 0x81;
++ }
++ }
++ else
++ { /* mouse e/w*/
++ if(context->key_x > 0 && rel_x > 0 )
++ { /* mouse e */
++ buf[0] = 0x68;
++ buf[1] = 0x8A;
++ buf[2] = 0x81;
++ }
++ else if(context->key_x < 0 && rel_x < 0 )
++ { /* mouse w */
++ buf[0] = 0x6A;
++ buf[1] = 0x82;
++ buf[2] = 0x81;
++ }
++ }
++ }
++ else
++ {
++ context->key_x += rel_x;
++ context->key_y += rel_y;
++
++ return; /* discard those key codes */
++ }
++ }
++ /* a key was pressed, reset count */
++ context->key_x = 0;
++ context->key_y = 0;
++ context->last_count = 0;
++ }
++
+ lirc_buffer_write_1(context->plugin->rbuf, buf);
+ wake_up(&context->plugin->rbuf->wait_poll);
+ return;
+diff -NuBbwr lirc-0.8.3pre1-orig/remotes/imon/lircd.conf.imon-pad2keys lirc-0.8.3pre1/remotes/imon/lircd.conf.imon-pad2keys
+--- lirc-0.8.3pre1-orig/remotes/imon/lircd.conf.imon-pad2keys 1970-01-01 01:00:00.000000000 +0100
++++ lirc-0.8.3pre1/remotes/imon/lircd.conf.imon-pad2keys 2007-10-14 14:13:01.000000000 +0200
+@@ -0,0 +1,88 @@
++# Please make this file available to others
++# by sending it to <lirc@bartelmus.de>
++#
++# this config file was generated
++# using lirc-0.8.3pre1 (imon w/pad2keys patch)
++#
++# contributed by M.Brakemeier
++#
++# brand: SoundGraph
++# model no. of remote control: iMON-PAD
++# devices being controlled by this remote:
++#
++
++begin remote
++
++ name iMON-PAD
++ bits 32
++ eps 30
++ aeps 100
++
++ one 0 0
++ zero 0 0
++ gap 235965
++ min_repeat 1
++ toggle_bit 0
++
++ begin codes
++ AppExit 0x288195B7
++ Power 0x289115B7
++ Record 0x298115B7
++ Play 0x2A8115B7
++ Open 0x29B1D5B7
++ Rewind 0x2A8195B7
++ Pause 0x2A9115B7
++ FastForward 0x2B8115B7
++ PrevChapter 0x2B9115B7
++ Stop 0x2B9715B7
++ NextChapter 0x298195B7
++ Esc 0x2BB715B7
++ Eject 0x299395B7
++ AppLauncher 0x29B715B7
++ MultiMon 0x2AB195B7
++ TaskSwitcher 0x2A9395B7
++ Mute 0x2B9595B7
++ Vol+ 0x28A395B7
++ Vol- 0x28A595B7
++ Ch+ 0x289395B7
++ Ch- 0x288795B7
++ Timer 0x2B8395B7
++ 1 0x28B595B7
++ 2 0x2BB195B7
++ 3 0x28B195B7
++ 4 0x2A8595B7
++ 5 0x299595B7
++ 6 0x2AA595B7
++ 7 0x2B9395B7
++ 8 0x2A8515B7
++ 9 0x2AA115B7
++ 0 0x2BA595B7
++ ShiftTab 0x28B515B7
++ Tab 0x29A115B7
++ Red 0x2B8515B7 # MyMovie
++ Green 0x299195B7 # MyMusic
++ Blue 0x2BA115B7 # MyPhoto
++ Yellow 0x28A515B7 # MyTV
++ Bookmark 0x288515B7
++ Thumbnail 0x2AB715B7
++ AspectRatio 0x29A595B7
++ FullScreen 0x2AA395B7
++ Purple 0x29A295B7 # MyDVD
++ Menu 0x2BA385B7
++ Caption 0x298595B7
++ Language 0x2B8595B7
++ MouseKeyboard 0x299115B7
++ SelectSpace 0x2A9315B7
++ MouseMenu 0x28B715B7
++ MouseRightClick 0x688481B7
++ Enter 0x28A195B7
++ MouseLeftClick 0x688301B7
++ WindowsKey 0x2B8195B7
++ Backspace 0x28A115B7
++ Mouse_N 0x690281B7
++ Mouse_S 0x688291B7
++ Mouse_W 0x6A8281B7
++ Mouse_E 0x688A81B7
++ end codes
++
++end remote
diff --git a/app-misc/lirc/lirc-0.8.3_pre1.ebuild b/app-misc/lirc/lirc-0.8.3_pre1.ebuild
index 63e90c9cf9d5..a553b043a112 100644
--- a/app-misc/lirc/lirc-0.8.3_pre1.ebuild
+++ b/app-misc/lirc/lirc-0.8.3_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.3_pre1.ebuild,v 1.2 2007/10/14 10:16:47 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.3_pre1.ebuild,v 1.3 2007/10/17 20:48:26 zzam Exp $
inherit eutils linux-mod flag-o-matic autotools
@@ -146,6 +146,8 @@ pkg_setup() {
if use lirc_devices_imon_pad2keys; then
add_device imon_pad "device imon_pad (with converting pad input to keyspresses)"
+ ewarn "You need to set the option pad2keys_active=1"
+ ewarn "when loading the module lirc_imon"
fi
if use lirc_devices_xboxusb; then
@@ -233,7 +235,7 @@ src_unpack() {
edos2unix contrib/lirc.rules
# Apply patches needed for some special device-types
- use lirc_devices_imon_pad2keys && epatch "${FILESDIR}"/${PN}-0.8.1-imon-pad2keys.patch
+ epatch "${FILESDIR}"/${P}-imon-pad2keys.patch
use lirc_devices_remote_wonder_plus && epatch "${FILESDIR}"/lirc-0.8.3_pre1-remotewonderplus.patch
# remove parallel driver on SMP systems