summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-06-21 14:19:10 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-06-21 14:19:10 +0000
commit42e08e608f093558a2ce685558466a9b6907d695 (patch)
tree20a22c14bc092fb605f8b94fcd3fa7428d6a712a /app-misc/jot/jot-9.0.ebuild
parenttypos in comments, also make it depend on any rpm2targz eclass for now (diff)
downloadgentoo-2-42e08e608f093558a2ce685558466a9b6907d695.tar.gz
gentoo-2-42e08e608f093558a2ce685558466a9b6907d695.tar.bz2
gentoo-2-42e08e608f093558a2ce685558466a9b6907d695.zip
first rpm.eclass demonstration
Diffstat (limited to 'app-misc/jot/jot-9.0.ebuild')
-rw-r--r--app-misc/jot/jot-9.0.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/app-misc/jot/jot-9.0.ebuild b/app-misc/jot/jot-9.0.ebuild
index eafac3a2df8d..8206eaf77d51 100644
--- a/app-misc/jot/jot-9.0.ebuild
+++ b/app-misc/jot/jot-9.0.ebuild
@@ -1,29 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jot/jot-9.0.ebuild,v 1.1 2003/04/22 21:11:33 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jot/jot-9.0.ebuild,v 1.2 2003/06/21 14:19:02 liquidx Exp $
+inherit rpm
+
+RH_REV=3
DESCRIPTION="Print out increasing, decreasing, random, or redundant data"
HOMEPAGE="http://freshmeat.net/projects/bsd-jot/"
-SRC_URI="http://www.mit.edu/afs/athena/system/rhlinux/athena-9.0/free/SRPMS/athena-jot-9.0-3.src.rpm"
+SRC_URI="http://www.mit.edu/afs/athena/system/rhlinux/athena-${PV}/free/SRPMS/athena-${P}-${RH_REV}.src.rpm"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="rpm2targz"
-RDEPEND=""
-S="${WORKDIR}/athena-jot-9.0"
-src_unpack() {
- cd ${WORKDIR}
- rpm2targz ${DISTDIR}/${A}
- tar xzf athena-jot-9.0-3.src.tar.gz
- tar xzf athena-jot-9.0.tar.gz
-}
-
-src_compile() {
- econf || die
- emake || die
-}
+S="${WORKDIR}/athena-${P}"
src_install() {
einstall || die