summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-15 07:09:23 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-15 07:09:23 +0000
commitd07a7526399a7db8b6d08a3617422a099e9433e8 (patch)
treed0c85113cad30810fe122011a2f710e6cbd78efe /app-misc/golly
parentsci-libs/scikits_learn: Drop parallel build, has problem here (diff)
downloadgentoo-2-d07a7526399a7db8b6d08a3617422a099e9433e8.tar.gz
gentoo-2-d07a7526399a7db8b6d08a3617422a099e9433e8.tar.bz2
gentoo-2-d07a7526399a7db8b6d08a3617422a099e9433e8.zip
Add icon (thanks Samuel BAUER, bug 469608), python-single-r1 eclass.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-misc/golly')
-rw-r--r--app-misc/golly/ChangeLog9
-rw-r--r--app-misc/golly/golly-2.4-r1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-misc/golly/ChangeLog b/app-misc/golly/ChangeLog
index d1a4a8fc2ee2..2777b219fc53 100644
--- a/app-misc/golly/ChangeLog
+++ b/app-misc/golly/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/golly
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/ChangeLog,v 1.17 2012/12/26 18:16:45 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/ChangeLog,v 1.18 2013/05/15 07:09:23 xmw Exp $
+
+*golly-2.4-r1 (15 May 2013)
+
+ 15 May 2013; Michael Weber <xmw@gentoo.org> +golly-2.4-r1.ebuild:
+ Add icon (thanks Samuel BAUER, bug 469608), python-single-r1 eclass.
26 Dec 2012; Jeff Horelick <jdhore@gentoo.org> golly-2.4.ebuild:
marked x86 per bug 447700
diff --git a/app-misc/golly/golly-2.4-r1.ebuild b/app-misc/golly/golly-2.4-r1.ebuild
new file mode 100644
index 000000000000..5ae830d6491b
--- /dev/null
+++ b/app-misc/golly/golly-2.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/golly-2.4-r1.ebuild,v 1.1 2013/05/15 07:09:23 xmw Exp $
+
+EAPI=5
+WX_GTK_VER=2.8
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit eutils python-single-r1 wxwidgets
+
+DESCRIPTION="simulator for Conway's Game of Life and other cellular automata"
+HOMEPAGE="http://golly.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ sys-libs/zlib
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ sed -e 's:-O2::' -i configure Makefile.{am,in} || die
+}
+
+src_configure() {
+ econf \
+ --with-perl-shlib="libperl.so"
+}
+
+src_install() {
+ emake docdir= DESTDIR="${D}" install
+ newicon appicon.xpm ${PN}.xpm
+ dodoc README TODO
+}