summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-07 08:21:55 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-07 08:21:55 +0000
commit7eb7a52e832fd3e71e66c5d11d3ff8407e6757d5 (patch)
tree28b657a44497eb5d18fc104e2ef72e7e87b9399a /app-misc/gcal
parentVersion Bump (diff)
downloadgentoo-2-7eb7a52e832fd3e71e66c5d11d3ff8407e6757d5.tar.gz
gentoo-2-7eb7a52e832fd3e71e66c5d11d3ff8407e6757d5.tar.bz2
gentoo-2-7eb7a52e832fd3e71e66c5d11d3ff8407e6757d5.zip
Version Bump #322607, mv to GPL-3, cleaned up src_install
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/gcal')
-rw-r--r--app-misc/gcal/ChangeLog9
-rw-r--r--app-misc/gcal/gcal-3.6.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/app-misc/gcal/ChangeLog b/app-misc/gcal/ChangeLog
index 7802c91d3a71..4405423d2635 100644
--- a/app-misc/gcal/ChangeLog
+++ b/app-misc/gcal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gcal
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/ChangeLog,v 1.31 2009/04/14 10:11:05 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/ChangeLog,v 1.32 2010/06/07 08:21:55 jlec Exp $
+
+*gcal-3.6 (07 Jun 2010)
+
+ 07 Jun 2010; Justin Lecher <jlec@gentoo.org> +gcal-3.6.ebuild:
+ Version Bump #322607, mv to GPL-3, cleaned up src_install
14 Apr 2009; Ulrich Mueller <ulm@gentoo.org> -gcal-3.01-r2.ebuild:
Remove old.
diff --git a/app-misc/gcal/gcal-3.6.ebuild b/app-misc/gcal/gcal-3.6.ebuild
new file mode 100644
index 000000000000..7f2b8770c30e
--- /dev/null
+++ b/app-misc/gcal/gcal-3.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/gcal-3.6.ebuild,v 1.1 2010/06/07 08:21:55 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU Calendar - a replacement for cal"
+HOMEPAGE="http://www.gnu.org/software/gcal/gcal.html"
+SRC_URI="mirror://gnu/gcal/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="ncurses nls"
+
+DEPEND="nls? ( >=sys-devel/gettext-0.17 )"
+RDEPEND=""
+
+src_configure() {
+ tc-export CC
+ append-flags -D_GNU_SOURCE
+ econf \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_enable ncurses term)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ dodoc BUGS LIMITATIONS NEWS README THANKS TODO || die
+}