summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-03-18 17:49:55 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-03-18 17:49:55 +0000
commite0f38fc44c3e9398393fcd52a0469098539562d5 (patch)
tree59550c623715997a013847e8386e780ba0350272 /app-misc/g15daemon
parentNew package, pythonic API to the Linux uinput kernel module. (diff)
downloadgentoo-2-e0f38fc44c3e9398393fcd52a0469098539562d5.tar.gz
gentoo-2-e0f38fc44c3e9398393fcd52a0469098539562d5.tar.bz2
gentoo-2-e0f38fc44c3e9398393fcd52a0469098539562d5.zip
Fixed module loading logic. Moved ebuild with g510 support to -r8
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-misc/g15daemon')
-rw-r--r--app-misc/g15daemon/ChangeLog10
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.9.5.3.initd4
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild8
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.5.3-r8.ebuild (renamed from app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild)8
4 files changed, 19 insertions, 11 deletions
diff --git a/app-misc/g15daemon/ChangeLog b/app-misc/g15daemon/ChangeLog
index d69a18e8686f..07bf00024707 100644
--- a/app-misc/g15daemon/ChangeLog
+++ b/app-misc/g15daemon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/g15daemon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.43 2013/03/01 23:16:49 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.44 2013/03/18 17:49:55 polynomial-c Exp $
+
+*g15daemon-1.9.5.3-r8 (18 Mar 2013)
+
+ 18 Mar 2013; Lars Wendler <polynomial-c@gentoo.org>
+ -g15daemon-1.9.5.3-r6.ebuild, g15daemon-1.9.5.3-r7.ebuild,
+ +g15daemon-1.9.5.3-r8.ebuild, files/g15daemon-1.9.5.3.initd:
+ Non-maintainer commit. Fixed module loading logic. Moved ebuild with g510
+ support to -r8.
*g15daemon-1.9.5.3-r7 (01 Mar 2013)
diff --git a/app-misc/g15daemon/files/g15daemon-1.9.5.3.initd b/app-misc/g15daemon/files/g15daemon-1.9.5.3.initd
index d2775643f2c1..7976cff0144f 100644
--- a/app-misc/g15daemon/files/g15daemon-1.9.5.3.initd
+++ b/app-misc/g15daemon/files/g15daemon-1.9.5.3.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/files/g15daemon-1.9.5.3.initd,v 1.1 2013/03/01 23:16:50 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/files/g15daemon-1.9.5.3.initd,v 1.2 2013/03/18 17:49:55 polynomial-c Exp $
# Init script for g15daemon
@@ -19,7 +19,7 @@ depend() {
start_pre() {
# Does the input device already exist?
if [ -e "/proc/modules" ] ; then
- if [ ! -e "/dev/input/uinput" ] || [ ! -e "/dev/uinput" ] ; then
+ if [ ! -e "/dev/input/uinput" ] && [ ! -e "/dev/uinput" ] ; then
# We can load modules, but uinput device does not exist
einfo "Loading uinput module"
/sbin/modprobe uinput > /dev/null 2> /dev/null
diff --git a/app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild b/app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild
index 322ab802c99f..f33dbe50c7d9 100644
--- a/app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild
+++ b/app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild,v 1.1 2013/03/01 23:16:49 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild,v 1.2 2013/03/18 17:49:55 polynomial-c Exp $
EAPI=4
GENTOO_DEPEND_ON_PERL="no"
@@ -15,11 +15,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="perl python static-libs"
DEPEND="virtual/libusb:0
- >=dev-libs/libg15-9999
+ >=dev-libs/libg15-1.2.4
>=dev-libs/libg15render-1.2
perl? (
dev-lang/perl
@@ -31,9 +31,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-forgotten-open-mode.patch"
"${FILESDIR}/${P}-overflow-fix.patch"
- "${FILESDIR}/${P}-g510-keys.patch"
)
-
uinput_check() {
ebegin "Checking for uinput support"
local rc=1
diff --git a/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild b/app-misc/g15daemon/g15daemon-1.9.5.3-r8.ebuild
index f0e21d1feab5..dbf1343ff0f4 100644
--- a/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild
+++ b/app-misc/g15daemon/g15daemon-1.9.5.3-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild,v 1.2 2013/03/01 23:16:49 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r8.ebuild,v 1.1 2013/03/18 17:49:55 polynomial-c Exp $
EAPI=4
GENTOO_DEPEND_ON_PERL="no"
@@ -15,11 +15,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS=""
IUSE="perl python static-libs"
DEPEND="virtual/libusb:0
- >=dev-libs/libg15-1.2.4
+ >=dev-libs/libg15-9999
>=dev-libs/libg15render-1.2
perl? (
dev-lang/perl
@@ -31,7 +31,9 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-forgotten-open-mode.patch"
"${FILESDIR}/${P}-overflow-fix.patch"
+ "${FILESDIR}/${P}-g510-keys.patch"
)
+
uinput_check() {
ebegin "Checking for uinput support"
local rc=1