summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-08 03:30:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-08 03:30:39 +0000
commit886d7b663cd9b5a8f05b381e5a1bb6f81c2e6304 (patch)
tree1745f3bd5d841d4d217258dabbec648b212c3750 /app-misc/figlet
parentVersion bump. (diff)
downloadgentoo-2-886d7b663cd9b5a8f05b381e5a1bb6f81c2e6304.tar.gz
gentoo-2-886d7b663cd9b5a8f05b381e5a1bb6f81c2e6304.tar.bz2
gentoo-2-886d7b663cd9b5a8f05b381e5a1bb6f81c2e6304.zip
version bump (version numbering change per upstream) with ebuild submitted by Matthias Maier via bug #427700
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-misc/figlet')
-rw-r--r--app-misc/figlet/ChangeLog10
-rw-r--r--app-misc/figlet/figlet-2.2.5.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/app-misc/figlet/ChangeLog b/app-misc/figlet/ChangeLog
index 89ee14feae3f..b0387835a9ca 100644
--- a/app-misc/figlet/ChangeLog
+++ b/app-misc/figlet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/figlet
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/ChangeLog,v 1.39 2013/07/28 12:03:22 grobian Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/ChangeLog,v 1.40 2014/07/08 03:30:39 mr_bones_ Exp $
+
+*figlet-2.2.5 (08 Jul 2014)
+
+ 08 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org> +figlet-2.2.5.ebuild:
+ version bump (version numbering change per upstream) with ebuild submitted by
+ Matthias Maier via bug #427700
28 Jul 2013; Fabian Groffen <grobian@gentoo.org> figlet-222.ebuild:
Marked ~x64-macos, bug #416949
diff --git a/app-misc/figlet/figlet-2.2.5.ebuild b/app-misc/figlet/figlet-2.2.5.ebuild
new file mode 100644
index 000000000000..6100a5c01da6
--- /dev/null
+++ b/app-misc/figlet/figlet-2.2.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-2.2.5.ebuild,v 1.1 2014/07/08 03:30:38 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="program for making large letters out of ordinary text"
+HOMEPAGE="http://www.figlet.org/"
+SRC_URI="ftp://ftp.figlet.org/pub/figlet/program/unix/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+src_compile() {
+ emake clean
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ all
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ MANDIR="${EPREFIX}/usr/share/man" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ doman chkfont.6 figlet.6 figlist.6 showfigfonts.6
+ dodoc README figfont.txt
+
+ dobashcomp "${FILESDIR}"/figlet.bashcomp
+}