summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-03-20 18:38:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-03-20 18:38:33 +0000
commitefd6fb5cfe184c3709ff0487eedeb4a6f5d2a275 (patch)
tree95de5f396aa952473204b23958a70d85a1ebc3ba /app-misc/fdutils
parentVersion bump. (diff)
downloadgentoo-2-efd6fb5cfe184c3709ff0487eedeb4a6f5d2a275.tar.gz
gentoo-2-efd6fb5cfe184c3709ff0487eedeb4a6f5d2a275.tar.bz2
gentoo-2-efd6fb5cfe184c3709ff0487eedeb4a6f5d2a275.zip
bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-misc/fdutils')
-rw-r--r--app-misc/fdutils/ChangeLog13
-rw-r--r--app-misc/fdutils/fdutils-5.5.20060227.ebuild53
2 files changed, 64 insertions, 2 deletions
diff --git a/app-misc/fdutils/ChangeLog b/app-misc/fdutils/ChangeLog
index bdbabd43fdd0..bd7582e33541 100644
--- a/app-misc/fdutils/ChangeLog
+++ b/app-misc/fdutils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/fdutils
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/fdutils/ChangeLog,v 1.25 2010/09/09 18:24:17 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fdutils/ChangeLog,v 1.26 2013/03/20 18:38:33 ssuominen Exp $
+
+*fdutils-5.5.20060227 (20 Mar 2013)
+
+ 20 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +fdutils-5.5.20060227.ebuild:
+ Version bump wrt #337721 by Diego Elio Pettenò and Michael Mair-Keimberger;
+ and respect LDFLAGS using one-liner sed in ebuild. Fix building with recent
+ linux headers wrt #425316 by Peter Sliepenbeek. Import quite large Debian
+ patchset, containing 20 patches in total.
*fdutils-5.5-r2 (09 Sep 2010)
diff --git a/app-misc/fdutils/fdutils-5.5.20060227.ebuild b/app-misc/fdutils/fdutils-5.5.20060227.ebuild
new file mode 100644
index 000000000000..7331fea66e00
--- /dev/null
+++ b/app-misc/fdutils/fdutils-5.5.20060227.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fdutils/fdutils-5.5.20060227.ebuild,v 1.1 2013/03/20 18:38:33 ssuominen Exp $
+
+EAPI=5
+inherit eutils
+
+MY_P=${PN}_5.5-20060227
+
+DESCRIPTION="utilities for configuring and debugging the Linux floppy driver"
+HOMEPAGE="http://fdutils.linux.lu/"
+SRC_URI="mirror://debian/pool/main/f/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/f/${PN}/${MY_P}-6.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=sys-fs/mtools-4"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ virtual/os-headers
+ doc? ( virtual/texi2dvi )"
+
+S=${WORKDIR}/${PN}-5.5-20060227
+
+src_prepare() {
+ local d="${WORKDIR}"/debian/patches
+ EPATCH_SOURCE="${d}" epatch $(<"${d}"/series)
+ sed -i -e 's:{LDFLAFS}:(LDFLAGS):' src/Makefile.in || die #337721
+}
+
+src_configure() {
+ econf --enable-fdmount-floppy-only
+}
+
+src_compile() {
+ emake -j1 $(use doc || echo compile)
+}
+
+src_install() {
+ dodir /etc
+ use doc && dodir /usr/share/info
+
+ emake -j1 DESTDIR="${D}" install
+
+ # The copy in sys-apps/man-pages is more recent
+ rm -f "${ED}"/usr/share/man/man4/fd.4 || die
+
+ # Rename to match binary
+ mv "${ED}"/usr/share/man/man1/{makefloppies,MAKEFLOPPIES}.1 || die
+}