summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-02-02 20:42:11 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-02-02 20:42:11 +0000
commit4fa9babf57831b801783e0cff629a979afcbf81c (patch)
tree6b95e62666643390ded657e30416b06f9036979e /app-misc/digitemp
parentAdded support for xinerama flag. Thanks to James Le Cuirot <chewi@ffaura.com>... (diff)
downloadgentoo-2-4fa9babf57831b801783e0cff629a979afcbf81c.tar.gz
gentoo-2-4fa9babf57831b801783e0cff629a979afcbf81c.tar.bz2
gentoo-2-4fa9babf57831b801783e0cff629a979afcbf81c.zip
Version bumped. Closes 39946
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/ChangeLog9
-rw-r--r--app-misc/digitemp/Manifest2
-rw-r--r--app-misc/digitemp/digitemp-3.3.1.ebuild62
-rw-r--r--app-misc/digitemp/files/digest-digitemp-3.3.11
4 files changed, 72 insertions, 2 deletions
diff --git a/app-misc/digitemp/ChangeLog b/app-misc/digitemp/ChangeLog
index e0d64a1c88aa..e90df227855f 100644
--- a/app-misc/digitemp/ChangeLog
+++ b/app-misc/digitemp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/digitemp
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/ChangeLog,v 1.1 2003/09/15 14:06:56 seemant Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/ChangeLog,v 1.2 2004/02/02 20:42:11 mholzer Exp $
+
+*digitemp-3.3.1 (02 Feb 2004)
+
+ 02 Feb 2004; Martin Holzer <mholzer@gentoo.org> digitemp-3.3.1.ebuild:
+ Version bumped. Closes 39946
*digitemp-3.2.0 (15 Sep 2003)
diff --git a/app-misc/digitemp/Manifest b/app-misc/digitemp/Manifest
index 1bdd9863f77d..e5c5dec62009 100644
--- a/app-misc/digitemp/Manifest
+++ b/app-misc/digitemp/Manifest
@@ -1,3 +1,5 @@
+MD5 e5c80bad4cc23722c54cb329fc1799ac digitemp-3.3.1.ebuild 1873
MD5 1fc48011fb1db95114e5d008646881df ChangeLog 726
MD5 136101d14546a784335fe0d00e642abf digitemp-3.2.0.ebuild 1872
+MD5 97b7451b04d6c11f4379f845b552b682 files/digest-digitemp-3.3.1 66
MD5 be3c44f8d662d55090d70813c9b3adc9 files/digest-digitemp-3.2.0 66
diff --git a/app-misc/digitemp/digitemp-3.3.1.ebuild b/app-misc/digitemp/digitemp-3.3.1.ebuild
new file mode 100644
index 000000000000..b359b19b6567
--- /dev/null
+++ b/app-misc/digitemp/digitemp-3.3.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.3.1.ebuild,v 1.1 2004/02/02 20:42:11 mholzer Exp $
+
+IUSE="perl python"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Temperature logging and reporting using Dallas Semiconductor's iButtons and 1-Wire protocol"
+HOMEPAGE="http://www.digitemp.com http://www.ibutton.com"
+SRC_URI="http://www.digitemp.com/software/linux/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ # default is to compile to the ds9097u. local use flag takes care of
+ # passive ds9097. the ds9097u setting is what i have, so probably a safe
+ # default - nothing special here.
+ local target="ds9097u"
+ [ "${SERIAL_DRIVER}" = ds9097 ] && target="ds9097"
+ make clean
+
+ ewarn ""
+ ewarn "making for ${target} serial controller. if you would like support"
+ ewarn "for another controller, please set SERIAL_DRIVER=\"ds9097u\" or"
+ ewarn "SERIAL_DRIVER=\"ds9097\" as appropriate"
+ ewarn ""
+
+ make ${target}
+}
+
+src_install() {
+ dobin digitemp
+ dodoc README COPYING FAQ TODO
+
+ # method one: don't treat the examples as docs; place them somewhere else.
+ # then tell the user where to find this stuff. suitable alternative:
+ # specify exampledir="/usr/share/doc/${PF}"
+
+ local exampledir="/usr/share/${PN}"
+ local perldir="${exampledir}/perl_examples"
+ insinto ${perldir}
+ doins perl/*
+ local pythondir="${exampledir}/python_examples"
+ insinto ${pythondir}
+ doins python/*
+ local rrdbdir="${exampledir}/rrdb_examples"
+ insinto ${rrdbdir}
+ doins rrdb/*
+}
+
+pkg_postinst() {
+ ewarn "set the SERIAL_DRIVER environment variable to ds9097 to build"
+ ewarn "for that controller instead"
+ einfo ""
+ einfo "examples of using digitemp with python, perl, and rrdtool are"
+ einfo "located in ${exampledir}"
+ einfo ""
+}
diff --git a/app-misc/digitemp/files/digest-digitemp-3.3.1 b/app-misc/digitemp/files/digest-digitemp-3.3.1
new file mode 100644
index 000000000000..891df07eb752
--- /dev/null
+++ b/app-misc/digitemp/files/digest-digitemp-3.3.1
@@ -0,0 +1 @@
+MD5 d0bffd1b566965e27f15b3213050d3a5 digitemp-3.3.1.tar.gz 209461