summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-23 07:11:07 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-23 07:11:07 +0000
commitc270f9ef3c66106b95692364158b0ca79766271f (patch)
treee1032664eba5405ad3f38014a289f32b08accb98 /app-misc/detox
parentBump, tests may fail with newest sqlalchemy (diff)
downloadgentoo-2-c270f9ef3c66106b95692364158b0ca79766271f.tar.gz
gentoo-2-c270f9ef3c66106b95692364158b0ca79766271f.tar.bz2
gentoo-2-c270f9ef3c66106b95692364158b0ca79766271f.zip
Make build format-security save, bug #521084; bump to EAPI=5; drop base.eclass usage
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'app-misc/detox')
-rw-r--r--app-misc/detox/ChangeLog9
-rw-r--r--app-misc/detox/detox-1.2.0-r3.ebuild47
-rw-r--r--app-misc/detox/files/detox-1.2.0-format-security.patch72
3 files changed, 127 insertions, 1 deletions
diff --git a/app-misc/detox/ChangeLog b/app-misc/detox/ChangeLog
index 2dc7344cb293..e7a8f6392268 100644
--- a/app-misc/detox/ChangeLog
+++ b/app-misc/detox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/detox
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/ChangeLog,v 1.34 2015/06/09 11:38:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/ChangeLog,v 1.35 2015/06/23 07:11:07 jlec Exp $
+
+*detox-1.2.0-r3 (23 Jun 2015)
+
+ 23 Jun 2015; Justin Lecher <jlec@gentoo.org> +detox-1.2.0-r3.ebuild,
+ +files/detox-1.2.0-format-security.patch:
+ Make build format-security save, bug #521084; bump to EAPI=5; drop base.eclass
+ usage
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/app-misc/detox/detox-1.2.0-r3.ebuild b/app-misc/detox/detox-1.2.0-r3.ebuild
new file mode 100644
index 000000000000..ed46ceaa2657
--- /dev/null
+++ b/app-misc/detox/detox-1.2.0-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/detox-1.2.0-r3.ebuild,v 1.1 2015/06/23 07:11:07 jlec Exp $
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="Safely remove spaces and strange characters from filenames"
+HOMEPAGE="http://detox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-parallel.patch
+ "${FILESDIR}"/${P}-LDFLAGS.patch
+ "${FILESDIR}"/${P}-change-default-sequence-to-use-utf8-table.patch
+ "${FILESDIR}"/${P}-install-missing-file.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ )
+
+src_prepare() {
+ sed \
+ -e 's:Fl c Ar:Fl f Ar:g' \
+ -i ${PN}.1 || die
+ epatch "${PATCHES[@]}"
+ sed \
+ -e '/detoxrc.sample/d' \
+ -i Makefile.in || die
+}
+
+src_configure() {
+ econf --with-popt="${EPREFIX}/usr"
+}
diff --git a/app-misc/detox/files/detox-1.2.0-format-security.patch b/app-misc/detox/files/detox-1.2.0-format-security.patch
new file mode 100644
index 000000000000..c03a98aa046c
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-format-security.patch
@@ -0,0 +1,72 @@
+ parse_options_getopt.c | 8 ++++----
+ parse_options_popt.c | 8 ++++----
+ 2 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/parse_options_getopt.c b/parse_options_getopt.c
+index 1f80966..ea2b266 100644
+--- a/parse_options_getopt.c
++++ b/parse_options_getopt.c
+@@ -98,9 +98,9 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
+ #endif
+ switch (optcode) {
+ case 'h':
+- printf(usage_message);
++ printf("%s", usage_message);
+ printf("\n");
+- printf(help_message);
++ printf("%s", help_message);
+ exit(EXIT_SUCCESS);
+
+ case 'f':
+@@ -138,7 +138,7 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
+ exit(EXIT_SUCCESS);
+
+ case '?':
+- printf(usage_message);
++ printf("%s", usage_message);
+ exit(EXIT_SUCCESS);
+
+ case 0:
+@@ -195,7 +195,7 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
+ }
+ else {
+ #ifndef INLINE_MODE
+- printf(usage_message);
++ printf("%s", usage_message);
+ exit(EXIT_FAILURE);
+ #endif
+ }
+diff --git a/parse_options_popt.c b/parse_options_popt.c
+index 60dad7a..370c3cc 100644
+--- a/parse_options_popt.c
++++ b/parse_options_popt.c
+@@ -94,9 +94,9 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
+ while ((c = poptGetNextOpt(optCon)) >= 0) {
+ switch (c) {
+ case 'h':
+- printf(usage_message);
++ printf("%s", usage_message);
+ printf("\n");
+- printf(help_message);
++ printf("%s", help_message);
+ exit(EXIT_SUCCESS);
+
+ case 'f':
+@@ -142,7 +142,7 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
+ break;
+
+ case '?':
+- printf(usage_message);
++ printf("%s", usage_message);
+ exit(EXIT_SUCCESS);
+
+ }
+@@ -177,7 +177,7 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
+
+ #ifndef INLINE_MODE
+ if (i == 0) {
+- fprintf(stderr, usage_message);
++ fprintf(stderr, "%s", usage_message);
+ exit(EXIT_FAILURE);
+ }
+ #endif