summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-09-24 15:48:06 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-09-24 15:48:06 +0000
commit193b2ecc8241347a16ef228f2606d99e30d681a9 (patch)
treefb8fdebef495b93acec50af6fe70ddb680205261 /app-leechcraft/lc-monocle
parentBump LeechCraft to 0.6.0 (diff)
downloadgentoo-2-193b2ecc8241347a16ef228f2606d99e30d681a9.tar.gz
gentoo-2-193b2ecc8241347a16ef228f2606d99e30d681a9.tar.bz2
gentoo-2-193b2ecc8241347a16ef228f2606d99e30d681a9.zip
Bump LeechCraft to 0.6.0
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-monocle')
-rw-r--r--app-leechcraft/lc-monocle/ChangeLog7
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-leechcraft/lc-monocle/ChangeLog b/app-leechcraft/lc-monocle/ChangeLog
index 9324ed85f507..724d3dc70016 100644
--- a/app-leechcraft/lc-monocle/ChangeLog
+++ b/app-leechcraft/lc-monocle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-monocle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.7 2013/07/18 12:47:45 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.8 2013/09/24 15:48:06 maksbotan Exp $
+
+*lc-monocle-0.6.0 (24 Sep 2013)
+
+ 24 Sep 2013; Maxim Koltsov <maksbotan@gentoo.org> +lc-monocle-0.6.0.ebuild:
+ Bump LeechCraft to 0.6.0
*lc-monocle-0.5.99 (18 Jul 2013)
diff --git a/app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild b/app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild
new file mode 100644
index 000000000000..64422e62592f
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild,v 1.1 2013/09/24 15:48:06 maksbotan Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +djvu doc +fb2 +pdf +spectre"
+
+RDEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )
+ spectre? ( app-text/libspectre )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}