summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-09-24 15:40:58 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-09-24 15:40:58 +0000
commitb5fb9c42f4ffa4fef1030c3d313cab3b7835e386 (patch)
tree17385603608841d64edfbbec174dfc2c4a1803f2 /app-leechcraft/lc-aggregator
parentBump LeechCraft to 0.6.0 (diff)
downloadgentoo-2-b5fb9c42f4ffa4fef1030c3d313cab3b7835e386.tar.gz
gentoo-2-b5fb9c42f4ffa4fef1030c3d313cab3b7835e386.tar.bz2
gentoo-2-b5fb9c42f4ffa4fef1030c3d313cab3b7835e386.zip
Bump LeechCraft to 0.6.0
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-aggregator')
-rw-r--r--app-leechcraft/lc-aggregator/ChangeLog7
-rw-r--r--app-leechcraft/lc-aggregator/lc-aggregator-0.6.0.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/app-leechcraft/lc-aggregator/ChangeLog b/app-leechcraft/lc-aggregator/ChangeLog
index 3b7bbea5e2f4..9108c424d441 100644
--- a/app-leechcraft/lc-aggregator/ChangeLog
+++ b/app-leechcraft/lc-aggregator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-aggregator
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/ChangeLog,v 1.6 2013/07/18 12:39:50 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/ChangeLog,v 1.7 2013/09/24 15:40:58 maksbotan Exp $
+
+*lc-aggregator-0.6.0 (24 Sep 2013)
+
+ 24 Sep 2013; Maxim Koltsov <maksbotan@gentoo.org> +lc-aggregator-0.6.0.ebuild:
+ Bump LeechCraft to 0.6.0
*lc-aggregator-0.5.99 (18 Jul 2013)
diff --git a/app-leechcraft/lc-aggregator/lc-aggregator-0.6.0.ebuild b/app-leechcraft/lc-aggregator/lc-aggregator-0.6.0.ebuild
new file mode 100644
index 000000000000..de2af7cd233d
--- /dev/null
+++ b/app-leechcraft/lc-aggregator/lc-aggregator-0.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/lc-aggregator-0.6.0.ebuild,v 1.1 2013/09/24 15:40:58 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug mysql +sqlite postgres"
+
+DEPEND="~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+ dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-downloader-http"
+
+REQUIRED_USE="|| ( mysql sqlite postgres )"
+
+pkg_setup(){
+ if use mysql; then
+ ewarn "Support for MySQL databases is experimental and is more likely"
+ ewarn "to contain bugs or mishandle your data than other storage"
+ ewarn "backends. If you do not plan testing the MySQL storage backend"
+ ewarn "itself, consider using other backends."
+ ewarn "Anyway, it is perfectly safe to enable the mysql use flag as"
+ ewarn "long as at least one other storage is enabled since you will"
+ ewarn "be able to choose another storage backend at run time."
+ fi
+}