summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-28 15:22:23 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-28 15:22:23 +0000
commitef43f105e6046743b43507218f2bebd884829119 (patch)
treee62580e2336a77f0179704b519d7e91ade385b25 /app-laptop/omnibook/omnibook-20090628.ebuild
parentStable on alpha, bug #275404 (diff)
downloadgentoo-2-ef43f105e6046743b43507218f2bebd884829119.tar.gz
gentoo-2-ef43f105e6046743b43507218f2bebd884829119.tar.bz2
gentoo-2-ef43f105e6046743b43507218f2bebd884829119.zip
Taking maintainership. remove old, bump snapshot
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop/omnibook/omnibook-20090628.ebuild')
-rw-r--r--app-laptop/omnibook/omnibook-20090628.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-laptop/omnibook/omnibook-20090628.ebuild b/app-laptop/omnibook/omnibook-20090628.ebuild
new file mode 100644
index 000000000000..2b8a6a5b85d8
--- /dev/null
+++ b/app-laptop/omnibook/omnibook-20090628.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/omnibook/omnibook-20090628.ebuild,v 1.1 2009/06/28 15:22:23 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+DESCRIPTION="Linux kernel module for (but not limited to) HP Omnibook support"
+HOMEPAGE="http://www.sourceforge.net/projects/omnibook"
+# Revision 280 from upstream SVN repository
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 -ppc ~x86"
+IUSE=""
+
+MODULE_NAMES="omnibook(char:)"
+BUILD_TARGETS=" "
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNEL=${KV_MAJOR}.${KV_MINOR} KSRC=${KV_DIR}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/remove_owner.patch"
+}
+
+src_install() {
+ dodoc doc/*
+ docinto misc
+ dodoc misc/*.patch misc/*.txt
+ docinto hotkeys
+ dodoc misc/hotkeys/*
+
+ linux-mod_src_install
+}