summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-12-24 14:48:24 +0000
committerNaohiro Aota <naota@gentoo.org>2013-12-24 14:48:24 +0000
commit5baee3d7e41af1626875dd4fe8a86b71dab19f20 (patch)
treebff6b5811f48bd12dc5994316d5198f98e2429b3 /app-i18n
parentdev-python/argcomplete: New package, ebuild written by me (diff)
downloadgentoo-2-5baee3d7e41af1626875dd4fe8a86b71dab19f20.tar.gz
gentoo-2-5baee3d7e41af1626875dd4fe8a86b71dab19f20.tar.bz2
gentoo-2-5baee3d7e41af1626875dd4fe8a86b71dab19f20.zip
version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-anthy/ChangeLog7
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.4.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index ba46c6724755..8acbaba18413 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.45 2013/09/05 18:22:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.46 2013/12/24 14:48:24 naota Exp $
+
+*ibus-anthy-1.5.4 (24 Dec 2013)
+
+ 24 Dec 2013; Naohiro Aota <naota@gentoo.org> +ibus-anthy-1.5.4.ebuild:
+ version bump.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> ibus-anthy-1.5.0.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.4.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.4.ebuild
new file mode 100644
index 000000000000..8441ffb45609
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.5.4.ebuild,v 1.1 2013/12/24 14:48:24 naota Exp $
+
+EAPI=5
+PYTHON_DEPEND="2:2.5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit eutils python-single-r1 autotools gnome2-utils
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz
+ https://raw.github.com/ibus/ibus-anthy/${PV}/engine/anthy.i"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="deprecated nls"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-i18n/ibus-1.5.0
+ app-i18n/anthy
+ deprecated? ( >=dev-python/pygtk-2.15.2 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection
+ dev-util/intltool
+ virtual/pkgconfig
+ deprecated? ( dev-lang/swig )
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_prepare() {
+ >py-compile #397497
+ cp "${DISTDIR}"/anthy.i "${S}"/engine # deal with packaging bug
+}
+
+src_configure() {
+ econf --enable-private-png \
+ $(use_enable deprecated pygtk2-anthy) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ find "${ED}" -name '*.la' -type f -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ elog
+ elog "# emerge app-dicts/kasumi"
+ elog
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}