summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-26 20:29:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-26 20:29:59 +0000
commit3ee9e8e5d4dc569423c02296f347ac3e941c52d4 (patch)
tree966ee49251aa0e87deaf6f9857d973f6c87d8212 /app-forensics
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-3ee9e8e5d4dc569423c02296f347ac3e941c52d4.tar.gz
gentoo-2-3ee9e8e5d4dc569423c02296f347ac3e941c52d4.tar.bz2
gentoo-2-3ee9e8e5d4dc569423c02296f347ac3e941c52d4.zip
Bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libewf/ChangeLog9
-rw-r--r--app-forensics/libewf/libewf-20100226.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index bc0e32547e2c..2589fcf92d9a 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/libewf
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.6 2009/11/08 11:54:19 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.7 2010/02/26 20:29:59 patrick Exp $
+
+*libewf-20100226 (26 Feb 2010)
+
+ 26 Feb 2010; Patrick Lauer <patrick@gentoo.org> +libewf-20100226.ebuild:
+ Bump
*libewf-20091108 (08 Nov 2009)
diff --git a/app-forensics/libewf/libewf-20100226.ebuild b/app-forensics/libewf/libewf-20100226.ebuild
new file mode 100644
index 000000000000..00ee21c46344
--- /dev/null
+++ b/app-forensics/libewf/libewf-20100226.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20100226.ebuild,v 1.1 2010/02/26 20:29:59 patrick Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://libewf.sourceforge.net"
+SRC_URI="mirror://sourceforge/libewf/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="debug rawio unicode"
+
+DEPEND="
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable unicode wide-character-type) \
+ $(use_enable rawio raw-access) \
+ $(use_enable debug verbose-output) \
+ $(use_enable debug debug-output)
+ emake
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README documents/*.txt
+ doman manuals/*.1 manuals/*.3
+}