summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-19 18:23:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-19 18:23:13 +0000
commit4055821aa4a79ee530c25b39bdf54029b958b646 (patch)
tree76d4a84ad3421ba01be85ffb63a03c243a7c9233 /app-forensics/openscap
parentStable on amd64 wrt bug #379681 (diff)
downloadgentoo-2-4055821aa4a79ee530c25b39bdf54029b958b646.tar.gz
gentoo-2-4055821aa4a79ee530c25b39bdf54029b958b646.tar.bz2
gentoo-2-4055821aa4a79ee530c25b39bdf54029b958b646.zip
Version bump
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics/openscap')
-rw-r--r--app-forensics/openscap/ChangeLog7
-rw-r--r--app-forensics/openscap/openscap-0.7.4.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/app-forensics/openscap/ChangeLog b/app-forensics/openscap/ChangeLog
index 55d998e8629d..42a06c9ab563 100644
--- a/app-forensics/openscap/ChangeLog
+++ b/app-forensics/openscap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/openscap
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.8 2011/08/19 18:18:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.9 2011/08/19 18:23:13 hwoarang Exp $
+
+*openscap-0.7.4 (19 Aug 2011)
+
+ 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +openscap-0.7.4.ebuild:
+ Version bump
19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> openscap-0.7.3.ebuild:
Stable on amd64 wrt bug #379681
diff --git a/app-forensics/openscap/openscap-0.7.4.ebuild b/app-forensics/openscap/openscap-0.7.4.ebuild
new file mode 100644
index 000000000000..80cae5c67d67
--- /dev/null
+++ b/app-forensics/openscap/openscap-0.7.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-0.7.4.ebuild,v 1.1 2011/08/19 18:23:13 hwoarang Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit eutils multilib python bash-completion
+
+DESCRIPTION="Framework which enables integration with the Security Content Automation Protocol (SCAP)"
+HOMEPAGE="http://www.open-scap.org/"
+SRC_URI="http://www.open-scap.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion doc nss perl python sql"
+RESTRICT="test"
+
+RDEPEND="!nss? ( dev-libs/libgcrypt )
+ nss? ( dev-libs/nss )
+ sql? ( dev-db/opendbx )
+ dev-libs/libpcre
+ dev-libs/libxml2
+ dev-libs/libxslt
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local myconf
+ if use python || use perl ; then
+ myconf+=" --enable-bindings"
+ else
+ myconf+=" --disable-bindings"
+ fi
+ if use nss ; then
+ myconf+=" --with-crypto=nss3"
+ else
+ myconf+=" --with-crypto=gcrypt"
+ fi
+ econf ${myconf}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ find "${D}" -name '*.la' -delete || die
+ sed -i 's/^Description/&:/' ${D}/usr/$(get_libdir)/pkgconfig/libopenscap.pc || die
+ #--enable-bindings enable all bindings, clean unwanted bindings
+ if use python && ! use perl ; then
+ rm -rf "${D}"/usr/$(get_libdir)/perl5 || die
+ fi
+ if ! use python && use perl ; then
+ rm -rf "${D}"/$(python_get_sitedir) || die
+ fi
+ if use doc ; then
+ dohtml -r docs/html/* || die
+ dodoc docs/examples/* || die
+ fi
+ if ! use bash-completion ; then
+ rm -rf "${D}"/etc/bash_completion.d || die
+ fi
+}