summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-26 20:43:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-26 20:43:37 +0000
commitf2c28e0bdc586e974d15b14a628444454a591098 (patch)
tree9134ace6edbfb55dde0d4c52b6e122cea4895203 /app-forensics/air/air-2.0.0.ebuild
parentFix CVE-2009-2347 again wrt security #307001. (diff)
downloadgentoo-2-f2c28e0bdc586e974d15b14a628444454a591098.tar.gz
gentoo-2-f2c28e0bdc586e974d15b14a628444454a591098.tar.bz2
gentoo-2-f2c28e0bdc586e974d15b14a628444454a591098.zip
Bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics/air/air-2.0.0.ebuild')
-rw-r--r--app-forensics/air/air-2.0.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-forensics/air/air-2.0.0.ebuild b/app-forensics/air/air-2.0.0.ebuild
new file mode 100644
index 000000000000..e476d155142f
--- /dev/null
+++ b/app-forensics/air/air-2.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/air/air-2.0.0.ebuild,v 1.1 2010/02/26 20:43:37 patrick Exp $
+
+DESCRIPTION="A GUI front-end to dd/dcfldd"
+HOMEPAGE="http://air-imager.sourceforge.net/"
+SRC_URI="mirror://sourceforge/air-imager/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-perl/perl-tk-804.027
+ userland_GNU? ( app-arch/sharutils )
+ sys-apps/sed
+ dev-lang/perl"
+
+RDEPEND="app-arch/mt-st
+ sys-apps/dcfldd
+ net-analyzer/netcat
+ net-analyzer/cryptcat
+ dev-lang/perl
+ userland_GNU? ( sys-apps/coreutils )"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+
+ PERLTK_VER=$(best_version dev-perl/perl-tk)
+ export PERLTK_VER=${PERLTK_VER:17:7}
+
+ env INTERACTIVE=no INSTALL_DIR="${D}/usr" TEMP_DIR="${T}" \
+ FINAL_INSTALL_DIR=/usr \
+ ./install-${P} \
+ || die "failed to install - please attach ${T}/air-install.log to a bug report at http://bugs.gentoo.org"
+
+ dodoc README
+
+ dodoc "${T}/air-install.log"
+
+ chown -R root:0 "${D}"
+ fowners root:users /usr/share/air/logs
+ fperms ug+rwx /usr/share/air/logs
+ if [ -p "${D}usr/share/air/air-fifo" ]; then
+ fperms ug+rw /usr/share/air/air-fifo
+ fowners root:users /usr/share/air/air-fifo
+ fi
+ fperms a+x /usr/bin/air
+}
+
+pkg_postinst() {
+ elog "The author, steve@unixgurus.com, would appreciate an email of the install file /usr/share/doc/${PF}/air-install.log"
+}