summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-03-31 16:51:01 +0000
committerUlrich Müller <ulm@gentoo.org>2015-03-31 16:51:01 +0000
commit02045202a2fd43feba02bff7da99729f5e3e6d11 (patch)
tree3762a66c03ebf6ed190a4dee12a6008943d02754 /app-eselect/eselect-mesa/eselect-mesa-0.0.9.ebuild
parentMove package from app-admin to app-eselect category. (diff)
downloadgentoo-2-02045202a2fd43feba02bff7da99729f5e3e6d11.tar.gz
gentoo-2-02045202a2fd43feba02bff7da99729f5e3e6d11.tar.bz2
gentoo-2-02045202a2fd43feba02bff7da99729f5e3e6d11.zip
Move package from app-admin to app-eselect category.
(Portage version: 2.2.18/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-eselect/eselect-mesa/eselect-mesa-0.0.9.ebuild')
-rw-r--r--app-eselect/eselect-mesa/eselect-mesa-0.0.9.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-eselect/eselect-mesa/eselect-mesa-0.0.9.ebuild b/app-eselect/eselect-mesa/eselect-mesa-0.0.9.ebuild
new file mode 100644
index 000000000000..1de4da2061ca
--- /dev/null
+++ b/app-eselect/eselect-mesa/eselect-mesa-0.0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-eselect/eselect-mesa/eselect-mesa-0.0.9.ebuild,v 1.1 2015/03/31 16:51:01 ulm Exp $
+
+EAPI=3
+
+DESCRIPTION="Utility to change the Mesa OpenGL driver being used"
+HOMEPAGE="http://www.gentoo.org/"
+
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-admin/eselect-1.2.4
+ >=app-shells/bash-4"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins mesa.eselect || die
+}
+
+pkg_postinst() {
+ if has_version ">=media-libs/mesa-7.9" && \
+ ! [ -f "${EROOT}"/usr/share/mesa/eselect-mesa.conf ]; then
+ eerror "Rebuild media-libs/mesa for ${PN} to work."
+ fi
+}