summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-29 03:48:40 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-29 03:48:40 +0000
commitfc3bd57dad4b299cde8a988d91a57a495f1b20ea (patch)
treef388d66db7c416e8e365149c257e2434fe0b73e6 /app-emulation
parentFixed compilation error with xorg-x11 and fixed einstall; bug #72169. (diff)
downloadgentoo-2-fc3bd57dad4b299cde8a988d91a57a495f1b20ea.tar.gz
gentoo-2-fc3bd57dad4b299cde8a988d91a57a495f1b20ea.tar.bz2
gentoo-2-fc3bd57dad4b299cde8a988d91a57a495f1b20ea.zip
Re-order ALSA includes so they dont conflict with wine headers #94272 by Ernst de Haan.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog9
-rw-r--r--app-emulation/wine/files/wine-20050524-alsa-headers.patch29
-rw-r--r--app-emulation/wine/wine-20041019-r3.ebuild5
-rw-r--r--app-emulation/wine/wine-20050111-r1.ebuild3
-rw-r--r--app-emulation/wine/wine-20050211.ebuild3
-rw-r--r--app-emulation/wine/wine-20050310-r1.ebuild3
-rw-r--r--app-emulation/wine/wine-20050419.ebuild3
-rw-r--r--app-emulation/wine/wine-20050524.ebuild3
8 files changed, 50 insertions, 8 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index dfd0aab1d664..ab8a7f214059 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.96 2005/05/26 00:51:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.97 2005/05/29 03:48:40 vapier Exp $
+
+ 29 May 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/wine-20050524-alsa-headers.patch, wine-20041019-r3.ebuild,
+ wine-20050111-r1.ebuild, wine-20050211.ebuild, wine-20050310-r1.ebuild,
+ wine-20050419.ebuild, wine-20050524.ebuild:
+ Re-order ALSA includes so they dont conflict with wine headers #94272 by
+ Ernst de Haan.
*wine-20050524 (26 May 2005)
diff --git a/app-emulation/wine/files/wine-20050524-alsa-headers.patch b/app-emulation/wine/files/wine-20050524-alsa-headers.patch
new file mode 100644
index 000000000000..74e47895009f
--- /dev/null
+++ b/app-emulation/wine/files/wine-20050524-alsa-headers.patch
@@ -0,0 +1,29 @@
+Reorder the alsa includes so the wine defines dont stomp
+the alsa prototypes.
+
+Patch by Ed Catmur
+
+http://bugs.gentoo.org/94272
+
+--- dlls/winmm/winealsa/audio.c
++++ dlls/winmm/winealsa/audio.c
+@@ -45,6 +45,9 @@
+ # include <sys/mman.h>
+ #endif
+ #include "windef.h"
++#define ALSA_PCM_NEW_HW_PARAMS_API
++#define ALSA_PCM_NEW_SW_PARAMS_API
++#include "alsa.h"
+ #include "winbase.h"
+ #include "wingdi.h"
+ #include "winerror.h"
+@@ -58,9 +61,6 @@
+ #include "ks.h"
+ #include "ksguid.h"
+ #include "ksmedia.h"
+-#define ALSA_PCM_NEW_HW_PARAMS_API
+-#define ALSA_PCM_NEW_SW_PARAMS_API
+-#include "alsa.h"
+ #include "wine/library.h"
+ #include "wine/unicode.h"
+ #include "wine/debug.h"
diff --git a/app-emulation/wine/wine-20041019-r3.ebuild b/app-emulation/wine/wine-20041019-r3.ebuild
index b19f3a1612ca..f7745ff62c3d 100644
--- a/app-emulation/wine/wine-20041019-r3.ebuild
+++ b/app-emulation/wine/wine-20041019-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.12 2005/03/29 01:35:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.13 2005/05/29 03:48:40 vapier Exp $
inherit eutils flag-o-matic
@@ -36,7 +36,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack Wine-${PV}.tar.gz
- cd ${S}
+ cd "${S}"
+ epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch ${FILESDIR}/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
diff --git a/app-emulation/wine/wine-20050111-r1.ebuild b/app-emulation/wine/wine-20050111-r1.ebuild
index ef923f83d273..5516513b12be 100644
--- a/app-emulation/wine/wine-20050111-r1.ebuild
+++ b/app-emulation/wine/wine-20050111-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111-r1.ebuild,v 1.4 2005/03/29 01:35:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111-r1.ebuild,v 1.5 2005/05/29 03:48:40 vapier Exp $
inherit eutils flag-o-matic
@@ -36,6 +36,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack Wine-${PV}.tar.gz
cd "${S}"
+ epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/${P}-upstream-registry-fix.patch.bz2 #85387
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index 2c69f2a9b4a1..84a70f7bda36 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.9 2005/04/07 22:59:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.10 2005/05/29 03:48:40 vapier Exp $
inherit eutils flag-o-matic
@@ -56,6 +56,7 @@ src_unpack() {
unpack Wine-${PV}.tar.gz
cd "${S}"
+ epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
epatch "${FILESDIR}"/20050211-docs.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
diff --git a/app-emulation/wine/wine-20050310-r1.ebuild b/app-emulation/wine/wine-20050310-r1.ebuild
index 5c05df562161..95c1bd74d3f9 100644
--- a/app-emulation/wine/wine-20050310-r1.ebuild
+++ b/app-emulation/wine/wine-20050310-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.2 2005/04/19 16:40:13 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.3 2005/05/29 03:48:40 vapier Exp $
inherit eutils flag-o-matic
@@ -56,6 +56,7 @@ src_unpack() {
unpack Wine-${PV}.tar.gz
cd "${S}"
+ epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/wine-20050310-upstream-colortable.patch #88715
diff --git a/app-emulation/wine/wine-20050419.ebuild b/app-emulation/wine/wine-20050419.ebuild
index ebd2d4c9a029..7334b142a4a0 100644
--- a/app-emulation/wine/wine-20050419.ebuild
+++ b/app-emulation/wine/wine-20050419.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.4 2005/05/08 17:20:49 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.5 2005/05/29 03:48:40 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -56,6 +56,7 @@ src_unpack() {
unpack Wine-${PV}.tar.gz
cd "${S}"
+ epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/20041019-no-stack.patch #66002
diff --git a/app-emulation/wine/wine-20050524.ebuild b/app-emulation/wine/wine-20050524.ebuild
index 33bdb3b31a37..ac8f757ee3df 100644
--- a/app-emulation/wine/wine-20050524.ebuild
+++ b/app-emulation/wine/wine-20050524.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.2 2005/05/27 02:13:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.3 2005/05/29 03:48:40 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -56,6 +56,7 @@ src_unpack() {
unpack Wine-${PV}.tar.gz
cd "${S}"
+ epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/20041019-no-stack.patch #66002