summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-01-19 19:24:40 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-01-19 19:24:40 +0000
commite10cbb0ed13f052e9589875e55eae43578cbfe0b (patch)
tree311894dc84a454e093b097fb86c9aeb666881a65 /app-emulation
parentminor fixes (diff)
downloadgentoo-2-e10cbb0ed13f052e9589875e55eae43578cbfe0b.tar.gz
gentoo-2-e10cbb0ed13f052e9589875e55eae43578cbfe0b.tar.bz2
gentoo-2-e10cbb0ed13f052e9589875e55eae43578cbfe0b.zip
version bump
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog8
-rw-r--r--app-emulation/wine/files/digest-wine-200301151
-rw-r--r--app-emulation/wine/wine-20030115.ebuild117
3 files changed, 125 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 4857ce3fea6a..df12a876e719 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.26 2002/12/13 10:56:08 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.27 2003/01/19 19:24:40 lu_zero Exp $
+
+*wine-20030115 (19 Jan 2003)
+
+ 19 Jan 2003; Luca Barbato <lu_zero@gentoo.org> : wine-20030115.ebuild
+ Version bump.
+
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/app-emulation/wine/files/digest-wine-20030115 b/app-emulation/wine/files/digest-wine-20030115
new file mode 100644
index 000000000000..d97b452b8364
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20030115
@@ -0,0 +1 @@
+MD5 31169eae48d2d51e6771fafd1b12f8d2 Wine-20030115.tar.gz 8235786
diff --git a/app-emulation/wine/wine-20030115.ebuild b/app-emulation/wine/wine-20030115.ebuild
new file mode 100644
index 000000000000..760dee608898
--- /dev/null
+++ b/app-emulation/wine/wine-20030115.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20030115.ebuild,v 1.1 2003/01/19 19:24:40 lu_zero Exp $
+
+IUSE="nas arts cups opengl alsa"
+
+DESCRIPTION="Wine is a free implementation of Windows(tm) on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc "
+DEPEND="virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ dev-lang/tcl dev-lang/tk
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install () {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${FILESDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${FILESDIR}/${P}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine
+ rm regedit-wine wine
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+ einfo ""
+ einfo "If you have further questions, enhancements or patches"
+ einfo "send an email to phoenix@gentoo.org"
+}