summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2006-04-10 13:52:48 +0000
committerChris Bainbridge <chrb@gentoo.org>2006-04-10 13:52:48 +0000
commitdfec30e110df139d0e79819d64738acab26e0603 (patch)
tree95dc7de48f7ce35c8b8893f8e9828c1b8a7ca1b1 /app-emulation
parentBump mplayer-bin. Fixes bug #127969 and bug #127936 (diff)
downloadgentoo-2-dfec30e110df139d0e79819d64738acab26e0603.tar.gz
gentoo-2-dfec30e110df139d0e79819d64738acab26e0603.tar.bz2
gentoo-2-dfec30e110df139d0e79819d64738acab26e0603.zip
removed the hardened stripping flags - now that the hypervisor is split out, the tools should be compilable with hardened flags. There is currently a bug with register clobbering which has been filed at bugzilla.xensource.com #609
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/ChangeLog7
-rw-r--r--app-emulation/xen-tools/xen-tools-3.0.2.ebuild8
2 files changed, 8 insertions, 7 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 73954c07068f..0d34c085785a 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.6 2006/04/10 12:18:34 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.7 2006/04/10 13:52:48 chrb Exp $
+
+ 10 Apr 2006; <chrb@gentoo.org> xen-tools-3.0.2.ebuild:
+ removed the hardened stripping flags - now that the hypervisor is split out,
+ the tools should be compilable with hardened flags. There is currently a bug
+ with register clobbering which has been filed at bugzilla.xensource.com #609
10 Apr 2006; <chrb@gentoo.org> xen-tools-3.0.2.ebuild:
add some extra man pages, #129189
diff --git a/app-emulation/xen-tools/xen-tools-3.0.2.ebuild b/app-emulation/xen-tools/xen-tools-3.0.2.ebuild
index aa98c597502a..372cfe3a850b 100644
--- a/app-emulation/xen-tools/xen-tools-3.0.2.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.0.2.ebuild,v 1.3 2006/04/10 12:18:34 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.0.2.ebuild,v 1.4 2006/04/10 13:52:48 chrb Exp $
inherit mount-boot flag-o-matic eutils
@@ -58,11 +58,7 @@ src_compile() {
local myopt
use debug && myopt="${myopt} debug=y"
- if use custom-cflags; then
- filter-flags -fPIE -fstack-protector
- else
- unset CFLAGS
- fi
+ use custom-cflags || unset CFLAGS
emake -C tools ${myopt} || die "compile failed"