summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-07-11 01:58:02 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-07-11 01:58:02 +0000
commitd16f7b802a93935532f3034280477684078abddb (patch)
tree157d7dfeb5996bf1b00cc2901fd375a86b777dab /app-emulation
parentMake USE=snmp fatal when net-snmp is not installed, and make an unreadable /p... (diff)
downloadgentoo-2-d16f7b802a93935532f3034280477684078abddb.tar.gz
gentoo-2-d16f7b802a93935532f3034280477684078abddb.tar.bz2
gentoo-2-d16f7b802a93935532f3034280477684078abddb.zip
Attempt to better handle the case when we can't have PIE enabled, which is when GCC was built with USE=nopie or when USE=static is enabled. bug #425662
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-kvm/ChangeLog6
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild12
2 files changed, 14 insertions, 4 deletions
diff --git a/app-emulation/qemu-kvm/ChangeLog b/app-emulation/qemu-kvm/ChangeLog
index 3cc12410f732..9cf166976d91 100644
--- a/app-emulation/qemu-kvm/ChangeLog
+++ b/app-emulation/qemu-kvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu-kvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.133 2012/07/10 23:46:39 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.134 2012/07/11 01:58:02 cardoe Exp $
+
+ 10 Jul 2012; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-1.1.0.ebuild:
+ Attempt to better handle the case when we can't have PIE enabled, which is
+ when GCC was built with USE=nopie or when USE=static is enabled. bug #425662
10 Jul 2012; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-1.1.0.ebuild:
Fix 'virtfs' USE flag to correctly depend on sys-libs/libcap and not depend
diff --git a/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild b/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild
index 4b1ed55d4d3d..74963f839cb0 100644
--- a/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild
+++ b/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild,v 1.11 2012/07/10 23:46:39 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild,v 1.12 2012/07/11 01:58:02 cardoe Exp $
EAPI="4"
@@ -221,7 +221,14 @@ src_configure() {
conf_opts="${conf_opts} --extra-ldflags=-Wl,-z,execheap"
# Add support for static builds
- use static && conf_opts="${conf_opts} --static"
+ use static && conf_opts="${conf_opts} --static --disable-pie"
+
+ # We always want to attempt to build with PIE support as it results
+ # in a more secure binary. But it doesn't work with static or if
+ # the current GCC doesn't have PIE support.
+ if ! use static && gcc-specs-pie; then
+ conf_opts="${conf_opts} --enable-pie"
+ fi
# audio options
audio_opts="oss"
@@ -241,7 +248,6 @@ src_configure() {
--disable-strip \
--disable-werror \
--enable-guest-agent \
- --enable-pie \
--enable-vnc-jpeg \
--enable-vnc-png \
--enable-vnc-thread \