summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-03-05 23:44:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-03-05 23:44:38 +0000
commit9a8f77e1ce537f02000e98f585e6c01a888d940a (patch)
tree1e03cb81ddff4faaf51b1c8220aa1a33039ef29b /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-9a8f77e1ce537f02000e98f585e6c01a888d940a.tar.gz
gentoo-2-9a8f77e1ce537f02000e98f585e6c01a888d940a.tar.bz2
gentoo-2-9a8f77e1ce537f02000e98f585e6c01a888d940a.zip
Add support for bootstrapping so the live git ebuild works. bug #377279. Change based on patches from hasufell <julian.ospald@googlemail.com>
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog9
-rw-r--r--app-emulation/libvirt/libvirt-0.9.10-r4.ebuild19
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild19
3 files changed, 43 insertions, 4 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index 8db9dd53780c..705a1d7493e5 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.163 2012/03/05 14:46:07 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.164 2012/03/05 23:44:38 cardoe Exp $
+
+ 05 Mar 2012; Doug Goldstein <cardoe@gentoo.org> libvirt-0.9.10-r4.ebuild,
+ libvirt-9999.ebuild:
+ Add support for bootstrapping so the live git ebuild works. bug #377279.
+ Change based on patches from hasufell <julian.ospald@googlemail.com>
*libvirt-0.9.10-r4 (05 Mar 2012)
05 Mar 2012; Doug Goldstein <cardoe@gentoo.org> -libvirt-0.9.10-r3.ebuild,
+libvirt-0.9.10-r4.ebuild, libvirt-9999.ebuild:
- Fix filename of sysctl config file so OpenRC respects it Identified by BT
+ Fix filename of sysctl config file so OpenRC respects it. Identified by BT
<amak79@gmail.com>. bug #406729
01 Mar 2012; Doug Goldstein <cardoe@gentoo.org> libvirt-0.9.10-r3.ebuild,
diff --git a/app-emulation/libvirt/libvirt-0.9.10-r4.ebuild b/app-emulation/libvirt/libvirt-0.9.10-r4.ebuild
index 86c682b80905..7d0f3dfd5c26 100644
--- a/app-emulation/libvirt/libvirt-0.9.10-r4.ebuild
+++ b/app-emulation/libvirt/libvirt-0.9.10-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.9.10-r4.ebuild,v 1.1 2012/03/05 14:46:07 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.9.10-r4.ebuild,v 1.2 2012/03/05 23:44:38 cardoe Exp $
BACKPORTS=1
#AUTOTOOLIZE=yes
@@ -100,6 +100,17 @@ src_prepare() {
EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
epatch
+ if [[ ${PV} = *9999* ]]; then
+ # git checkouts require bootstrapping to create the configure script.
+ # Additionally the submodules must be cloned to the right locations
+ # bug #377279
+ ./bootstrap || die "bootstrap failed"
+ (
+ git submodule status | sed 's/^[ +-]//;s/ .*//'
+ git hash-object bootstrap.conf
+ ) >.git-module-status
+ fi
+
[[ -n ${AUTOTOOLIZE} ]] && eautoreconf
}
@@ -193,6 +204,12 @@ src_configure() {
--docdir=/usr/share/doc/${PF} \
--with-remote \
--localstatedir=/var
+
+ if [[ ${PV} = *9999* ]]; then
+ # Restore gnulib's config.sub and config.guess
+ # bug #377279
+ (cd .gnulib && git reset --hard > /dev/null)
+ fi
}
src_test() {
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index 61cc42c46fa2..69e4d5bbd277 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.24 2012/03/05 14:46:07 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.25 2012/03/05 23:44:38 cardoe Exp $
BACKPORTS=1
#AUTOTOOLIZE=yes
@@ -100,6 +100,17 @@ src_prepare() {
EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
epatch
+ if [[ ${PV} = *9999* ]]; then
+ # git checkouts require bootstrapping to create the configure script.
+ # Additionally the submodules must be cloned to the right locations
+ # bug #377279
+ ./bootstrap || die "bootstrap failed"
+ (
+ git submodule status | sed 's/^[ +-]//;s/ .*//'
+ git hash-object bootstrap.conf
+ ) >.git-module-status
+ fi
+
[[ -n ${AUTOTOOLIZE} ]] && eautoreconf
}
@@ -193,6 +204,12 @@ src_configure() {
--docdir=/usr/share/doc/${PF} \
--with-remote \
--localstatedir=/var
+
+ if [[ ${PV} = *9999* ]]; then
+ # Restore gnulib's config.sub and config.guess
+ # bug #377279
+ (cd .gnulib && git reset --hard > /dev/null)
+ fi
}
src_test() {