summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-09 13:25:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-09 13:25:58 +0000
commit692f18e890b9e2f33d48fe592aab7939c31e09f9 (patch)
tree6f94c17aa59c601411ee076cc32fcf71c8def607 /app-emulation
parentMarked ~hppa (bug #344093). (diff)
downloadgentoo-2-692f18e890b9e2f33d48fe592aab7939c31e09f9.tar.gz
gentoo-2-692f18e890b9e2f33d48fe592aab7939c31e09f9.tar.bz2
gentoo-2-692f18e890b9e2f33d48fe592aab7939c31e09f9.zip
Cleanup old version; add new revbump that disables the xen-proxy in all cases, since upstream deprecated it and won't be in the next version anyway.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog10
-rw-r--r--app-emulation/libvirt/libvirt-0.8.5-r2.ebuild (renamed from app-emulation/libvirt/libvirt-0.8.4.ebuild)21
2 files changed, 20 insertions, 11 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index 401956776bc3..170d79fa1554 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.79 2010/10/30 17:54:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.80 2010/11/09 13:25:58 flameeyes Exp $
+
+*libvirt-0.8.5-r2 (09 Nov 2010)
+
+ 09 Nov 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -libvirt-0.8.4.ebuild, +libvirt-0.8.5-r2.ebuild:
+ Cleanup old version; add new revbump that disables the xen-proxy in all
+ cases, since upstream deprecated it and won't be in the next version
+ anyway.
*libvirt-0.8.5-r1 (30 Oct 2010)
diff --git a/app-emulation/libvirt/libvirt-0.8.4.ebuild b/app-emulation/libvirt/libvirt-0.8.5-r2.ebuild
index 151b99a7b2a6..3b3c81bf69cf 100644
--- a/app-emulation/libvirt/libvirt-0.8.4.ebuild
+++ b/app-emulation/libvirt/libvirt-0.8.5-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.8.4.ebuild,v 1.1 2010/09/17 17:58:34 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.8.5-r2.ebuild,v 1.1 2010/11/09 13:25:58 flameeyes Exp $
-#BACKPORTS=3
+BACKPORTS=2
EAPI="2"
@@ -15,13 +15,15 @@ inherit eutils python autotools
DESCRIPTION="C toolkit to manipulate virtual machines"
HOMEPAGE="http://www.libvirt.org/"
SRC_URI="http://libvirt.org/sources/${P}.tar.gz
- ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
+ ${BACKPORTS:+
+ http://dev.gentoo.org/~flameeyes/${PN}/${P}-backports-${BACKPORTS}.tar.bz2
+ http://dev.gentoo.org/~cardoe/${PN}/${P}-backports-${BACKPORTS}.tar.bz2}"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="avahi caps debug iscsi +libvirtd lvm +lxc macvtap +network nfs nls \
numa openvz parted pcap phyp policykit python qemu sasl selinux
- uml virtualbox xen udev"
+ uml virtualbox xen udev +json"
# IUSE=one : bug #293416 & bug #299011
RDEPEND="sys-libs/readline
@@ -51,7 +53,8 @@ RDEPEND="sys-libs/readline
selinux? ( >=sys-libs/libselinux-2.0.85 )
virtualbox? ( || ( >=app-emulation/virtualbox-ose-2.2.0 >=app-emulation/virtualbox-bin-2.2.0 ) )
xen? ( app-emulation/xen-tools app-emulation/xen )
- udev? ( >=sys-fs/udev-145 >=x11-libs/libpciaccess-0.10.9 )"
+ udev? ( >=sys-fs/udev-145 >=x11-libs/libpciaccess-0.10.9 )
+ json? ( dev-libs/yajl )"
# one? ( dev-libs/xmlrpc-c )
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -81,10 +84,7 @@ src_configure() {
myconf="${myconf} $(use_with avahi)"
## hypervisors on the local host
- myconf="${myconf} $(use_with xen) $(use_with xen xen-inotify)"
- if ! use policykit && use xen; then
- myconf="${myconf} --with-xen-proxy"
- fi
+ myconf="${myconf} $(use_with xen) $(use_with xen xen-inotify) --without-xen-proxy"
myconf="${myconf} $(use_with openvz)"
myconf="${myconf} $(use_with lxc)"
if use virtualbox && has_version app-emulation/virtualbox-ose; then
@@ -128,9 +128,10 @@ src_configure() {
## other
myconf="${myconf} $(use_enable nls)"
myconf="${myconf} $(use_with python)"
+ myconf="${myconf} $(use_with json yajl)"
## stuff we don't yet support
- myconf="${myconf} --without-netcf"
+ myconf="${myconf} --without-netcf --without-audit"
# we use udev over hal
myconf="${myconf} --without-hal"