summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-07-13 06:25:10 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-07-13 06:25:10 +0000
commit6347dbe21f1c163391922c6669c03354747777c0 (patch)
tree98f3fe1576f0fcd755f8f0a89e64c2dee44a2ba4 /app-emulation
parentpurge (Manifest recommit) (diff)
downloadgentoo-2-6347dbe21f1c163391922c6669c03354747777c0.tar.gz
gentoo-2-6347dbe21f1c163391922c6669c03354747777c0.tar.bz2
gentoo-2-6347dbe21f1c163391922c6669c03354747777c0.zip
adding patch. closes 56701 and 56736
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog8
-rw-r--r--app-emulation/wine/Manifest2
-rw-r--r--app-emulation/wine/files/digest-wine-20040615-r13
-rw-r--r--app-emulation/wine/files/scrollbars.diff95
-rw-r--r--app-emulation/wine/wine-20040615-r1.ebuild128
5 files changed, 235 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 0a42afe1a28f..5f1d3ac35de0 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.74 2004/07/08 14:33:53 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.75 2004/07/13 06:25:10 mholzer Exp $
+
+*wine-20040615-r1 (13 Jul 2004)
+
+ 13 Jul 2004; Martin Holzer <mholzer@gentoo.org> +files/scrollbars.diff,
+ +wine-20040615-r1.ebuild:
+ adding patch. closes 56701 and 56736
08 Jul 2004; Martin Holzer <mholzer@gentoo.org> wine-20040121.ebuild,
wine-20040213.ebuild, wine-20040309.ebuild, wine-20040408-r1.ebuild,
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index 9d0674146b47..8ecdec70f867 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,6 +1,7 @@
MD5 44e535935efed5038a68bf8e8a91d86d wine-20040408.ebuild 3268
MD5 95a9ed6854a342434007b3e51008ef4b wine-20040408-r1.ebuild 3270
MD5 24e0c9d978568399d08b5110fc9f37b5 wine-20040121.ebuild 3267
+MD5 c3199910ffae7d8f63e4b2d7b95cf40a wine-20040615-r1.ebuild 3425
MD5 0c5e08e32b01d33dcb2d317d40e141d1 wine-20040615.ebuild 3399
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 ba30e4e9a414d79f787b4ad2ca55d012 wine-20040505.ebuild 3317
@@ -8,6 +9,7 @@ MD5 684f07277fc6e7b8022cb6f286e2b8fc wine-20040213.ebuild 3268
MD5 0ef05c2c8b3bd6001295945f327f200b ChangeLog 12910
MD5 613e3e8d4ffd83b28198b385eb4401be wine-20040309.ebuild 3268
MD5 b5307649654483532930907b0485eaf0 files/wine-alsa.patch 86359
+MD5 4312d9c1f7af214bd5cd25fe5f7d4521 files/digest-wine-20040615-r1 212
MD5 b31b2888ece1838bb246d5d66818c152 files/digest-wine-20040408-r1 215
MD5 73c3f4c41391cb7ba033bf8d34f54029 files/digest-wine-20040505 212
MD5 8eb0a0c62fa1579183fab16d341cbcdd files/digest-wine-20040309 212
diff --git a/app-emulation/wine/files/digest-wine-20040615-r1 b/app-emulation/wine/files/digest-wine-20040615-r1
new file mode 100644
index 000000000000..d343067f1b07
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20040615-r1
@@ -0,0 +1,3 @@
+MD5 5cfec5a33b596a08eefd2f8a44ccd205 Wine-20040615.tar.gz 10582792
+MD5 af8da46a0e51578ff1e18e399141d628 wine-20040615-fake_windows.tar.bz2 500
+MD5 e85afd5661bfc1b6dffc05db480b52a8 wine-20040615-misc.tar.bz2 5300
diff --git a/app-emulation/wine/files/scrollbars.diff b/app-emulation/wine/files/scrollbars.diff
new file mode 100644
index 000000000000..6210e2713db9
--- /dev/null
+++ b/app-emulation/wine/files/scrollbars.diff
@@ -0,0 +1,95 @@
+diff -u controls/scroll.c:1.79 controls/scroll.c:1.78
+--- controls/scroll.c:1.79 Sat Jul 10 12:24:59 2004
++++ controls/scroll.c Sat Jul 10 12:24:59 2004
+@@ -1211,28 +1211,6 @@
+ }
+
+
+-/*************************************************************************
+- * SCROLL_SetScrollRange
+- *
+- */
+-static BOOL SCROLL_SetScrollRange(
+- HWND hwnd, /* [in] Handle of window */
+- INT nBar, /* [in] One of SB_HORZ, SB_VERT, or SB_CTL */
+- INT minVal, /* [out] minimum value */
+- INT maxVal /* [out] maximum value */)
+-{
+- LPSCROLLBAR_INFO infoPtr = SCROLL_GetScrollBarInfo(hwnd, nBar);
+-
+- TRACE("hwnd=%p nBar=%d min=%d max=%d\n", hwnd, nBar, minVal, maxVal);
+-
+- if (infoPtr)
+- {
+- infoPtr->minVal = minVal;
+- infoPtr->maxVal = maxVal;
+- }
+- return infoPtr ? TRUE : FALSE;
+-}
+-
+
+ /***********************************************************************
+ * ScrollBarWndProc
+@@ -1340,17 +1362,14 @@
+ return SCROLL_GetScrollPos(hwnd, SB_CTL);
+
+ case SBM_SETRANGE16:
++ SetScrollRange( hwnd, SB_CTL, LOWORD(lParam), HIWORD(lParam),
++ wParam /* FIXME: Is this correct? */ );
++ return 0;
++
+- if (wParam) message = SBM_SETRANGEREDRAW;
+- wParam = LOWORD(lParam);
+- lParam = HIWORD(lParam);
+- /* fall through */
+- case SBM_SETRANGEREDRAW:
+ case SBM_SETRANGE:
+ {
+ INT oldPos = SCROLL_GetScrollPos( hwnd, SB_CTL );
++ SetScrollRange( hwnd, SB_CTL, wParam, lParam, FALSE );
+- SCROLL_SetScrollRange( hwnd, SB_CTL, wParam, lParam );
+- if (message == SBM_SETRANGEREDRAW)
+- SCROLL_RefreshScrollBar( hwnd, SB_CTL, TRUE, TRUE );
+ if (oldPos != SCROLL_GetScrollPos( hwnd, SB_CTL )) return oldPos;
+ }
+ return 0;
+@@ -1363,6 +1388,14 @@
+ case SBM_ENABLE_ARROWS:
+ return EnableScrollBar( hwnd, SB_CTL, wParam );
+
++ case SBM_SETRANGEREDRAW:
++ {
++ INT oldPos = SCROLL_GetScrollPos( hwnd, SB_CTL );
++ SetScrollRange( hwnd, SB_CTL, wParam, lParam, TRUE );
++ if (oldPos != SCROLL_GetScrollPos( hwnd, SB_CTL )) return oldPos;
++ }
++ return 0;
++
+ case SBM_SETSCROLLINFO:
+ return SetScrollInfo( hwnd, SB_CTL, (SCROLLINFO *)lParam, wParam );
+
+@@ -1665,19 +1682,14 @@
+ INT maxVal, /* [in] New maximum value */
+ BOOL bRedraw /* [in] Should scrollbar be redrawn afterwards ? */)
+ {
++ SCROLLINFO info;
+- BOOL ret;
+
++ info.cbSize = sizeof(info);
++ info.nMin = minVal;
++ info.nMax = maxVal;
++ info.fMask = SIF_RANGE;
++ SetScrollInfo( hwnd, nBar, &info, bRedraw );
++ return TRUE;
+- TRACE("hwnd=%p nBar=%d min=%d max=%d\n", hwnd, nBar, minVal, maxVal);
+-
+- /* Refer SB_CTL requests to the window */
+- if (nBar == SB_CTL)
+- ret = SendMessageW(hwnd, SBM_SETRANGE, minVal, maxVal);
+- else
+- ret = SCROLL_SetScrollRange(hwnd, nBar, minVal, maxVal);
+-
+- if (bRedraw)
+- SCROLL_RefreshScrollBar( hwnd, SB_CTL, TRUE, TRUE );
+- return ret;
+ }
diff --git a/app-emulation/wine/wine-20040615-r1.ebuild b/app-emulation/wine/wine-20040615-r1.ebuild
new file mode 100644
index 000000000000..4b91b20075cf
--- /dev/null
+++ b/app-emulation/wine/wine-20040615-r1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20040615-r1.ebuild,v 1.1 2004/07/13 06:25:10 mholzer Exp $
+
+inherit eutils base
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
+ mirror://gentoo/${P}-fake_windows.tar.bz2
+ mirror://gentoo/${P}-misc.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE="X alsa arts cups debug nas nptl opengl tcltk"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack Wine-${PV}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/winearts-kdecvs-fix.patch
+ epatch ${FILESDIR}/QueryActCtxw_Photoshop7.0.diff
+ epatch ${FILESDIR}/scrollbars.diff
+}
+
+src_compile() {
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ unset CFLAGS CXXFLAGS
+
+ ac_cv_header_jack_jack_h=no \
+ ac_cv_lib_soname_jack= \
+ ./configure \
+ --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ `use_enable opengl` \
+ `use_with nptl` \
+ `use_enable debug trace` \
+ `use_enable debug` \
+ || die "configure failed"
+
+ cd ${S}/programs/winetest
+ sed -i 's:wine.pm:include/wine.pm:' Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install() {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${DISTDIR}/${PF}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine winedbg wine-pthread
+ rm regedit-wine wine winedbg wine-pthread
+
+ # copying the wine.inf into .data (used to be winedefault.reg)
+ cd ${S}
+ dodir /usr/lib/wine/.data
+ insinto /usr/lib/wine/.data
+ doins tools/wine.inf
+ insinto /usr/lib/wine/.data/fake_windows/Windows/System
+ doins tools/wine.inf
+ insinto /usr/lib/wine/.data/fake_windows/Windows/Inf
+ doins tools/wine.inf
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+ rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "if you have problems with nptl, use wine-pthread to start wine"
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+}