summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-08-07 16:40:38 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-08-07 16:40:38 +0000
commit43ae9a3a14259c883602b2c443e943e36d13fd22 (patch)
tree7d7eba47684bb46e8eb740bf90685d80bc7fe893 /app-emulation
parentrevert stable keyword for x86 (diff)
downloadgentoo-2-43ae9a3a14259c883602b2c443e943e36d13fd22.tar.gz
gentoo-2-43ae9a3a14259c883602b2c443e943e36d13fd22.tar.bz2
gentoo-2-43ae9a3a14259c883602b2c443e943e36d13fd22.zip
Initial commit, ebuild sourced from Sunrise overlay but modified slightly. With a warm thank you to Sergey Khalavchuck, Chad A. Simmons, Duncan Lockwood, Mark Silinio and "haad". Closes bug #154491.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dynamips/ChangeLog12
-rw-r--r--app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild46
-rw-r--r--app-emulation/dynamips/files/dynamips-0.2.8_rc2-makefile.patch49
-rw-r--r--app-emulation/dynamips/metadata.xml9
4 files changed, 116 insertions, 0 deletions
diff --git a/app-emulation/dynamips/ChangeLog b/app-emulation/dynamips/ChangeLog
new file mode 100644
index 000000000000..2d64af04d63b
--- /dev/null
+++ b/app-emulation/dynamips/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-emulation/dynamips
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dynamips/ChangeLog,v 1.1 2009/08/07 16:40:38 chainsaw Exp $
+
+*dynamips-0.2.8_rc2 (07 Aug 2009)
+
+ 07 Aug 2009; <chainsaw@gentoo.org> +dynamips-0.2.8_rc2.ebuild,
+ +files/dynamips-0.2.8_rc2-makefile.patch, +metadata.xml:
+ Initial commit, ebuild sourced from Sunrise overlay but modified slightly.
+ With a warm thank you to Sergey Khalavchuck, Chad A. Simmons, Duncan
+ Lockwood, Mark Silinio and "haad". Closes bug #154491.
+
diff --git a/app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild b/app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild
new file mode 100644
index 000000000000..234dcab413ac
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild,v 1.1 2009/08/07 16:40:38 chainsaw Exp $
+
+inherit eutils
+
+MY_P="${P/_rc/-RC}"
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator"
+SRC_URI="http://www.ipflow.utc.fr/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND="dev-libs/elfutils
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+
+ if use amd64; then
+ sed -i \
+ -e 's:DYNAMIPS_ARCH?=nojit:DYNAMIPS_ARCH?=amd64:g' \
+ Makefile || die "Failed to optimise for AMD64"
+ elif use amd64; then
+ sed -i \
+ -e 's:DYNAMIPS_ARCH?=nojit:DYNAMIPS_ARCH?=x86:g' \
+ Makefile || die "Failed to optimise for X86"
+ fi
+}
+
+src_install () {
+ dobin dynamips nvram_export \
+ || die "Installing binaries failed"
+ doman dynamips.1 hypervisor_mode.7 nvram_export.1 \
+ || die "Installing man pages failed"
+ dodoc ChangeLog TODO README README.hypervisor \
+ || die "Installing docs failed"
+}
diff --git a/app-emulation/dynamips/files/dynamips-0.2.8_rc2-makefile.patch b/app-emulation/dynamips/files/dynamips-0.2.8_rc2-makefile.patch
new file mode 100644
index 000000000000..3262515eacaf
--- /dev/null
+++ b/app-emulation/dynamips/files/dynamips-0.2.8_rc2-makefile.patch
@@ -0,0 +1,49 @@
+diff -uNr dynamips-0.2.8-RC2.ORIG/Makefile dynamips-0.2.8-RC2/Makefile
+--- dynamips-0.2.8-RC2.ORIG/Makefile 2009-08-07 17:24:11.000000000 +0100
++++ dynamips-0.2.8-RC2/Makefile 2009-08-07 17:24:52.000000000 +0100
+@@ -3,7 +3,7 @@
+
+ # Replace x86 by amd64 for a build on x86_64.
+ # Use "nojit" for architectures that are not x86 or x86_64.
+-DYNAMIPS_ARCH?=x86
++DYNAMIPS_ARCH?=nojit
+
+ # Change this to 0 if your system doesn't support RFC 2553 extensions
+ HAS_RFC2553?=1
+@@ -13,7 +13,7 @@
+ HAS_PCAP?=1
+
+ # Change this to 1 if your system has posix_memalign
+-HAS_POSIX_MEMALIGN?=0
++HAS_POSIX_MEMALIGN?=1
+
+ # Current dynamips release
+ VERSION_TRAIN=0.2.8
+@@ -35,7 +35,7 @@
+ MIPS64_ARCH_INC_FILE=\"mips64_$(DYNAMIPS_ARCH)_trans.h\"
+ PPC32_ARCH_INC_FILE=\"ppc32_$(DYNAMIPS_ARCH)_trans.h\"
+
+-CFLAGS+=-g -Wall -O3 -fomit-frame-pointer \
++CFLAGS+=-g -Wall \
+ -DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" -DJIT_CPU=CPU_$(DYNAMIPS_ARCH) \
+ -DMIPS64_ARCH_INC_FILE=$(MIPS64_ARCH_INC_FILE) \
+ -DPPC32_ARCH_INC_FILE=$(PPC32_ARCH_INC_FILE) \
+@@ -215,8 +215,7 @@
+ .PHONY: all
+ all: $(PROG) nvram_export
+
+-$(PROG): mips64_microcode_dump.inc ppc32_microcode_dump.inc \
+- $(LEX_C) $(C_OBJS) $(A_OBJS)
++$(PROG): $(LEX_C) $(C_OBJS) $(A_OBJS)
+ @echo "Linking $@"
+ @$(CC) -o $@ $(C_OBJS) $(A_OBJS) $(LIBS)
+
+@@ -246,6 +245,8 @@
+ @echo "Building assembly definitions header file"
+ @./asmdefs
+
++dev_rom.o: mips64_microcode_dump.inc ppc32_microcode_dump.inc
++
+ nvram_export$(BIN_EXT): nvram_export.c
+ @echo "Linking $@"
+ @$(CC) -Wall $(CFLAGS) -o $@ nvram_export.c
diff --git a/app-emulation/dynamips/metadata.xml b/app-emulation/dynamips/metadata.xml
new file mode 100644
index 000000000000..594fd74ffc85
--- /dev/null
+++ b/app-emulation/dynamips/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+</maintainer>
+</pkgmetadata>