summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-02-10 21:23:48 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-02-10 21:23:48 +0000
commit039029f2f837fbabec5fb36ebe0108a0e9a86d4f (patch)
treec43c2fbf181b96817f874daae81fa74a0c5d61e0 /app-emulation
parentinitial import wrt #214875 (diff)
downloadgentoo-2-039029f2f837fbabec5fb36ebe0108a0e9a86d4f.tar.gz
gentoo-2-039029f2f837fbabec5fb36ebe0108a0e9a86d4f.tar.bz2
gentoo-2-039029f2f837fbabec5fb36ebe0108a0e9a86d4f.zip
Bump to support two different builds for user targets and
system targets to allow you to build one static and one dynamic. Additionally bump the patchset to include fixes for bug #455552 and bug #454364 (Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog11
-rw-r--r--app-emulation/qemu/qemu-1.2.2-r3.ebuild (renamed from app-emulation/qemu/qemu-1.2.2-r100.ebuild)22
2 files changed, 21 insertions, 12 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 79e9c8fca497..b5c7d79dc84b 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.179 2013/02/10 20:15:35 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.180 2013/02/10 21:23:48 cardoe Exp $
+
+*qemu-1.2.2-r3 (10 Feb 2013)
+
+ 10 Feb 2013; Doug Goldstein <cardoe@gentoo.org> +qemu-1.2.2-r3.ebuild,
+ -qemu-1.2.2-r100.ebuild:
+ Bump to support two different builds for user targets and
+ system targets to allow you to build one static and one
+ dynamic. Additionally bump the patchset to include fixes for
+ bug #455552 and bug #454364
10 Feb 2013; Doug Goldstein <cardoe@gentoo.org> qemu-1.3.0.ebuild:
Add back vgabios which was removed incorrectly qemu-1.3.0.ebuild
diff --git a/app-emulation/qemu/qemu-1.2.2-r100.ebuild b/app-emulation/qemu/qemu-1.2.2-r3.ebuild
index 33aae06b4cae..1dbac9c935d8 100644
--- a/app-emulation/qemu/qemu-1.2.2-r100.ebuild
+++ b/app-emulation/qemu/qemu-1.2.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.2.2-r100.ebuild,v 1.2 2013/02/02 01:14:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.2.2-r3.ebuild,v 1.1 2013/02/10 21:23:48 cardoe Exp $
EAPI=5
@@ -9,7 +9,7 @@ MY_P=${MY_PN}-1.2.0
PYTHON_DEPEND="2"
inherit eutils flag-o-matic linux-info toolchain-funcs multilib python user udev
-BACKPORTS=9489a8c0-1
+BACKPORTS=7c9a3a87
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://git.kernel.org/pub/scm/virt/kvm/qemu-kvm.git"
@@ -348,31 +348,31 @@ src_configure() {
einfo "Building the following user targets: ${user_targets}"
if [[ -n ${softmmu_targets} ]]; then
- mkdir ${S}/softmmu-build
+ mkdir "${S}/softmmu-build"
qemu_src_configure "softmmu" "${S}/softmmu-build"
fi
if [[ -n ${user_targets} ]]; then
- mkdir ${S}/user-build
+ mkdir "${S}/user-build"
qemu_src_configure "user" "${S}/user-build"
fi
}
src_compile() {
if [[ -n ${user_targets} ]]; then
- cd ${S}/user-build
+ cd "${S}/user-build"
default
fi
if [[ -n ${softmmu_targets} ]]; then
- cd ${S}/softmmu-build
+ cd "${S}/softmmu-build"
default
fi
}
src_install() {
if [[ -n ${user_targets} ]]; then
- cd ${S}/user-build
+ cd "${S}/user-build"
emake DESTDIR="${ED}" install
# Install binfmt handler init script for user targets
@@ -380,7 +380,7 @@ src_install() {
fi
if [[ -n ${softmmu_targets} ]]; then
- cd ${S}/softmmu-build
+ cd "${S}/softmmu-build"
emake DESTDIR="${ED}" install
if use kernel_linux; then
@@ -397,11 +397,11 @@ src_install() {
elog "of the /usr/bin/qemu-kvm symlink."
fi
- use python && dobin ${S}/scripts/kvm/kvm_stat
- use python && dobin ${S}/scripts/kvm/vmxcap
+ use python && dobin "${S}/scripts/kvm/kvm_stat"
+ use python && dobin "${S}/scripts/kvm/vmxcap"
fi
- cd ${S}
+ cd "${S}"
dodoc Changelog MAINTAINERS TODO pci-ids.txt
newdoc pc-bios/README README.pc-bios