summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-27 00:35:00 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-27 00:35:00 +0000
commit49a1e015d2a141e62eee0259e932e7122d9b544e (patch)
tree10e7fa4e40bccf9efc42087d6e59ddd6be678959 /app-emulation/wine
parentadd support for cris (diff)
downloadgentoo-2-49a1e015d2a141e62eee0259e932e7122d9b544e.tar.gz
gentoo-2-49a1e015d2a141e62eee0259e932e7122d9b544e.tar.bz2
gentoo-2-49a1e015d2a141e62eee0259e932e7122d9b544e.zip
Update the SSP patch with the version now in upstream.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog12
-rw-r--r--app-emulation/wine/files/wine-20041019-no-stack.patch9
-rw-r--r--app-emulation/wine/files/wine-no-ssp.patch20
-rw-r--r--app-emulation/wine/wine-0.9.1.ebuild4
-rw-r--r--app-emulation/wine/wine-0.9.2.ebuild4
-rw-r--r--app-emulation/wine/wine-0.9.3.ebuild4
-rw-r--r--app-emulation/wine/wine-0.9.4.ebuild4
-rw-r--r--app-emulation/wine/wine-0.9.5-r1.ebuild4
-rw-r--r--app-emulation/wine/wine-0.9.6.ebuild4
-rw-r--r--app-emulation/wine/wine-0.9.ebuild4
-rw-r--r--app-emulation/wine/wine-20041019-r3.ebuild4
-rw-r--r--app-emulation/wine/wine-20050111-r2.ebuild4
-rw-r--r--app-emulation/wine/wine-20050211.ebuild4
-rw-r--r--app-emulation/wine/wine-20050310-r1.ebuild4
-rw-r--r--app-emulation/wine/wine-20050419.ebuild4
-rw-r--r--app-emulation/wine/wine-20050524.ebuild4
-rw-r--r--app-emulation/wine/wine-20050628.ebuild4
-rw-r--r--app-emulation/wine/wine-20050725-r1.ebuild4
-rw-r--r--app-emulation/wine/wine-20050830.ebuild4
-rw-r--r--app-emulation/wine/wine-20050930.ebuild4
-rw-r--r--app-emulation/wine/wine-9999.ebuild3
21 files changed, 66 insertions, 46 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index ab4ced10e192..b04679a9607b 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.123 2006/01/25 00:03:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.124 2006/01/27 00:35:00 vapier Exp $
+
+ 27 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+ -files/wine-20041019-no-stack.patch, +files/wine-no-ssp.patch,
+ wine-0.9.ebuild, wine-0.9.1.ebuild, wine-0.9.2.ebuild, wine-0.9.3.ebuild,
+ wine-0.9.4.ebuild, wine-0.9.5-r1.ebuild, wine-0.9.6.ebuild,
+ wine-9999.ebuild, wine-20041019-r3.ebuild, wine-20050111-r2.ebuild,
+ wine-20050211.ebuild, wine-20050310-r1.ebuild, wine-20050419.ebuild,
+ wine-20050524.ebuild, wine-20050628.ebuild, wine-20050725-r1.ebuild,
+ wine-20050830.ebuild, wine-20050930.ebuild:
+ Update the SSP patch with the version now in upstream.
25 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+files/wine-0.9.6-force-ddraw-gamma.patch, wine-0.9.6.ebuild:
diff --git a/app-emulation/wine/files/wine-20041019-no-stack.patch b/app-emulation/wine/files/wine-20041019-no-stack.patch
deleted file mode 100644
index 49852f3b6513..000000000000
--- a/app-emulation/wine/files/wine-20041019-no-stack.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- loader/Makefile.in
-+++ loader/Makefile.in
-@@ -21,5 +21,6 @@
-
- @MAKE_RULES@
-+CFLAGS += -fno-pic -fno-stack-protector
-
- LIBPTHREAD = @LIBPTHREAD@
- LDEXECFLAGS = @LDEXECFLAGS@
diff --git a/app-emulation/wine/files/wine-no-ssp.patch b/app-emulation/wine/files/wine-no-ssp.patch
new file mode 100644
index 000000000000..f75cfb701914
--- /dev/null
+++ b/app-emulation/wine/files/wine-no-ssp.patch
@@ -0,0 +1,20 @@
+Index: loader/preloader.c
+===================================================================
+RCS file: /home/wine/wine/loader/preloader.c,v
+retrieving revision 1.18
+retrieving revision 1.19
+diff -u -p -r1.18 -r1.19
+--- loader/preloader.c 14 Dec 2005 11:26:30 -0000 1.18
++++ loader/preloader.c 26 Jan 2006 12:45:33 -0000 1.19
+@@ -155,6 +155,11 @@ struct wld_link_map {
+ */
+ void __bb_init_func() { return; }
+
++/* similar to the above but for -fstack-protector */
++void *__stack_chk_guard = 0;
++void *__guard = 0;
++void __stack_chk_fail(void) { return; }
++void __stack_smash_handler(void) { return; }
+
+ /*
+ * The _start function is the entry and exit point of this program
diff --git a/app-emulation/wine/wine-0.9.1.ebuild b/app-emulation/wine/wine-0.9.1.ebuild
index 190a06d9bb62..942ff12f16c4 100644
--- a/app-emulation/wine/wine-0.9.1.ebuild
+++ b/app-emulation/wine/wine-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.1.ebuild,v 1.4 2006/01/14 18:38:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.1.ebuild,v 1.5 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -84,7 +84,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}
diff --git a/app-emulation/wine/wine-0.9.2.ebuild b/app-emulation/wine/wine-0.9.2.ebuild
index 169d605d13aa..2603524fb984 100644
--- a/app-emulation/wine/wine-0.9.2.ebuild
+++ b/app-emulation/wine/wine-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.2.ebuild,v 1.4 2006/01/14 18:38:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.2.ebuild,v 1.5 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -84,7 +84,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}
diff --git a/app-emulation/wine/wine-0.9.3.ebuild b/app-emulation/wine/wine-0.9.3.ebuild
index e8f7d3735645..b88082aad38d 100644
--- a/app-emulation/wine/wine-0.9.3.ebuild
+++ b/app-emulation/wine/wine-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.3.ebuild,v 1.5 2006/01/14 18:38:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.3.ebuild,v 1.6 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -84,7 +84,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}
diff --git a/app-emulation/wine/wine-0.9.4.ebuild b/app-emulation/wine/wine-0.9.4.ebuild
index c06b064de7de..bf005c98ec08 100644
--- a/app-emulation/wine/wine-0.9.4.ebuild
+++ b/app-emulation/wine/wine-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.4.ebuild,v 1.5 2006/01/14 18:38:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.4.ebuild,v 1.6 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -84,7 +84,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/${P}-null-thread-check.patch
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}
diff --git a/app-emulation/wine/wine-0.9.5-r1.ebuild b/app-emulation/wine/wine-0.9.5-r1.ebuild
index 7d130e043d4a..ffd28d5df793 100644
--- a/app-emulation/wine/wine-0.9.5-r1.ebuild
+++ b/app-emulation/wine/wine-0.9.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.5-r1.ebuild,v 1.1 2006/01/15 09:18:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.5-r1.ebuild,v 1.2 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -84,7 +84,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}
diff --git a/app-emulation/wine/wine-0.9.6.ebuild b/app-emulation/wine/wine-0.9.6.ebuild
index ba1209d0981b..6c4bce9c56d8 100644
--- a/app-emulation/wine/wine-0.9.6.ebuild
+++ b/app-emulation/wine/wine-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.6.ebuild,v 1.3 2006/01/25 00:03:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.6.ebuild,v 1.4 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -84,7 +84,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}
diff --git a/app-emulation/wine/wine-0.9.ebuild b/app-emulation/wine/wine-0.9.ebuild
index 2d4f91ef53e6..b67ec95f571f 100644
--- a/app-emulation/wine/wine-0.9.ebuild
+++ b/app-emulation/wine/wine-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.ebuild,v 1.4 2006/01/14 18:38:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.ebuild,v 1.5 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -84,7 +84,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}
diff --git a/app-emulation/wine/wine-20041019-r3.ebuild b/app-emulation/wine/wine-20041019-r3.ebuild
index 706e9f60c47a..c428212a890d 100644
--- a/app-emulation/wine/wine-20041019-r3.ebuild
+++ b/app-emulation/wine/wine-20041019-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.21 2006/01/14 18:39:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.22 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -58,7 +58,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-20050111-r2.ebuild b/app-emulation/wine/wine-20050111-r2.ebuild
index 4b3104f226c0..f7ac5c5d9a4f 100644
--- a/app-emulation/wine/wine-20050111-r2.ebuild
+++ b/app-emulation/wine/wine-20050111-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111-r2.ebuild,v 1.5 2006/01/14 18:39:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111-r2.ebuild,v 1.6 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -58,7 +58,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-upstream-registry-fix.patch.bz2 #85387
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index 3eef06abbc8a..79941f2cbe8b 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.19 2006/01/14 18:39:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.20 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -81,7 +81,7 @@ src_unpack() {
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
epatch "${FILESDIR}"/wine-20050211-docs.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-20050310-r1.ebuild b/app-emulation/wine/wine-20050310-r1.ebuild
index 57fc30ecc0d9..8389418f7bff 100644
--- a/app-emulation/wine/wine-20050310-r1.ebuild
+++ b/app-emulation/wine/wine-20050310-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.12 2006/01/14 18:39:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.13 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -82,7 +82,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-hangfix-bug2660.patch #98156
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/wine-20050310-upstream-colortable.patch #88715
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-20050419.ebuild b/app-emulation/wine/wine-20050419.ebuild
index abdd2fb0101c..dc3cc9d6d707 100644
--- a/app-emulation/wine/wine-20050419.ebuild
+++ b/app-emulation/wine/wine-20050419.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.14 2006/01/14 18:39:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.15 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -81,7 +81,7 @@ src_unpack() {
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
epatch "${FILESDIR}"/wine-hangfix-bug2660.patch #98156
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-20050524.ebuild b/app-emulation/wine/wine-20050524.ebuild
index 9dd3aa0ad85f..37ee867172b0 100644
--- a/app-emulation/wine/wine-20050524.ebuild
+++ b/app-emulation/wine/wine-20050524.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.13 2006/01/14 18:39:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.14 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -81,7 +81,7 @@ src_unpack() {
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
epatch "${FILESDIR}"/wine-hangfix-bug2660.patch #98156
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/wine-20050725-gcc-32bit.patch
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
diff --git a/app-emulation/wine/wine-20050628.ebuild b/app-emulation/wine/wine-20050628.ebuild
index 5a916d4990f8..e20c8b1c59aa 100644
--- a/app-emulation/wine/wine-20050628.ebuild
+++ b/app-emulation/wine/wine-20050628.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050628.ebuild,v 1.8 2006/01/14 18:39:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050628.ebuild,v 1.9 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -80,7 +80,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/wine-20050725-gcc-32bit.patch
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
diff --git a/app-emulation/wine/wine-20050725-r1.ebuild b/app-emulation/wine/wine-20050725-r1.ebuild
index 85c7f6bed2fd..f1c307057d5e 100644
--- a/app-emulation/wine/wine-20050725-r1.ebuild
+++ b/app-emulation/wine/wine-20050725-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050725-r1.ebuild,v 1.6 2006/01/14 18:39:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050725-r1.ebuild,v 1.7 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -80,7 +80,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/wine-20050725-gcc-32bit.patch
epatch "${FILESDIR}"/wine-20050930-no-x.patch
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
diff --git a/app-emulation/wine/wine-20050830.ebuild b/app-emulation/wine/wine-20050830.ebuild
index d8fc87eefcac..fc88978196fb 100644
--- a/app-emulation/wine/wine-20050830.ebuild
+++ b/app-emulation/wine/wine-20050830.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050830.ebuild,v 1.5 2006/01/14 18:39:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050830.ebuild,v 1.6 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -80,7 +80,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/wine-20050830-gcc-32bit.patch
epatch "${FILESDIR}"/wine-20050930-no-x.patch
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
diff --git a/app-emulation/wine/wine-20050930.ebuild b/app-emulation/wine/wine-20050930.ebuild
index 09e5f7c5ceb2..9ca56ceae5d9 100644
--- a/app-emulation/wine/wine-20050930.ebuild
+++ b/app-emulation/wine/wine-20050930.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050930.ebuild,v 1.9 2006/01/14 18:39:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050930.ebuild,v 1.10 2006/01/27 00:35:00 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -84,7 +84,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-no-ssp.patch #66002
epatch "${FILESDIR}"/wine-20050930-no-x.patch
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 80840e8fdb14..fe0077125093 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.3 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.4 2006/01/27 00:35:00 vapier Exp $
ECVS_SERVER="cvs.winehq.org:/home/wine"
ECVS_MODULE="wine"
@@ -90,7 +90,6 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}