summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-10-22 21:21:06 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-10-22 21:21:06 +0000
commitdbae16e0f2f7fcab66abf87bd6f2f551c134476f (patch)
tree0e3b0261847e1db16a8270540619fff9c57159f8 /app-emulation/vmware-modules/files
parentDrop old (diff)
downloadgentoo-2-dbae16e0f2f7fcab66abf87bd6f2f551c134476f.tar.gz
gentoo-2-dbae16e0f2f7fcab66abf87bd6f2f551c134476f.tar.bz2
gentoo-2-dbae16e0f2f7fcab66abf87bd6f2f551c134476f.zip
Drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-emulation/vmware-modules/files')
-rw-r--r--app-emulation/vmware-modules/files/238-2.6.39.patch243
-rw-r--r--app-emulation/vmware-modules/files/238-3.2.0.patch103
-rw-r--r--app-emulation/vmware-modules/files/238-d-make-root.patch14
-rw-r--r--app-emulation/vmware-modules/files/238-jobserver.patch75
-rw-r--r--app-emulation/vmware-modules/files/238-makefile-include.patch65
-rw-r--r--app-emulation/vmware-modules/files/238-makefile-kernel-dir.patch80
-rw-r--r--app-emulation/vmware-modules/files/238-netdevice.patch24
-rw-r--r--app-emulation/vmware-modules/files/238-sema.patch83
-rw-r--r--app-emulation/vmware-modules/files/238-unlocked_ioctl.patch33
9 files changed, 0 insertions, 720 deletions
diff --git a/app-emulation/vmware-modules/files/238-2.6.39.patch b/app-emulation/vmware-modules/files/238-2.6.39.patch
deleted file mode 100644
index 88873e581400..000000000000
--- a/app-emulation/vmware-modules/files/238-2.6.39.patch
+++ /dev/null
@@ -1,243 +0,0 @@
-diff --git a/vmblock-only/linux/dentry.c b/vmblock-only/linux/dentry.c
-index 66537c8..05ea95a 100644
---- a/vmblock-only/linux/dentry.c
-+++ b/vmblock-only/linux/dentry.c
-@@ -104,7 +104,7 @@ DentryOpRevalidate(struct dentry *dentry, // IN: dentry revalidating
- return actualDentry->d_op->d_revalidate(actualDentry, nd);
- }
-
-- if (path_lookup(iinfo->name, 0, &actualNd)) {
-+ if (compat_path_lookup(iinfo->name, 0, &actualNd)) {
- LOG(4, "DentryOpRevalidate: [%s] no longer exists\n", iinfo->name);
- return 0;
- }
-diff --git a/vmblock-only/linux/filesystem.c b/vmblock-only/linux/filesystem.c
-index 53840fd..bc117c5 100644
---- a/vmblock-only/linux/filesystem.c
-+++ b/vmblock-only/linux/filesystem.c
-@@ -66,7 +66,6 @@ static size_t fsRootLen;
- static struct file_system_type fsType = {
- .owner = THIS_MODULE,
- .name = VMBLOCK_FS_NAME,
-- .get_sb = FsOpGetSb,
- .kill_sb = kill_anon_super,
- };
-
-@@ -553,7 +552,7 @@ FsOpReadSuper(struct super_block *sb, // OUT: Superblock object
- *-----------------------------------------------------------------------------
- */
-
--static int
-+/*static int
- FsOpGetSb(struct file_system_type *fs_type, // IN: file system type of mount
- int flags, // IN: mount flags
- const char *dev_name, // IN: device mounting on
-@@ -561,7 +560,7 @@ FsOpGetSb(struct file_system_type *fs_type, // IN: file system type of mount
- struct vfsmount *mnt) // IN: vfs mount
- {
- return get_sb_nodev(fs_type, flags, rawData, FsOpReadSuper, mnt);
--}
-+}*/
- #else
- /*
- *-----------------------------------------------------------------------------
-diff --git a/vmblock-only/shared/compat_namei.h b/vmblock-only/shared/compat_namei.h
-index 28d72c8..4214247 100644
---- a/vmblock-only/shared/compat_namei.h
-+++ b/vmblock-only/shared/compat_namei.h
-@@ -40,8 +40,11 @@
- #define compat_path_release(nd) path_release(nd)
- #endif
-
-+/* path_lookup was removed in 2.6.39 merge window VFS merge */
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 39)
-+#define compat_path_lookup(name, flags, nd) kern_path(name, flags, &((nd)->path))
- /* path_lookup was exported in 2.4.25 */
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 4, 25)
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2, 4, 25)
- #define compat_path_lookup(path, flags, nd) path_lookup(path, flags, nd)
- #else
- #define compat_path_lookup(path, flags, nd) \
-diff --git a/vmci-only/linux/driver.c b/vmci-only/linux/driver.c
-index a0f5498..49795e1 100644
---- a/vmci-only/linux/driver.c
-+++ b/vmci-only/linux/driver.c
-@@ -42,7 +42,6 @@ sys_ioctl(unsigned int fd, unsigned int cmd, unsigned long arg);
- #include <linux/miscdevice.h>
- #include <linux/poll.h>
- #include <linux/smp.h>
--#include <linux/smp_lock.h>
-
- #include "compat_file.h"
- #include "compat_highmem.h"
-diff --git a/vmmon-only/linux/driver.c b/vmmon-only/linux/driver.c
-index a33c983..89f8827 100644
---- a/vmmon-only/linux/driver.c
-+++ b/vmmon-only/linux/driver.c
-@@ -781,7 +781,7 @@ LinuxDriver_Close(struct inode *inode, // IN
-
-
- #define POLLQUEUE_MAX_TASK 1000
--static spinlock_t pollQueueLock __attribute__((unused)) = SPIN_LOCK_UNLOCKED;
-+static DEFINE_SPINLOCK(pollQueueLock);
- static void *pollQueue[POLLQUEUE_MAX_TASK];
- static unsigned int pollQueueCount = 0;
-
-@@ -1042,7 +1042,8 @@ LinuxDriverPoll(struct file *filp,
- * but unfortunately there is no way how to detect that
- * we are building for RedHat's kernel...
- */
-- static spinlock_t timerLock = SPIN_LOCK_UNLOCKED;
-+
-+ static DEFINE_SPINLOCK(timerLock);
-
- spin_lock(&timerLock);
- mod_timer(&linuxState.pollTimer, jiffies + 1);
-diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
-index 6c7b34d..fabb44d 100644
---- a/vmmon-only/linux/hostif.c
-+++ b/vmmon-only/linux/hostif.c
-@@ -46,7 +46,6 @@
- #include <linux/mman.h>
-
- #include <linux/smp.h>
--#include <linux/smp_lock.h>
-
- #include <asm/io.h>
- #include <linux/mc146818rtc.h>
-diff --git a/vmmon-only/linux/iommu.c b/vmmon-only/linux/iommu.c
-index f64e80a..b0ee013 100644
---- a/vmmon-only/linux/iommu.c
-+++ b/vmmon-only/linux/iommu.c
-@@ -44,7 +44,7 @@ typedef struct PassthruDevice {
-
-
- static LIST_HEAD(passthruDeviceList);
--static spinlock_t passthruDeviceListLock = SPIN_LOCK_UNLOCKED;
-+static DEFINE_SPINLOCK(passthruDeviceListLock);
- static void *pciHolePage = NULL;
-
- /*
-diff --git a/vmnet-only/driver.c b/vmnet-only/driver.c
-index c91a1dc..4c195e1 100644
---- a/vmnet-only/driver.c
-+++ b/vmnet-only/driver.c
-@@ -28,7 +28,6 @@
- #include <linux/poll.h>
-
- #include <linux/smp.h>
--#include <linux/smp_lock.h>
-
- #include <linux/netdevice.h>
- #include <linux/etherdevice.h>
-@@ -105,7 +104,7 @@ const uint8 broadcast[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff, 0xff};
- * not have vnetStructureMutex already acquired,
- * it is most certainly a bug.
- */
--static rwlock_t vnetPeerLock = RW_LOCK_UNLOCKED;
-+static DEFINE_RWLOCK(vnetPeerLock);
-
- /*
- * All concurrent changes to the network structure are
-@@ -115,6 +114,7 @@ static rwlock_t vnetPeerLock = RW_LOCK_UNLOCKED;
- * vnetStructureMutex and vnetPeerLock for write.
- */
- compat_define_mutex(vnetStructureMutex);
-+compat_define_mutex(vnetMutex);
-
- #if defined(VM_X86_64) && !defined(HAVE_COMPAT_IOCTL)
- /*
-@@ -264,11 +264,11 @@ LinuxDriver_Ioctl32_Handler(unsigned int fd, // IN: (unused)
- struct file * filp) // IN:
- {
- int ret = -ENOTTY;
-- lock_kernel();
-+ compat_mutex_lock(&vnetMutex);
- if (filp && filp->f_op && filp->f_op->ioctl == VNetFileOpIoctl) {
- ret = VNetFileOpIoctl(filp->f_dentry->d_inode, filp, iocmd, ioarg);
- }
-- unlock_kernel();
-+ compat_mutex_unlock(&vnetMutex);
- return ret;
- }
-
-@@ -1134,9 +1134,9 @@ VNetFileOpUnlockedIoctl(struct file *filp, // IN:
- if (filp && filp->f_dentry) {
- inode = filp->f_dentry->d_inode;
- }
-- lock_kernel();
-+ compat_mutex_lock(&vnetMutex);
- err = VNetFileOpIoctl(inode, filp, iocmd, ioarg);
-- unlock_kernel();
-+ compat_mutex_unlock(&vnetMutex);
- return err;
- }
- #endif
-diff --git a/vmnet-only/filter.c b/vmnet-only/filter.c
-index 34b7d3d..b0017d7 100644
---- a/vmnet-only/filter.c
-+++ b/vmnet-only/filter.c
-@@ -85,7 +85,7 @@ static compat_define_mutex(filterIoctlMutex); /* serialize ioctl()s from user sp
- * callbacks can be concurrently executing on multiple threads on multiple
- * CPUs, so we should revisit locking for allowing for that in the future.
- */
--spinlock_t activeRuleLock = SPIN_LOCK_UNLOCKED;
-+DEFINE_SPINLOCK(activeRuleLock);
-
- /*
- * Logging.
-diff --git a/vmnet-only/hub.c b/vmnet-only/hub.c
-index b05efea..38d9aef 100644
---- a/vmnet-only/hub.c
-+++ b/vmnet-only/hub.c
-@@ -81,7 +81,7 @@ static VNetHub *vnetHub = NULL;
- * so we use __attribute__((unused)) to quiet the compiler.
- */
-
--static spinlock_t vnetHubLock __attribute__((unused)) = SPIN_LOCK_UNLOCKED;
-+static DEFINE_SPINLOCK(vnetHubLock);
-
-
- /*
-diff --git a/vsock-only/linux/af_vsock.c b/vsock-only/linux/af_vsock.c
-index ecd057e..d565ec0 100644
---- a/vsock-only/linux/af_vsock.c
-+++ b/vsock-only/linux/af_vsock.c
-@@ -102,7 +102,6 @@
- #include <linux/miscdevice.h>
- #include <linux/poll.h>
- #include <linux/smp.h>
--#include <linux/smp_lock.h>
- #include <asm/io.h>
- #if defined(__x86_64__) && LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 12)
- # if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
-diff --git a/vsock-only/linux/util.c b/vsock-only/linux/util.c
-index 53f2edb..32a7da7 100644
---- a/vsock-only/linux/util.c
-+++ b/vsock-only/linux/util.c
-@@ -34,7 +34,7 @@
- struct list_head vsockBindTable[VSOCK_HASH_SIZE + 1];
- struct list_head vsockConnectedTable[VSOCK_HASH_SIZE];
-
--spinlock_t vsockTableLock = SPIN_LOCK_UNLOCKED;
-+DEFINE_SPINLOCK(vsockTableLock);
-
- /*
- * snprintf() wasn't exported until 2.4.10: fall back on sprintf in those
-diff --git a/vsock-only/shared/compat_namei.h b/vsock-only/shared/compat_namei.h
-index 28d72c8..4214247 100644
---- a/vsock-only/shared/compat_namei.h
-+++ b/vsock-only/shared/compat_namei.h
-@@ -40,8 +40,11 @@
- #define compat_path_release(nd) path_release(nd)
- #endif
-
-+/* path_lookup was removed in 2.6.39 merge window VFS merge */
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 39)
-+#define compat_path_lookup(name, flags, nd) kern_path(name, flags, &((nd)->path))
- /* path_lookup was exported in 2.4.25 */
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 4, 25)
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2, 4, 25)
- #define compat_path_lookup(path, flags, nd) path_lookup(path, flags, nd)
- #else
- #define compat_path_lookup(path, flags, nd) \
diff --git a/app-emulation/vmware-modules/files/238-3.2.0.patch b/app-emulation/vmware-modules/files/238-3.2.0.patch
deleted file mode 100644
index 0416214c3125..000000000000
--- a/app-emulation/vmware-modules/files/238-3.2.0.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-diff --git a/vmmon-only/linux/iommu.c b/vmmon-only/linux/iommu.c
-index b0ee013..f0f5c9a 100644
---- a/vmmon-only/linux/iommu.c
-+++ b/vmmon-only/linux/iommu.c
-@@ -36,6 +36,12 @@
- #define PCI_BDF_SLOTFUNC(bdf) PCI_DEVFN(PCI_SLOT(bdf), PCI_FUNC(bdf))
- #define PCI_BDF_BUS(bdf) (((bdf) >> 8) & 0xff)
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 2, 0)
-+#include <linux/pci.h>
-+#define iommu_found() iommu_present(&pci_bus_type)
-+#define iommu_domain_alloc() iommu_domain_alloc(&pci_bus_type)
-+#endif
-+
- typedef struct PassthruDevice {
- struct pci_dev *pdev;
- VMLinux *vmLinux;
-diff --git a/vmnet-only/filter.c b/vmnet-only/filter.c
-index b0017d7..6c0687f 100644
---- a/vmnet-only/filter.c
-+++ b/vmnet-only/filter.c
-@@ -41,6 +41,10 @@
- #include "vnetInt.h"
- #include "vmnetInt.h"
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 2, 0)
-+#include <linux/export.h>
-+#endif
-+
- // VNet_FilterLogPacket.action for dropped packets
- #define VNET_FILTER_ACTION_DRP (1)
- #define VNET_FILTER_ACTION_DRP_SHORT (2)
-diff --git a/vmnet-only/netif.c b/vmnet-only/netif.c
-index b3c752b..79d4896 100644
---- a/vmnet-only/netif.c
-+++ b/vmnet-only/netif.c
-@@ -62,7 +62,9 @@ static int VNetNetifClose(struct net_device *dev);
- static int VNetNetifStartXmit(struct sk_buff *skb, struct net_device *dev);
- static struct net_device_stats *VNetNetifGetStats(struct net_device *dev);
- static int VNetNetifSetMAC(struct net_device *dev, void *addr);
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
- static void VNetNetifSetMulticast(struct net_device *dev);
-+#endif
- #if 0
- static void VNetNetifTxTimeout(struct net_device *dev);
- #endif
-@@ -131,7 +133,9 @@ VNetNetIfSetup(struct net_device *dev) // IN:
- .ndo_stop = VNetNetifClose,
- .ndo_get_stats = VNetNetifGetStats,
- .ndo_set_mac_address = VNetNetifSetMAC,
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
- .ndo_set_multicast_list = VNetNetifSetMulticast,
-+#endif
- /*
- * We cannot stuck... If someone will report problems under
- * low memory conditions or some such, we should enable it.
-@@ -152,7 +156,9 @@ VNetNetIfSetup(struct net_device *dev) // IN:
- dev->stop = VNetNetifClose;
- dev->get_stats = VNetNetifGetStats;
- dev->set_mac_address = VNetNetifSetMAC;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
- dev->set_multicast_list = VNetNetifSetMulticast;
-+#endif
- /*
- * We cannot stuck... If someone will report problems under
- * low memory conditions or some such, we should enable it.
-@@ -621,11 +627,12 @@ VNetNetifSetMAC(struct net_device *dev, // IN:
- *----------------------------------------------------------------------
- */
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
- void
- VNetNetifSetMulticast(struct net_device *dev) // IN: unused
- {
- }
--
-+#endif
-
- /*
- *----------------------------------------------------------------------
-diff --git a/vmnet-only/userif.c b/vmnet-only/userif.c
-index 4e65c76..fd12aa9 100644
---- a/vmnet-only/userif.c
-+++ b/vmnet-only/userif.c
-@@ -572,10 +572,18 @@ VNetCsumCopyDatagram(const struct sk_buff *skb, // IN: skb to copy
- unsigned int tmpCsum;
- const void *vaddr;
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 2, 0)
-+ vaddr = kmap(skb_frag_page(frag));
-+#else
- vaddr = kmap(frag->page);
-+#endif
- tmpCsum = csum_and_copy_to_user(vaddr + frag->page_offset,
- curr, frag->size, 0, &err);
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 2, 0)
-+ kunmap(skb_frag_page(frag));
-+#else
- kunmap(frag->page);
-+#endif
- if (err) {
- return err;
- }
diff --git a/app-emulation/vmware-modules/files/238-d-make-root.patch b/app-emulation/vmware-modules/files/238-d-make-root.patch
deleted file mode 100644
index 7e83a1e91092..000000000000
--- a/app-emulation/vmware-modules/files/238-d-make-root.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/vmblock-only/linux/filesystem.c 2012-05-23 20:08:00.632051396 -0500
-+++ b/vmblock-only/linux/filesystem.c 2012-05-23 20:17:00.896297163 -0500
-@@ -517,7 +517,11 @@
- return -EINVAL;
- }
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 4, 0)
- rootDentry = d_alloc_root(rootInode);
-+#else
-+ rootDentry = d_make_root(rootInode);
-+#endif
- if (!rootDentry) {
- iput(rootInode);
- return -ENOMEM;
diff --git a/app-emulation/vmware-modules/files/238-jobserver.patch b/app-emulation/vmware-modules/files/238-jobserver.patch
deleted file mode 100644
index 59a6ccca1da0..000000000000
--- a/app-emulation/vmware-modules/files/238-jobserver.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-diff -ru a/work/vmblock-only/Makefile b/work/vmblock-only/Makefile
---- a/work/vmblock-only/Makefile 2011-01-22 08:59:15.907152002 -0500
-+++ b/work/vmblock-only/Makefile 2011-01-22 09:13:55.894938002 -0500
-@@ -123,9 +123,9 @@
- postbuild:: ;
-
- $(DRIVER_KO): prebuild
-- make -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) modules
-- make -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild
- endif
-
-diff -ru a/work/vmci-only/Makefile b/work/vmci-only/Makefile
---- a/work/vmci-only/Makefile 2011-01-22 08:59:15.907152002 -0500
-+++ b/work/vmci-only/Makefile 2011-01-22 09:13:55.898936002 -0500
-@@ -123,9 +123,9 @@
- postbuild:: ;
-
- $(DRIVER_KO): prebuild
-- make -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) modules
-- make -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild
- endif
-
-diff -ru a/work/vmmon-only/Makefile b/work/vmmon-only/Makefile
---- a/work/vmmon-only/Makefile 2011-01-22 08:59:15.907152002 -0500
-+++ b/work/vmmon-only/Makefile 2011-01-22 09:13:55.894938002 -0500
-@@ -123,9 +123,9 @@
- postbuild:: ;
-
- $(DRIVER_KO): prebuild
-- make -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) modules
-- make -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild
- endif
-
-diff -ru a/work/vmnet-only/Makefile b/work/vmnet-only/Makefile
---- a/work/vmnet-only/Makefile 2011-01-22 08:59:15.911150002 -0500
-+++ b/work/vmnet-only/Makefile 2011-01-22 09:13:55.898936002 -0500
-@@ -123,9 +123,9 @@
- postbuild:: ;
-
- $(DRIVER_KO): prebuild
-- make -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) modules
-- make -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild
- endif
-
-diff -ru a/work/vsock-only/Makefile b/work/vsock-only/Makefile
---- a/work/vsock-only/Makefile 2011-01-22 08:59:15.911150002 -0500
-+++ b/work/vsock-only/Makefile 2011-01-22 09:13:55.894938002 -0500
-@@ -123,9 +123,9 @@
- postbuild:: ;
-
- $(DRIVER_KO): prebuild
-- make -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) modules
-- make -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild
- endif
-
diff --git a/app-emulation/vmware-modules/files/238-makefile-include.patch b/app-emulation/vmware-modules/files/238-makefile-include.patch
deleted file mode 100644
index 777a3fd8bb6f..000000000000
--- a/app-emulation/vmware-modules/files/238-makefile-include.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff --git a/work/vmblock-only/Makefile.kernel b/work/vmblock-only/Makefile.kernel
-index 9d7c5ca..92cefff 100644
---- a/work/vmblock-only/Makefile.kernel
-+++ b/work/vmblock-only/Makefile.kernel
-@@ -19,7 +19,7 @@
-
- INCLUDE += -I$(SRCROOT)/include
-
--EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE)
-+EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE) $(LINUXINCLUDE)
-
- EXTRA_CFLAGS += $(call vm_check_build, $(AUTOCONF_DIR)/setnice.c, -DVMW_HAVE_SET_USER_NICE, )
- EXTRA_CFLAGS += $(call vm_check_build, $(AUTOCONF_DIR)/epoll.c, -DVMW_HAVE_EPOLL, )
-diff --git a/work/vmci-only/Makefile.kernel b/work/vmci-only/Makefile.kernel
-index 22dc232..67e709f 100644
---- a/work/vmci-only/Makefile.kernel
-+++ b/work/vmci-only/Makefile.kernel
-@@ -21,7 +21,7 @@ CC_OPTS += -DVMCI
-
- INCLUDE := -I$(SRCROOT)/include -I$(SRCROOT)/common -I$(SRCROOT)/linux
-
--EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE)
-+EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE) $(LINUXINCLUDE)
-
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/autoconf/epoll.c, -DVMW_HAVE_EPOLL, )
-
-diff --git a/work/vmmon-only/Makefile.kernel b/work/vmmon-only/Makefile.kernel
-index a7e26ea..befaca7 100644
---- a/work/vmmon-only/Makefile.kernel
-+++ b/work/vmmon-only/Makefile.kernel
-@@ -22,7 +22,7 @@ CC_OPTS += -DVMMON -DVMCORE
- INCLUDE := -I$(SRCROOT)/include -I$(SRCROOT)/common -I$(SRCROOT)/linux \
- -I$(SRCROOT)/vmcore
-
--EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE)
-+EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE) $(LINUXINCLUDE)
-
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/autoconf/nopage1.c, -DVMW_NOPAGE_261, )
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/autoconf/skas1.c, -DVMW_SKAS_MMAP, )
-diff --git a/work/vmnet-only/Makefile.kernel b/work/vmnet-only/Makefile.kernel
-index 4b16d06..0e252a6 100644
---- a/work/vmnet-only/Makefile.kernel
-+++ b/work/vmnet-only/Makefile.kernel
-@@ -19,7 +19,7 @@
-
- INCLUDE := -I$(SRCROOT)
-
--EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE)
-+EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE) $(LINUXINCLUDE)
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/epoll.c, -DVMW_HAVE_EPOLL, )
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/sk_alloc.c,-DVMW_HAVE_SK_ALLOC_WITH_PROTO, )
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/netdev_has_net.c,-DVMW_NETDEV_HAS_NET, )
-diff --git a/work/vsock-only/Makefile.kernel b/work/vsock-only/Makefile.kernel
-index 47ef5f3..b3539ef 100644
---- a/work/vsock-only/Makefile.kernel
-+++ b/work/vsock-only/Makefile.kernel
-@@ -25,7 +25,7 @@ INCLUDE += -I$(SRCROOT)/include
- INCLUDE += -I$(SRCROOT)/linux
- INCLUDE += -I$(SRCROOT)/common
-
--EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE)
-+EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE) $(LINUXINCLUDE)
- EXTRA_CFLAGS += $(call vm_check_build, $(AUTOCONF_DIR)/epoll.c, -DVMW_HAVE_EPOLL, )
- EXTRA_CFLAGS += $(call vm_check_build, $(AUTOCONF_DIR)/setnice.c, -DVMW_HAVE_SET_USER_NICE, )
-
diff --git a/app-emulation/vmware-modules/files/238-makefile-kernel-dir.patch b/app-emulation/vmware-modules/files/238-makefile-kernel-dir.patch
deleted file mode 100644
index d4bd6d12fed0..000000000000
--- a/app-emulation/vmware-modules/files/238-makefile-kernel-dir.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-diff --git a/work/vmblock-only/Makefile b/work/vmblock-only/Makefile
-index 0bd0e74..27c3ede 100644
---- a/work/vmblock-only/Makefile
-+++ b/work/vmblock-only/Makefile
-@@ -46,9 +46,9 @@ endif
- VM_UNAME = $(shell uname -r)
-
- # Header directory for the running kernel
--HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
-+HEADER_DIR = $(KERNEL_DIR)
-
--BUILD_DIR = $(HEADER_DIR)/..
-+BUILD_DIR = $(KBUILD_OUTPUT)
-
- DRIVER := vmblock
- PRODUCT := tools
-diff --git a/work/vmci-only/Makefile b/work/vmci-only/Makefile
-index 7babb8a..fbc5878 100644
---- a/work/vmci-only/Makefile
-+++ b/work/vmci-only/Makefile
-@@ -46,9 +46,9 @@ endif
- VM_UNAME = $(shell uname -r)
-
- # Header directory for the running kernel
--HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
-+HEADER_DIR = $(KERNEL_DIR)
-
--BUILD_DIR = $(HEADER_DIR)/..
-+BUILD_DIR = $(KBUILD_OUTPUT)
-
- DRIVER := vmci
- PRODUCT := @@PRODUCT@@
-diff --git a/work/vmmon-only/Makefile b/work/vmmon-only/Makefile
-index 4b4eb3e..1bb35ef 100644
---- a/work/vmmon-only/Makefile
-+++ b/work/vmmon-only/Makefile
-@@ -46,9 +46,9 @@ endif
- VM_UNAME = $(shell uname -r)
-
- # Header directory for the running kernel
--HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
-+HEADER_DIR = $(KERNEL_DIR)
-
--BUILD_DIR = $(HEADER_DIR)/..
-+BUILD_DIR = $(KBUILD_OUTPUT)
-
- DRIVER := vmmon
- PRODUCT := @@PRODUCT@@
-diff --git a/work/vmnet-only/Makefile b/work/vmnet-only/Makefile
-index 06856e7..fd53bf8 100644
---- a/work/vmnet-only/Makefile
-+++ b/work/vmnet-only/Makefile
-@@ -46,9 +46,9 @@ endif
- VM_UNAME = $(shell uname -r)
-
- # Header directory for the running kernel
--HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
-+HEADER_DIR = $(KERNEL_DIR)
-
--BUILD_DIR = $(HEADER_DIR)/..
-+BUILD_DIR = $(KBUILD_OUTPUT)
-
- DRIVER := vmnet
- PRODUCT := @@PRODUCT@@
-diff --git a/work/vsock-only/Makefile b/work/vsock-only/Makefile
-index e02adb0..210e502 100644
---- a/work/vsock-only/Makefile
-+++ b/work/vsock-only/Makefile
-@@ -46,9 +46,9 @@ endif
- VM_UNAME = $(shell uname -r)
-
- # Header directory for the running kernel
--HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
-+HEADER_DIR = $(KERNEL_DIR)
-
--BUILD_DIR = $(HEADER_DIR)/..
-+BUILD_DIR = $(KBUILD_OUTPUT)
-
- DRIVER := vsock
- PRODUCT := ws
diff --git a/app-emulation/vmware-modules/files/238-netdevice.patch b/app-emulation/vmware-modules/files/238-netdevice.patch
deleted file mode 100644
index 35231a3205e3..000000000000
--- a/app-emulation/vmware-modules/files/238-netdevice.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/vmnet-only/compat_netdevice.h b/vmnet-only/compat_netdevice.h
-index 7a56304..9ff4548 100644
---- a/vmnet-only/compat_netdevice.h
-+++ b/vmnet-only/compat_netdevice.h
-@@ -47,6 +47,19 @@
- # define net_device device
- #endif
-
-+/* it looks like these have been removed from the kernel 3.1
-+ * probably because the "transition" is considered complete.
-+ * so to keep this source compatible we just redefine them like they were
-+ * previously
-+ */
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 1, 0)
-+#define HAVE_ALLOC_NETDEV /* feature macro: alloc_xxxdev
-+ functions are available. */
-+#define HAVE_FREE_NETDEV /* free_netdev() */
-+#define HAVE_NETDEV_PRIV /* netdev_priv() */
-+#define HAVE_NETIF_QUEUE
-+#define HAVE_NET_DEVICE_OPS
-+#endif
-
- /*
- * SET_MODULE_OWNER appeared sometime during 2.3.x. It was setting
diff --git a/app-emulation/vmware-modules/files/238-sema.patch b/app-emulation/vmware-modules/files/238-sema.patch
deleted file mode 100644
index 1ebdab7ee009..000000000000
--- a/app-emulation/vmware-modules/files/238-sema.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-diff -ru original//vmci-only/include/compat_semaphore.h patched//vmci-only/include/compat_semaphore.h
---- original//vmci-only/include/compat_semaphore.h 2010-11-11 15:37:25.000000000 -0500
-+++ patched//vmci-only/include/compat_semaphore.h 2010-11-20 10:11:56.000000000 -0500
-@@ -28,7 +28,7 @@
- #endif
-
-
--#if defined CONFIG_PREEMPT_RT && LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 31)
-+#if (defined CONFIG_PREEMPT_RT && LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 31)) || LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 37)
- /*
- * The -rt patch series changes the name of semaphore/mutex initialization
- * routines (across the entire kernel). Probably to identify locations that
-@@ -41,7 +41,7 @@
- #define DECLARE_MUTEX(_m) DEFINE_SEMAPHORE(_m)
- #endif
- #ifndef init_MUTEX
-- #define init_MUTEX(_m) semaphore_init(_m)
-+ #define init_MUTEX(_m) sema_init(_m,1)
- #endif
- #endif
-
-diff -ru original//vmmon-only/linux/driver.c patched//vmmon-only/linux/driver.c
---- original//vmmon-only/linux/driver.c 2010-11-11 15:37:22.000000000 -0500
-+++ patched//vmmon-only/linux/driver.c 2010-11-29 23:09:16.000000000 -0500
-@@ -145,7 +145,7 @@
- #endif
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 0) && \
- (defined(CONFIG_SMP) || defined(CONFIG_PREEMPT))
--# define kernel_locked_by_current() kernel_locked()
-+# define kernel_locked_by_current() (current->lock_depth >= 0)
- #else
- # define kernel_locked_by_current() 0
- #endif
-@@ -170,6 +170,7 @@
- static int LinuxDriver_Ioctl(struct inode *inode, struct file *filp,
- u_int iocmd, unsigned long ioarg);
- #if defined(HAVE_UNLOCKED_IOCTL) || defined(HAVE_COMPAT_IOCTL)
-+#define VMW_HAVE_UNLOCKED_IOCTL
- static long LinuxDriver_UnlockedIoctl(struct file *filp,
- u_int iocmd, unsigned long ioarg);
- #endif
-diff -ru original//vmnet-only/compat_semaphore.h patched//vmnet-only/compat_semaphore.h
---- original//vmnet-only/compat_semaphore.h 2010-11-11 15:37:23.000000000 -0500
-+++ patched//vmnet-only/compat_semaphore.h 2010-11-20 10:11:56.000000000 -0500
-@@ -28,7 +28,7 @@
- #endif
-
-
--#if defined CONFIG_PREEMPT_RT && LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 31)
-+#if (defined CONFIG_PREEMPT_RT && LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 31)) || LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 37)
- /*
- * The -rt patch series changes the name of semaphore/mutex initialization
- * routines (across the entire kernel). Probably to identify locations that
-@@ -41,7 +41,7 @@
- #define DECLARE_MUTEX(_m) DEFINE_SEMAPHORE(_m)
- #endif
- #ifndef init_MUTEX
-- #define init_MUTEX(_m) semaphore_init(_m)
-+ #define init_MUTEX(_m) sema_init(_m,1)
- #endif
- #endif
-
-diff -ru original//vsock-only/shared/compat_semaphore.h patched//vsock-only/shared/compat_semaphore.h
---- original//vsock-only/shared/compat_semaphore.h 2010-11-11 13:04:44.000000000 -0500
-+++ patched//vsock-only/shared/compat_semaphore.h 2010-11-20 10:11:56.000000000 -0500
-@@ -28,7 +28,7 @@
- #endif
-
-
--#if defined CONFIG_PREEMPT_RT && LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 31)
-+#if (defined CONFIG_PREEMPT_RT && LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 31)) || LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 37)
- /*
- * The -rt patch series changes the name of semaphore/mutex initialization
- * routines (across the entire kernel). Probably to identify locations that
-@@ -41,7 +41,7 @@
- #define DECLARE_MUTEX(_m) DEFINE_SEMAPHORE(_m)
- #endif
- #ifndef init_MUTEX
-- #define init_MUTEX(_m) semaphore_init(_m)
-+ #define init_MUTEX(_m) sema_init(_m,1)
- #endif
- #endif
-
diff --git a/app-emulation/vmware-modules/files/238-unlocked_ioctl.patch b/app-emulation/vmware-modules/files/238-unlocked_ioctl.patch
deleted file mode 100644
index 3f1cd030c425..000000000000
--- a/app-emulation/vmware-modules/files/238-unlocked_ioctl.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/vmmon-only/linux/driver.c b/vmmon-only/linux/driver.c
-index 1a0e753..089aba3 100644
---- a/vmmon-only/linux/driver.c
-+++ b/vmmon-only/linux/driver.c
-@@ -170,6 +170,7 @@ static int LinuxDriver_Open(struct inode *inode, struct file *filp);
- static int LinuxDriver_Ioctl(struct inode *inode, struct file *filp,
- u_int iocmd, unsigned long ioarg);
- #if defined(HAVE_UNLOCKED_IOCTL) || defined(HAVE_COMPAT_IOCTL)
-+#define VMW_HAVE_UNLOCKED_IOCTL
- static long LinuxDriver_UnlockedIoctl(struct file *filp,
- u_int iocmd, unsigned long ioarg);
- #endif
-diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
-index 5847323..9042b97 100644
---- a/vmmon-only/linux/hostif.c
-+++ b/vmmon-only/linux/hostif.c
-@@ -3702,7 +3702,7 @@ HostIFDoIoctl(struct file *filp,
- if (filp->f_op->unlocked_ioctl) {
- return filp->f_op->unlocked_ioctl(filp, iocmd, ioarg);
- }
--#endif
-+#else
- if (filp->f_op->ioctl) {
- long err;
-
-@@ -3712,6 +3712,7 @@ HostIFDoIoctl(struct file *filp,
-
- return err;
- }
-+#endif
-
- return -ENOIOCTLCMD;
- }