summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-08 23:20:29 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-08 23:20:29 +0000
commit2a3114e748e09d57e020adbe2f4fa877b031920d (patch)
tree99fd490d06089b64060624c5e42d15694df313c1 /app-emulation/point2play
parentversion bump (bug #84543) (diff)
downloadgentoo-2-2a3114e748e09d57e020adbe2f4fa877b031920d.tar.gz
gentoo-2-2a3114e748e09d57e020adbe2f4fa877b031920d.tar.bz2
gentoo-2-2a3114e748e09d57e020adbe2f4fa877b031920d.zip
Version bump #84504 by Joel Konkle-Parker.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emulation/point2play')
-rw-r--r--app-emulation/point2play/ChangeLog7
-rw-r--r--app-emulation/point2play/files/digest-point2play-1.3.31
-rw-r--r--app-emulation/point2play/point2play-1.3.3.ebuild42
3 files changed, 49 insertions, 1 deletions
diff --git a/app-emulation/point2play/ChangeLog b/app-emulation/point2play/ChangeLog
index 8a5efc13a6fd..38949fe38cc6 100644
--- a/app-emulation/point2play/ChangeLog
+++ b/app-emulation/point2play/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/point2play
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.16 2005/01/01 14:15:42 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.17 2005/03/08 23:20:29 vapier Exp $
+
+*point2play-1.3.3 (08 Mar 2005)
+
+ 08 Mar 2005; Mike Frysinger <vapier@gentoo.org> +point2play-1.3.3.ebuild:
+ Version bump #84504 by Joel Konkle-Parker.
*point2play-1.3.2 (24 Oct 2004)
diff --git a/app-emulation/point2play/files/digest-point2play-1.3.3 b/app-emulation/point2play/files/digest-point2play-1.3.3
new file mode 100644
index 000000000000..6c1d7b7349a0
--- /dev/null
+++ b/app-emulation/point2play/files/digest-point2play-1.3.3
@@ -0,0 +1 @@
+MD5 7a382a95d61b1f63ccd67b3e1fdcb8e3 point2play-small-1.3.3-1.tgz 824377
diff --git a/app-emulation/point2play/point2play-1.3.3.ebuild b/app-emulation/point2play/point2play-1.3.3.ebuild
new file mode 100644
index 000000000000..70657cecc5f6
--- /dev/null
+++ b/app-emulation/point2play/point2play-1.3.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.3.3.ebuild,v 1.1 2005/03/08 23:20:29 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-small-${PV}-1
+DESCRIPTION="graphical frontend for WineX"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="point2play"
+SLOT="0"
+KEYWORDS="-* ~amd64 x86"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-1.99.16"
+ #>=x11-themes/gtk-engines-metal-2.2.0"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Point2Play archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ echo
+ einfo "The archive should then be placed into ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.3.2-fix-sound-test.patch
+}
+
+src_install() {
+ mv usr "${D}"/ || die "mv usr"
+ mv etc/X11/applnk "${D}"/usr/share
+ make_desktop_entry Point2Play Point2Play /usr/lib/transgaming_point2play/pixmaps/tg_logo.png
+}