summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2003-01-31 03:53:11 +0000
committerMark Guertin <gerk@gentoo.org>2003-01-31 03:53:11 +0000
commit76eb0473e8a9d5ec332ab2eb5d689316d7b39d31 (patch)
treed3f5475affe536ea1b29ebe996f2b318b031c2be /app-emulation/mol
parentfixes and additions. see tha changelog, fool! (diff)
downloadgentoo-2-76eb0473e8a9d5ec332ab2eb5d689316d7b39d31.tar.gz
gentoo-2-76eb0473e8a9d5ec332ab2eb5d689316d7b39d31.tar.bz2
gentoo-2-76eb0473e8a9d5ec332ab2eb5d689316d7b39d31.zip
rev bump to fix bug # 13136
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/ChangeLog7
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.65-r11
-rw-r--r--app-emulation/mol/files/mol-0.9.65_dhcp-fix.diff13
-rw-r--r--app-emulation/mol/mol-0.9.65-r1.ebuild44
4 files changed, 64 insertions, 1 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 5dc3afdc4d9b..8ffbdfb1efee 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for app-emulation/mol
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.9 2002/12/13 10:56:08 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.10 2003/01/31 03:53:08 gerk Exp $
+*mol-0.9.65-r1 (30 Jan 2003)
+ 30 Jan 2003; Mark Guertin <gerk@gentoo.org> mol-0.9.65-r1.ebuild :
+ Added patch to close bug # 13136, errors in dhcp-mol.conf. Thanks
+ to Lars Weiler for this bug.
+
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*mol-0.9.65 (20 July 2002)
diff --git a/app-emulation/mol/files/digest-mol-0.9.65-r1 b/app-emulation/mol/files/digest-mol-0.9.65-r1
new file mode 100644
index 000000000000..cac4c1e40380
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.65-r1
@@ -0,0 +1 @@
+MD5 a06972750177b007e0b595b4e6b8de07 mol-0.9.65.tgz 1384272
diff --git a/app-emulation/mol/files/mol-0.9.65_dhcp-fix.diff b/app-emulation/mol/files/mol-0.9.65_dhcp-fix.diff
new file mode 100644
index 000000000000..9a033f0060c1
--- /dev/null
+++ b/app-emulation/mol/files/mol-0.9.65_dhcp-fix.diff
@@ -0,0 +1,13 @@
+--- Doc/config/dhcpd-mol.conf.old 2002-09-04 19:40:38.000000000 -0400
++++ Doc/config/dhcpd-mol.conf 2003-01-30 22:32:05.000000000 -0500
+@@ -55,8 +55,9 @@
+ }
+ subnet 192.168.6.0 netmask 255.255.255.0 {
+ option domain-name-servers 192.168.6.1;
++ ddns-update-style ad-hoc;
+ option routers 192.168.6.1;
+- host mol4 {
++ host mol5 {
+ hardware ethernet 00:00:0D:EA:DB:EE;
+ fixed-address 192.168.6.2;
+ }
diff --git a/app-emulation/mol/mol-0.9.65-r1.ebuild b/app-emulation/mol/mol-0.9.65-r1.ebuild
new file mode 100644
index 000000000000..b0c5f65c03cf
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.65-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.65-r1.ebuild,v 1.1 2003/01/31 03:53:08 gerk Exp $
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="MOL (Mac-on-Linux) is a PPC-only program to run Mac OS X and under natively within Linux"
+SRC_URI="ftp://ftp.nada.kth.se/pub/home/f95-sry/Public/mac-on-linux/${P}.tgz"
+HOMEPAGE="http://www.maconlinux.net/"
+
+DEPEND="virtual/glibc"
+RDEPEND=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="ppc -x86 -sparc -alpha -mips"
+IUSE=""
+
+src_compile() {
+
+ filter-flags -fsigned-char
+ ./configure --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
+ # apply patch for dhcp config fix, closes bug #13136
+ cd ${S}
+ patch -p0 < ${FILESDIR}/mol-0.9.65_dhcp-fix.diff || die "patch failed"
+ emake || die "Failed to compile MOL"
+
+}
+
+src_install() {
+
+ emake DESTDIR=${D} install || die "Failed to install MOL"
+
+ dodoc 0README BUILDING COPYING COPYRIGHT CREDITS Doc/*
+
+}
+
+pkg_postinst() {
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol"
+ einfo "You might want to configure video modes first with molvconfig"
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " www.maconlinux.net"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+}